Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Crystal Reports and ActiveX

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • harrison4411
    replied
    Re: Crystal Reports and ActiveX

    Crystal XI v2 with Alpha v10 also not showing properties for the objects. My OS is Win 7 64 bit. Its strange that I can see the activex but Alph doesn't show the properties, methods. Don't know what else to try.

    Leave a comment:


  • harrison4411
    replied
    Re: Crystal Reports and ActiveX

    Same issue in Alpha Five v10. Crystal Reports XI not working in v9 and v10.

    Leave a comment:


  • Doug Page
    replied
    Re: Crystal Reports and ActiveX

    To complete your tests, you should download Alpha 5 v10 and try Crystal there. If it works, then you know what the solution is. If it doesn't, Alpha will fix it for v10 but I would think you're out of luck with v9.

    Leave a comment:


  • harrison4411
    replied
    Re: Crystal Reports and ActiveX

    I downloaded Crystal XI Release 2 hoping it will work with Alpha Five v9. It didn't solve the problem.

    I have reported this as a bug in v9.

    Thanks for looking into this.

    Harrison

    Leave a comment:


  • Finian Lennon
    replied
    Re: Crystal Reports and ActiveX

    As far as I can see, only one version is available for download in an evaluation version and that's Crystal Reports 2008 V2. I don't have access to any other version.

    Leave a comment:


  • harrison4411
    replied
    Re: Crystal Reports and ActiveX

    Originally posted by Finian Lennon View Post
    Oh and I should mention, I was testing with A5 V10 as I no longer have V9 installed on that machine.
    Thanks for testing. Can you try with version XI instead of version Crystal Reports 8.

    Leave a comment:


  • Finian Lennon
    replied
    Re: Crystal Reports and ActiveX

    Oh and I should mention, I was testing with A5 V10 as I no longer have V9 installed on that machine.

    Leave a comment:


  • Finian Lennon
    replied
    Re: Crystal Reports and ActiveX

    I don't know if this will be much help but ...

    I was curious about the Crystal Reports control and thought I'd take a quick look. Well, as you probably know, it's not a quick install but I downloaded the 30 day evaluation package and installed it.

    Since it's a later version than you are using, it may be comparing apples and oranges, but there are differences. The major ones are that (a) there are (by comparison with your graphic) a couple of additional controls that get installed. (b) For the main controls (Crystal Report Control and Crystal Report View Control) the methods, events, types and constants all display, though I have no way of knowing if the list is complete.

    So, why not try with the later version?

    Leave a comment:


  • harrison4411
    replied
    Re: Crystal Reports and ActiveX

    Anybody have ideas why Crystal XI controls not showing up ?


    FYI, found info to code for viewing

    "The most important task with the Crystal Report Viewer Control is to specify a report and display it at runtime. This is easily handled with the ReportSource property and the ViewReport method.

    Private Sub Form1_Load()

    Dim report As New CrystalReport1

    CRViewer1.ReportSource = report

    CRViewer1.ViewReport

    End Sub

    In this example, assigning the report and displaying it in the Report Viewer is handled when the Form containing the Report Viewer object is loaded into the application. A reference to the report is first obtained in the form of a Report object representing a Crystal Report Designer Component that has been added to the Visual Basic project.

    ReportSource is a property of the Report Viewer's CRViewer object which corresponds directly to the Crystal Report Viewer Control added to the project. In this case, that control has been named CRViewer1. The ReportSource property can accept a report in the form of a Report Object exposed by the Report Designer Component or the Crystal Web Reports Server.

    Finally, the ViewReport method is called. This method has no parameters and has the job simply of displaying the specified report inside the Crystal Report Viewer Control.
    "

    Leave a comment:


  • harrison4411
    replied
    Re: Crystal Reports and ActiveX

    I need to use Crystal not redevelope the reports in Alpha.

    Leave a comment:


  • Keith Hubert
    replied
    Re: Crystal Reports and ActiveX

    Hi Harrison,

    If you can link directly to the data source, why cant you build your report from the linked table?

    Leave a comment:


  • harrison4411
    started a topic Crystal Reports and ActiveX

    Crystal Reports and ActiveX

    I am not able to place an ActiveX Control usint Crystal ActiveX Report Viewer Control 11.0 on my version of Alpha Five v9.

    I can draw a rectangle but no box displays after selecting the Crystal Viewer control.

    I am looking at the OLE Automation Object Browser and selected the Crystal ActiveX Viewer Control 11.0 and selecting the Properties, Methods, Events, Constants, Types all are blank.

    Any ideas how to get them to show up ?

    My OS is Win 7 64bix and Crystal Developer XI. The controls are loaded in default directory:

    C:\Program Files (x86)\Common Files\Business Objects\3.0\crystalreportviewers11\ActiveXControls


    This is my first connection to Crystal Reports. Need to have access to the rpt fiels.... about 45 from legacy system.

    Note: I have Access 2007 loaded and can place the same ActiveX Control on a blank MS Access form.

    Also Can somebody share code and instructions to link a Crystal Report within an Alpha Form/Browse would be helpful.

    Thanks,
    Harrison
    Last edited by harrison4411; 03-15-2010, 03:22 PM.
Working...
X