Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

having trouble child table not saving entries

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • David
    replied
    Re: having trouble child table not saving entries

    Sorry it has taken so long to get back to this.
    The data was entered by the "ticket" form, then I deleted changed dates and name and left some of the data so you could see what I am using.
    The problem started when I would try to change child records in the "Pay" form, I was not able to, so I created an event to zoom to record on the "Ticket" form on double click. I would changed the child record there and save, go back to the "Pay" form and the changes would not show. So I thought I must be doing something wrong with the set.
    I have changed the the field lenght to 6
    I have put alltrim in both ID fields.
    I have re-evaluated rules, updated indexs, and compacted db.
    when I updated indexs I got an error message set not found, then I got a message saying indexs were updated.
    Questions:
    Should I be able to change child records in the "Pay" form, mainly the Quantity_in column?
    Thanks for your help.

    Leave a comment:


  • Tom Cone Jr
    replied
    Re: having trouble child table not saving entries

    David, I think your problem here results from how you entered your sample data. Tell us how you did it.

    If you change your link field from "ID" to alltrim(ID) for both the primary and child tables your set will begin to behave normally. Either the trailing blanks are disrupting things, or you have some invisible characters (print format control codes or something) that you've inadvertantly pasted into your data.

    Leave a comment:


  • David
    replied
    Re: having trouble child table not saving entries

    This is hard to show the problem.
    I have build 2095_3264
    I have deleted mpx files, compacted db, emptied tables, packed tables and now re-entering tickets to see if it happens again.
    I guess the set is set up right?
    In the Pay form on the embedded browse should I be able to change data in the Quantity_in column?
    Also, the direction arrows don't move down in the browse.
    thanks,

    Leave a comment:


  • Tbaker
    replied
    Re: having trouble child table not saving entries

    David

    Just took a look at your zipped tables and from your description of the problem, I don't really understand how to duplicate what you are seeing.

    Please give step by step instructions on how to repeat the problem.

    Also, are you using the latest version of 9 new browse or what version and build are you using?

    Tom Baker

    Leave a comment:


  • David
    replied
    Re: having trouble child table not saving entries

    Thank you Keith. I am going to start over on this one.
    I have another set setup the same way except it has a grandchild table in it and it works fine except for the browse does not allow moving up or down with the direction arrows.
    Thank you for looking.

    Leave a comment:


  • Keith Hubert
    replied
    Re: having trouble child table not saving entries

    Hi David,

    Unfortunately you have many things that need looking at. To start with you have set the Tickethdr->id to C 16 but you have given a simple default of "T00001". If you are going to use the Auto increment then you should use ALL the characters in your default. Therefore, I would recommend that you reduce the field length to 6.

    I cant see what you have done to cause the Header table in the browse to double up the records. I have put a new browse on the form and dont get the same result.

    I have uploaded you app with my changes, not sure if this is what you wanted.

    Leave a comment:


  • David
    started a topic having trouble child table not saving entries

    having trouble child table not saving entries

    I have attached a db with sample data.
    I am having trouble when I enter data through the form "Ticket"
    and then after all tickets are entered, I go to form called "Pay"
    to check off/double check my entries and not all of the child records match the parent records the way they were entered.
    If I try to edit one of entries in the "Pay" form, it will not let me edit or changed any of the entries, mainly the child records.
    I must have the "set" set up wrong. If someone could give me some guidance I would appreciate it.
    thank you,
Working...
X