Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

"Cannot find report" error messages

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Cannot find report" error messages

    Hi all,

    I have produced a report and produced a script that is pretty much code that copies records from a query to another temporary table.

    After it copies the records the button script uses a report layout based off the temporary table. And this is where the problems begin. When I click on the button that executes the script it goes past copying the records to the table but when it produces the report it causes error such as saying that it cannot find the report "tabletemp" . When i go to the report itself it says the same thing too.

    I redid the table title to "temptable" and report title to "temptable". Then the report comes up blank. If need be, I can post but I am a bit lost as to why it will do this.

    Help appreciated.

  • #2
    Re: "Cannot find report" error messages

    Wei-Yen,

    Do not name the report, with the same name as the temp table. You might confuse Alpha.

    Rename one or the other, so they are not the same.

    Then copy your records to the table, and make sure the records are in the table. Then try and print your report. Do this without using your script. To see if you can print knowing that the records are in the table.

    Then if everything is OK, go back and try your script again, it could be a timing issue?

    Ed

    Comment


    • #3
      Re: "Cannot find report" error messages

      Thanks Ed, I will give it a go. And I might put a pause in the script too to alleviate this issue.

      Comment


      • #4
        Re: "Cannot find report" error messages

        I came back and experimented it a bit more. I changed the report name but that did not resolve the issue.

        So I did some more investigating.

        Just some background. I use a script, that uses the copy record operation and it -overwrites- the table if it exists. I think this is where my problem lies because if the table vanishes then the report will vanish too. I just tested this and it and it is the case.

        So my options are to have the -copy- record feature without creating a new table and it will just copy the records into an existing table based on a filter in a form.

        I don't know where to go from here...or how to go about doing this. I would be grateful for any help.

        Comment


        • #5
          Re: "Cannot find report" error messages

          Success!

          What I did was to rework this table somewhat and what this does is to create two tables. One table is to hold the the records from the first query. The second is where the report is based on.

          So the way it works is like this. When the button is pressed, the query is copied to new table (using a converted operation to script). Second, the data of the first table is then 'appended' to a second table. Prior to appending the records I zap the data in the 2nd table. It then runs the report off the second table. So far so good.

          Now I just need to tidy up the report as the format seems to have a bit of issues. Thanks for your help and guidance.

          Comment

          Working...
          X