Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Record(s) not viewable in browse. Corrupted somehow?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Record(s) not viewable in browse. Corrupted somehow?

    Hello,

    I have some records that all of a sudden are not viewable in Browses.

    The browse is based off of a set with a Parent Table, 8 One to one child tables and, 1 one to many child tables. (I had a child link that was the same as the parent link, with a one to many connection but I deleted it because I thought possibly it was causing the problem).

    So basically these records used to show up in this browse normally, but now when I search for them it auto fills in the correct information but will not display the record in the browse. If you go to to the default browse of the table the records are still there.

    Does anyone know what might be causing this so I can fix it? I tried building a whole new browse off the set and still received the same error. Basically whole record lines and all of their information just are not appearing in the browse.

    If a build a browse off off of the parent table only these records appear in this, but off the set is where they are not appearing.

    Please help.

    Thanks,
    Chris

  • #2
    Re: Record(s) not viewable in browse. Corrupted somehow?

    If a child record does not display in a browse on a form built on a set it is because the linking values are not the same in the parent and child records. You need to carefully examine the linking field value in the child table record to see how it differs from the linking field value in the parent record to which you think it should match.
    There can be only one.

    Comment


    • #3
      Re: Record(s) not viewable in browse. Corrupted somehow?

      The record that is not showing is from the parent table, so there is nothing linking them. In the browse I went through and removed and fields that are not in the parent table and they still do not appear. If I search for the same record in the Default Set Form the records appear, only in the browse do they not appear.

      Comment


      • #4
        Re: Record(s) not viewable in browse. Corrupted somehow?

        It's beginning to sound like you have a filter or query in place that is limiting the display of records. Do the "missing" records fail to meet your record selection criteria?

        Comment


        • #5
          Re: Record(s) not viewable in browse. Corrupted somehow?

          No filter or query are in place right now. I have had this issue in the past, and the only resolve was to re-create the entire record with all of it's data and then it would reappear again.

          The weird part is when I do a search it actually starts auto-filling the record that is missing, but once I press enter it will not appear.

          Comment


          • #6
            Re: Record(s) not viewable in browse. Corrupted somehow?

            Ok, then this may result from confusion about what a "record" is in Alpha Five. If you are thinking that each row in your set based browse is a single record you're mistaken. It's more complicated than that. Alpha stores records in tables, not in sets. If you have a set based browse and you begin a new row, but only fill in fields that belong to the child tables of the set, you will confuse Alpha. To do set based data entry you must always and forever populate the parent record first, before beginning data entry into any of the child tables.

            And, for what it's worth, I never do data entry into set based browses.

            -- tom

            Comment


            • #7
              Re: Record(s) not viewable in browse. Corrupted somehow?

              If this is an embedded browse in a form, check the form filter and see if Alpha created a filter there.
              Robin

              Discernment is not needed in things that differ, but in those things that appear to be the same. - Miles Sanford

              Comment


              • #8
                Re: Record(s) not viewable in browse. Corrupted somehow?

                No, it is just a basic browse view. I spoke with Tom Cone on the phone and we could not find a solution. If I find out exactly what is causing the error and/or how to fix it I will post.

                Thanks

                Comment


                • #9
                  Re: Record(s) not viewable in browse. Corrupted somehow?

                  Still trying to decipher exactly why this is happening, but I duplicated the entire table and all indexes, records, layouts, operations and then copied the same browse where error's were occuring to the test duplicate.

                  After doing that the records that were in question (not appearing in a browse) are now appearing in a browse... now I am more stumped than before.

                  My solution for the time being is going to be use the new duplicated table that actually works.

                  Comment


                  • #10
                    Re: Record(s) not viewable in browse. Corrupted somehow?

                    I do have a question. Is there a problem with doing this, because I feel like this is when the problem started.

                    I created a link to a child table within the set, and the child table was actually the Parent Table as well.

                    I linked them with a one to many link based off a character field. I did this because I need to display a one.many link in an email and it was the only way I could figure out how to pull in multiple records.

                    Is this in bad practice to do this?

                    Comment


                    • #11
                      Re: Record(s) not viewable in browse. Corrupted somehow?

                      Is it possible to post an example with anonymised data?
                      1:M using the Parent might cause you some grief, possibly an unresolvable loop. 1:1 should be OK.
                      Have you got V11 trial installed?
                      See our Hybrid Option here;
                      https://hybridapps.example-software.com/


                      There are 3 things you can do in any situation;
                      Live with it, Change it or Walk away from it.

                      Comment


                      • #12
                        Re: Record(s) not viewable in browse. Corrupted somehow?

                        1:M where the child table is actually the parent table sounds to me like a recipe for disaster.....Why would you need to do that anyway? Can't you get the relevant records via a query? I suspect you don't really even need a set....

                        Comment


                        • #13
                          Re: Record(s) not viewable in browse. Corrupted somehow?

                          Have you explored index issues? I Have had this problem occasionally and have found it to be a corrupted index in most cases. Take a look here for an explanation.

                          http://wiki.alphasoftware.com/Databa...rupted%20index

                          Comment


                          • #14
                            Re: Record(s) not viewable in browse. Corrupted somehow?

                            I am pretty sure that creating a child link of the parent table within the set is what caused this disaster. I am going to post a new thread to see if there is a smarter way to send the email I want to send without doing that. Thanks for your replies, sorry for the delay I am just getting back to this issue.

                            Comment

                            Working...
                            X