Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Alpha 5 version 9 run engine not connecting to sql, error 2003? need help urgently:-{

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Alpha 5 version 9 run engine not connecting to sql, error 2003? need help urgently:-{

    Hi there, i look after a website and chat forum and a guy who has now left to live in australia set up our database which 4 of us access on a daily basis to input data or look up data from etc. Its crucial that i get it sorted for everyone and i just dont do databases or mysql, i do websites but i can follow instructions.

    So here goes, we download the software and download the database files then open the database, there are only two and its not overloaded or anything, two of us have gone to connect in the last two days at different times and its coming up with an error and i cant even log into the damn thing, ive spoken to the servers and they say nothing is wrong with the settings, ive looked myself and confirmed that it all looks ok from their end. Also my outgoing email server isnt working?

    Any advice? I have attached a pdf of the database error.

    Bev
    Attached Files

  • #2
    Re: Alpha 5 version 9 run engine not connecting to sql, error 2003? need help urgentl

    Couple of questions.
    Why do download the database?
    Can you email from the PC using Outlook/Windows Live Mail etc.
    Has anything on the server been changed, like the name, or new/upgraded anti Virus been installed?

    It sounds like your connection string has been corrupted.

    In your Control Panel, in the Tables/Sets tab you should see a table with what looks like a green or red chain across it.
    To view the current Link definition, Right Click it, and choose Active (or Passive) Link Table, then Edit Link Definition. DO NOT CHANGE ANYTHING YET!

    If Alpha thinks you are connected, then you have the option to Disconnect.
    If you are not connected, you must Build a Connection String. See below. Note that the Connection Type should be correct as there are several to choose from.

    connection.JPG

    If all else fails, try here, Bev
    http://forums.mysql.com/read.php?34,49742,239961
    See our Hybrid Option here;
    https://hybridapps.example-software.com/


    There are 3 things you can do in any situation;
    Live with it, Change it or Walk away from it.

    Comment


    • #3
      Re: Alpha 5 version 9 run engine not connecting to sql, error 2003? need help urgentl

      Ted thank you very much for your help, i actually understood most of what you said, but when i right clicked on the arrow there werent those options for me and it wouldnt connect to any that was there, i tried the link that you ever so kindly posted and went into the control panel, i dont know much about it but i added my ip in there and i can now access it as normal, phew! Could you please when you have time let me know though do i have to contact my servers again or get everyones ip address from them, easy to do il just send them the website that they click on and get them to email me it, or shall i ask the servers if they have changed anything? i know their control panel has been upgraded and new.

      It says on the link i followed that any host could connect if there is a % which there is, so i dont understand why its corrupt?

      Enclosed a pdf of the control panel settings, thanks again, where would we be without people like yourselves?

      Regards
      Bev :-)))
      Attached Files

      Comment


      • #4
        Re: Alpha 5 version 9 run engine not connecting to sql, error 2003? need help urgentl

        Bev, I'd ask the ISP what has changed.
        If nothing your end had changed then it must be their end. The new control panel suggests that there are more changes behind the scenes.
        Sorry, I don't know enough about the hosting side to be able to help. Maybe someone will chip in who knows more.
        At least one of you is up and running!
        See our Hybrid Option here;
        https://hybridapps.example-software.com/


        There are 3 things you can do in any situation;
        Live with it, Change it or Walk away from it.

        Comment


        • #5
          Re: Alpha 5 version 9 run engine not connecting to sql, error 2003? need help urgentl

          All I can chip in is when one of my host providers changed the "cpanel" to a different version, it flat messed up my websites on that host. I am sure they changed other stuff at the same time. I really had to climb their butts to get it resolved. Being my own IT, I knew that nothing on my end had changed, so it made things more clear.

          Good Luck.
          Dave Mason
          [email protected]
          Skype is dave.mason46

          Comment


          • #6
            Re: Alpha 5 version 9 run engine not connecting to sql, error 2003? need help urgentl

            Thanks Ted/Dave

            ive emailed the isp and surprise surprise they havent got back, good news is i put two other ip addresses on and they can now get access. I will just do this, im sure its down to them but initially without your help looked through everything and darent change anything. The control panel is different so they have probably updated everything, the database started not saving data last week so hopefully it will be ok now they have finished their upgrades!

            Dont suppose you know how to add an extra field of block text in the tables do you, looked everywhere, cant see what to do to add one.

            Bev x

            Comment


            • #7
              Re: Alpha 5 version 9 run engine not connecting to sql, error 2003? need help urgentl

              Adding a field means you need the development version if Alpha.
              If your database is DBF, you can add a memo field which gives unlimited text. You need to be able to show the new field on a form. If the back end is SQL you may need admin rights on the server or know how to change the tables and upload.
              Suggest you contact someone in the WAS forum. Send them a private message. Pick someone with lots of posts.
              Can you post more details of the installation?
              See our Hybrid Option here;
              https://hybridapps.example-software.com/


              There are 3 things you can do in any situation;
              Live with it, Change it or Walk away from it.

              Comment


              • #8
                Re: Alpha 5 version 9 run engine not connecting to sql, error 2003? need help urgentl

                Hi Ted and thanks again, yes it is dbf and back end is sql so i will have a look in the forum next week when i have more time, im trying to back it up but when i export to excel it doesnt save the text block column?

                Also ive tried everything to get the main person of staff who uses the database to connect, the servers say their end is fine and they sent me a link to test the connection with and it all came up ok, ive let the alpha through the firewall, rang aol who said nothing has changed from them, system restored to two weeks ago and its still coming up with the same error. Think i will just wait until she gets a new pc in the next few weeks and do all her work until then.

                Thanks again
                Bev :-)

                Comment

                Working...
                X