Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook



The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic

Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.

If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.

Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.

Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Access Denied when Editing Structure of a table

  • Filter
  • Time
  • Show
Clear All
new posts

  • Access Denied when Editing Structure of a table

    Good Afternoon,

    Every time I try to restructure a table, when I click save I get an error message "Access is denied"

    The data is stored on a Mapped Network Drive that my user has Full Access to (less taking ownership or changing permissions)
    I do not have any tables names $$052200.dbf.

    I tried creating a whole new table, saving it, and then trying to edit the structure with the same error.
    I tried duplicating the table with a new name, with the same error.
    I tried Rebooting, and using a different computer with the same error.

    Alpha4v9 Developer Version

    Any thoughts?
    (I wasn't able to find anything in the forums or wiki)

  • #2
    Re: Access Denied when Editing Structure of a table

    what version(s) of windows is the first thought?? Also, are there memo files involved with the table??
    the $$052200.dbf looks like some type of file created when the error occurred.

    Generally, you cannot edit table structure when the table is open and that includes when forms and such have it open.

    Have you compacted the database at server level?? Are there queries(or other) run that did not close the table??

    When you do a compact, open tables will show up every time. You won't be able to compact them.
    Dave Mason
    [email protected]
    Skype is dave.mason46


    • #3
      Re: Access Denied when Editing Structure of a table

      On top of what Dave has said - try look for and delete if exists the $$052200 file - this is how temp files are named, it could be a temp table remnant from a table re-structure that didnt complete.


      • #4
        Re: Access Denied when Editing Structure of a table

        I have tried this on 2 different computers running: Windows 2000 Professional SP4, and Windows 7 Home Premium SP1.
        Both computers got the same error.

        Each subsequent attempt to edit the structure of the table on any computer gives a different "temporary filename" (the $$052200.dbf file)

        After trying to edit an existing table (which did not have any memo fields) with no luck I created a new table, putting only character fields in it, and saving it. I then tried to edit the structure imeadiatly after saving (without opening any forms or adding any rows to the table) and got the same message. The new "test" table I created did not have any forms or queries attached to it. I made sure there were no other users on the system when I was editing the table, and no forms open on my system.

        I compacted the database and tried again with the same result.

        I went to the folder the files are in, and was unable to find the file mentioned. I made sure that hidden files were visible. There were some .MDX files that has a similar name (starting with $$) but no files at all $$******.dbf

        The files are on a mapped network drive, that is on a CentOS server running Samba4 as a PDC. All users have the same network share mapped to the N: to access the files. The NTFS permissions on the folder allow all users Full Control (less changing permissions and file ownership). Users can create, delete, and modify files without any issue.


        • #5
          Re: Access Denied when Editing Structure of a table

          Check your temp folders %temp% and %tmp%. The offending file might be lurking there.

          On Windows 8 and Windows 7 it is C:\Users\%profilename%\AppData\Local\Temp
          On Windows XP it is C:\Document and Settings\%profilename%\Local Settings\Temp

          Not sure on Windows 2000 but would imagine it to be similar to Windows XP.

          I had a similar error message after I changed domains on my workstation. I couldn't figure it out and had other issues related to corruption that I re-installed the OS. Re-installing was faster than trying to resolve the issues I was having.


          • #6
            Re: Access Denied when Editing Structure of a table

            If no help with above, you may have a bad alpha install. Can you re-download alpha and install it? your installation could be flawed is some way.
            a brand new table with that kind of problem indicates a problem not having to do with files left open.
            There is one other, what antivirus are you using?
            Dave Mason
            [email protected]
            Skype is dave.mason46


            • #7
              Re: Access Denied when Editing Structure of a table


              After a lot of frustration I finally solved the issue. The files were saved on our CentOS server, and we were connecting to them using Samba4 with a mapped network drive.

              When I compared our setup to a colleague's system I discovered the following:
              in the /etc/fstab

              The Alpha5 HDD (/dev/sdd1) was mounted with defaults,acl,user_xattr 00 attributes,
              /dev/sdd1 /Alpha5 ext4 defaults,acl,user_xattr 0 0

              when I removed the extended user attributes (user_xattr) and changed the dump pass number, unmounted/remounted the drive, and restarted Samba4 the issue was resolved.
              /dev/sdd1 /Alpha5 ext4 defaults,acl 0 2

              The NTFS file permissions were sufficient, but the underlying PAM permissions were set in a way which cause a conflict with Alpha5

              Thanks for all the suggestions and help.


              • #8
                Re: Access Denied when Editing Structure of a table

                Glad you got it and thanks for posting here for others that may go through this.
                Dave Mason
                [email protected]
                Skype is dave.mason46