Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook



The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic

Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.

If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.

Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.

Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Something is wrong

  • Filter
  • Time
  • Show
Clear All
new posts

  • Something is wrong

    Hey Folks
    I haven;t had to use this board in over 2 years because everything has been running fine here..Until today..
    In one days time I have received calls from several people in out plant saying the database is acting funny.
    I can't explain what is happening so I figured I ask the pro's
    Seems as though the database is getting re written..
    I am missing forms, Browse's, field rules...Buttons are not working on some forms..
    I have been rewriting the database all day...I have replaced the missings forms and browes and fixed the field rules in several tables but everytime I do it, an hour later something else pops up in another table where something has gone wrong..
    There is only one computer in the building that has access to modify the database and I know no one has played with it or even know how to rewrite anything.
    I could understand if there was just some corrupt or missing data but I'm missing so many other things..All the data appears to be fine except in one table that I sometimes have trouble with..All tables pack and update their field rules without problem.
    What could be the problem on the server?
    Could something be deleting files off the server?
    Why would buttons that have always worked suddenly not function and give errors?
    I'm lost ...HELP

  • #2
    RE: Something is wrong

    Poor Ken,

    Accept my sympathies.

    Are you absolutely certain that nothing has been done to the server, no other software or printer drivers or anything done to it? Totally certain.

    Is there a possibility of vandalism? What is your security like?

    Can the server itself be failing?

    Does your application employ network optimization? IF so, have you made changes to the shadow on your local station or on the server. After you make a change do you see it and does it work for a while.

    Have you compacted the database?

    How many users are there?

    Bill Hanigsberg


    • #3
      RE: Something is wrong


      Check and update your anti-virus software, too.

      -- tom


      • #4
        RE: Something is wrong

        You have heard it before - backup. ddd/ddm/ddx/set/sem/set should be archived and redundent backups saved. esp. if you don't change your app for two years.
        AlphaBase Solutions, LLC

        [email protected]


        • #5
          RE: Something is wrong


          Can you say exactly what those errors were from the database?

          It sounds like the easiest thing to do is to go back and find some earlier copy of your software if you can. Make a good copy of this on another hard drive or known good floppies before going any further. I'd also suggest making a data backup of your DBF files too. You may be able to copy the older data dictionary files over your current corrupted files to restore the database if you have them.

          I'd be concerned with such a reliable database that either an internal index is corrupted or the hard drive may be failing. Try running a Scan Disk in Windows to see if this finds anything wrong. Also set Scan Disk to the lowest level where it test reads the hard drive to see if the drive is fully functional. This may take some time to run. If the database has been notably slow, missed reads may be the problem.

          If this test is a success, the other cause could be that the internal indexes for the application have become corrupted. Try running a Database Compact command to see if this calms down the bad behavior of the database or stops it from getting worse. The application objects can get corrupted by errant overwrites opf the binary portions.

          Other more rare but possible problems would be some miminally bad RAM or a corrupted OS copy. You would be having problems with other programs too if this were the case. Computers after about 4 to 6 years can get gimpy due to corrosion getting under the board and memory contacts.

          After you find or fix the main problem its then time to restore or rewrite the lost application objects.



          • #6
            RE: Something is wrong

            Hey Guys..
            Thanks for the info..
            The problems on the database seem to only be the loss of my forms,browses, and field rules.. There seems to be no problems with the data in any table or loss of it.
            The virus software on the server is updated daily.
            As far as useres on the server their are about 15 people on it during the day.
            There are a total of about 20 or so tables in the database itself and the problems are popping up on most of them.
            I just received word this morning that there is another form missing and some lookup tables are not functioning.
            I have been replacing the forms with backup copies I had from about a month ago. Seems the women in charge of the backups has not been doing the regularly..
            When I replace the missing forms I also have to rewrite the field rules..
            This problem is somewhat a mystery to me...
            At first I thought it was a fluke..Then I started thinking someone was deleting files on me..But how would anyone know what to delete without disturbing the data??
            I'm not a server guy by any means but is there a way to find out if someone deleted files from the server?
            Also I don't believe the problem to be with corruption of the database. When I notice something is not working correctly I open the control panel up and look for the table and then the form or browse view. If the control panel shows no form or browse with the correct name I assume it is missing in action, So i replace it with a backup. I will be going through the entire database today to fix all the problems I have a list of as of right now.
            I just hope once i get things working again that it won't keep happening.
            Additionally, I do have one table that will not compact.
            I have had problems with this table before..LAst year to be exact..I had a bunch of memo fields in the table and they became corrupt easily. I re-worked the table and replaced the memo fields with long charector fields which seemed to fix the problem but it is back again..when compact or pack is run on this table it gives the error of unable to write order.$$$ ( order is the name of the table)when the file already exist.. At least that is what I remember it saying. I have tried working on a backup copy of the database and deleting the order.$$$ file but when I run pack or compact again it will hang up the computer at about 80% complete.
            Also the problems I'm having with the database forms and such are not linked to the order table in any way. In fact I have had no loss what so ever ( forms, browse, or field rules)with regard to that table.
            Any other ideas???


            • #7
              RE: Something is wrong


              Has the server software been updated and could the pointers to the directorys have changed as a result so Alpha can no longer find the correct folder?

              Just a thought?

              Glen Schild

              My Blog


              • #8
                RE: Something is wrong


                Your form layouts, your report layouts, and your field rules are stored in the dictionary files for the tables or sets upon which they are based. These are the files in your database folder that have extensions other than DBF, CDX, ADB, and FPT. If you compare the file list in the database folder on your server with the file list in your development folder they should match. Missing files would indicate that some process (or person) on the server is deleting files. If the files are present but Alpha Five is not showing the forms when the database is run, it's likely the dictionary files have been corrupted. -- tom


                • #9
                  RE: Something is wrong

                  To echo Tom somewhat. If you have backups of your ddd/ddm/ddx/set/sem/set files, then there is no need to "rebuild" field rules or forms, etc. Just copy those backup files to your siurce directory.
                  AlphaBase Solutions, LLC

                  [email protected]


                  • #10
                    RE: Something is wrong

                    Use windows explorer and go to the folder which your applications resides. look at the files. sometimes a files corrupts and is closed as another file with nonsensical file name or extension. ie myfile.ddx , ^7myfile.ddx and myfile.#$5. delete the strange file and see what happens.

                    i would also close and delete all shadows and reoptimize on every station and the server

                    Good Luck


                    • #11
                      RE: Something is wrong

                      OK Guys
                      I went through the database and repaired all the damage I could find. Had to reload 5 more forms and 3 browses.
                      The only thing I noticed different from the server databse and my backup copy is that some of the DDD, DDX, DDM files on the server have both lower and upper case letter extensions where as the backup has all uppercase extensions.
                      Example. Server file shows order.Ddx and the backup shows Order.DDX
                      This is only the case with some of the tables and not all..
                      Is it possible that something here is case sensitive???
                      These problems were all noticed in the morning and were not noticed the night before. The only thing going on at night is a tape backup of the server..

                      My last question would be..How do I fix the one table that will not pack and gives me the error that it cannot save the file order.$$m if it already exist???
                      As mentioned earlier the last time I had this problem was because of memo fields in the table. Those memo fields were changed to charector fields some time ago. Did I perhaps forget to delete a file that held these fields and that is causing the problems??
                      I have checked thru the data and found no garbled fields.


                      • #12
                        RE: Something is wrong


                        I had this problem once. The fpt file had gotten huge due to some unknown corruption and the compact basically froze at that table. Because of its size and the relative amount of free space on the hard drive it was unable to rebuild the fpt file. I copied everything to a much larger drive, compacted there, then copied everything back. Fixed.

                        By the way, how much free space is on your server drive? At lease 2x the size of the largest file associated with your database? Some space can be recovered if you have any files with an extension beginning with $$. You can just delete them. Depending on your server security setup, you may have to empty the recycle bin before that space is truly released.

                        Hope this helps.


                        • #13
                          RE: Something is wrong

                          Hmmm. Interesting...
                          If I have no memo fields in the table do I still need the ftp file?
                          I Know there is one file on there that is huge..about 65 megs or so...I don't remember if it was the ftp file or the $$m file.
                          Drive space on the server is more then enough for the job to answer that question..
                          Where would I look to see what file extension does what?
                          It is possible that when I changed the memo fields ( I had 7 of them in there)it left behind a file that I no longer needed.
                          When I had this problem last year much of the data in the memo fields was corrupt. It would not even let me delete the records that were corrupt. I had to go and change all the memo fields to charector fields. I should have made it that way in the first place but the plant manager wanted memo fields..
                          Any ideas??


                          • #14
                            RE: Something is wrong

                            If I remember right the $$m file is a special temp file which is left over when a compact aborts. I would think you could delete it. But I venture it will be created the next time you attempt to compact and are unsuccessful.

                            I don't see how a bad memo file can explain all your problems but it does explain why you cannot compact.

                            Bill Hanigsberg


                            • #15
                              RE: Something is wrong

                              Hey Bill
                              The memo fields did not cause all the problems I stated here first. It is only another problem I have on one table.
                              I have tried to delete the $$m file and re-run compact but it hangs my computer up at about 80% complete...