Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

scrambled field data in table

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • scrambled field data in table

    This morning, I have noticed that the default browse as well as any custom browse is showing the job name (35 character field) in the job number field (6 charater field). The job name data is correct, but the job number is gone from 98% of the records and is replaced with the Job name. When I go to the edit mode for the table, the definition for the two fields is okay. This is occurring on the forms as well.

    The shadow database does not appear to be affected yet. When I go to enter a new item, the job name shows up in the field.

    Any ideas on what has happened?

    Larry

  • #2
    RE: scrambled field data in table

    Larry, the symptoms you describe might be caused by incomplete attempts to change the table structure. Is this a table you've using your copy and paste approach to restructuring? Suggest you reboot the computer, restart Alpha Five, and inspect the tables with the default browse and form.

    -- tom

    Comment


    • #3
      RE: scrambled field data in table

      Tom, I have rebooted the computer several times and still no difference. The cut and paste was for adding info to a field and not for structure changes.

      I have not done any structure changes to this table.

      Larry

      Comment


      • #4
        RE: scrambled field data in table

        Larry:

        Here are 2 other reasons why did could have happened from what I know of another database engine.

        [1] The table may be encrypted and got corrupted
        [2] The records did not write to the hard drive from cache and there may have been some network crash

        In any event, seems like you will have to replace the records from a latest backup

        HTH
        Mickey
        Mickey Shekdar

        Comment


        • #5
          RE: scrambled field data in table

          Well it happened again. This time I got an error message when I tried to add a new record.

          "cannot create lookup
          lookup definition incomplete or invalid
          could not load that saved layout"

          I went into the lookup and could not see anything that was missing or out of place.

          When I went to look at my database, The 6 charater job number field now had the job name in it. I found that if I remnoved the first posting item from the lookup ,which was posting the job name, this cleared up the data problem. I have since added the job name posting to the bottom of the 2 other posting items and it seems to be working.

          Larry

          Comment


          • #6
            RE: scrambled field data in table

            Are you perhaps using a custom form to display lookup table records?

            -- tom

            Comment


            • #7
              RE: scrambled field data in table

              Tom, I don't quite understand what you are asking.
              I have a custom form that has a drop down list that I select the job number from and this posts the job number and name to the new record. This has worked for the past couple of years and I do not belive that I have edited the table for some time. What I find very puzzling is how a 6 character field can end up with 35 or more characters.

              Larry

              Comment


              • #8
                RE: scrambled field data in table

                Larry,

                It seems you've found a solution, of sorts.

                A search for related threads in this forum and over in the A5V5 forum turned up a small number of hits, including one from several years ago in which the spelling of the lookup tablename seemed to be the culprit.

                If you have problems again I'd try:

                a) using the "default" browse to display the lookup table's choices; and
                b) if your lookup tablename includes blank spaces or underscore characters I'd rename it to remove them.

                If either suggestion solves the problem I'd recommend further that you report it to Alpha, sending them a working copy of your database so they can get it fixed.

                -- tom

                Comment


                • #9
                  RE: scrambled field data in table

                  Hi Tom
                  A) I am using the default browse for the lookups. I did not know theat you could use a browse other than the default.

                  B) Just about all of my tables have one or two spaces in the name. I was not aware that there could be issues with spaces. I check the Alphasports database and I noiced that their table names have spaces, underscores and dashes in them.

                  Larry

                  Comment


                  • #10
                    Strange but true, it happened again to a different table. The Company name (40 characters) is now in the company id (8 characters) spot. Many other items were scrambled in this database about a week ago. I fixed all the items that I could find (phone # masks, transformations etc.) and now I see this field is mixed up. Some of the items for this table are from a table lookup.
                    Anyone else experiencing this?

                    Comment


                    • #11
                      Hopefully, we won't experience this. But the only way we can all look at the problem if is you zip it up and send it.

                      The issue of 35 characters in a field only 6 big (or 40 into 8) is probably part of the problem. And very strange that it should happen twice.

                      Comment


                      • #12
                        Strange but true, it happened again to a different table.
                        Larry, I'm sorry to hear it. Don't have specific suggestions for you but here are a couple of more things to consider:

                        a) you use copy / paste to enter field values into new records, if I'm remembering this correctly. This is something I never do. I wonder if the problem goes away if you stop? An alternative would be to script the entry of the new record so that an entire record is copied & pasted. You could then edit the newly entered record by hand.

                        b) does the corruption of your table occur after any batch operation? an update? import? or append?

                        c) you mention (in your first post in this thread) that the "shadow database" is still ok. This is puzzling to me. There should be no data in the shadow copy of any of the tables in your database. I'm curious how you have arranged your tables. Assuming the data is on a machine you've designated as the file server for your network, you should see the same data in any given table whether you open that table directly (over the network), or whether you open the shadow copy of that table on your local workstation.

                        -- tom

                        Comment


                        • #13
                          I noticed that if I removed the lookup, the data in the 8 character Company ID field appears to be okay. I entered the Lookup info into the field rules and the problem came back.
                          The 40 character Company Name field was a display only and in my last programming of the entries for the lookup, it was the last field on the lookup table. I moved this up to the first entry and it seemed to be okay for the rest of the day.

                          Comment


                          • #14
                            Tom, you have a good memory regarding my copy/paste habit. In this table I do not use copy and paste. The copy and paste has not created a problem for the tables where I use it.

                            B) no, I don't use any of these features

                            C) I did check the data from a network machine and it was fine. As mentioned in a previous post today, it does not appear that the field data is corrupt, only the fact that the wrong field is being displayed in the server machine. When the lookup was removed, the field data appeared normal again. My understanding of the shadow is that it only contains reports and forms and such but the data is actually on the server and that is the way that our system is setup.
                            Prior to the problem, I had been correcting the scrambled field info such as the masks and transformations so perhaps I needed to compact more often, although the number of field changes made was only about 6. One thing that I have not been doing is packing the tables. Whether or not this has any effect I don't know, but they are all packed now.

                            Comment


                            • #15
                              Perhaps you're defining the lookup incorrectly?
                              Perhaps you're doing something unusual like using the table lookup field rule to lookup records in the current table?

                              It's probably time for you to post a working model that illustrates the problem, and tell us how to see it occur.

                              -- tom

                              Comment

                              Working...
                              X