Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook



The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic

Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.

If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.

Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.

Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Printer not activated, error code -30

  • Filter
  • Time
  • Show
Clear All
new posts

  • Printer not activated, error code -30


    Does any one have any idea how to fix this!!!
    Every time I think I have found a work around, It pops up again!
    Is it a problem with A5 or with the Amyuni PDF driver, I have emailed them and am awaiting a reply.

    Its driving me nuts, I just need to dump a report out as a PDF and its proving imposable.

    Have Alpha recognized it as a prob, or is it one of those obscure things that only a few of us have come across.

    Hate to say it, but V7 is proving to be one of the least pleasant versions of A5 I have ever used!
    Chris Tanti
    Technical Support

    Nuance & Fathom Ltd - The data-driven marketing agency

  • #2
    What *exactly* are you doing when you receive this message?
    Aaron Brown
    Alpha Software Development Team


    • #3

      Just Generating a very simple report.

      Well its a procedure I have done many times, but taking it from the top
      A button on a form, with an "On Push" event
      Event created with the Genie
      Save Layout to a file
      On the options tab of this, I choose Adobe acrobat as the type, I give it a file name, and I have open with an associated application ticked.
      There is a filter, that consists of
      del_flag=.f. (I have tried it with no filter at all, no difference)

      The report is based on a 1 to 1 set.
      I have managed to print it directly to a printer fine, but It will NOT preview or save as a file.
      Chris Tanti
      Technical Support

      Nuance & Fathom Ltd - The data-driven marketing agency


      • #4

        FWIW I have no trouble doing this with AlphaSports and the Customer List report using Build 4017_3022. You might verify that you can do it correctly with Alpha Sports. That would narrow the range to troubleshoot to your report.

        BTW, in your report layout have you embedded the name of an unavailable printer?

        -- tom


        • #5
          Hi Tom,

          Here is a few scenarios,

          I have old apps working nicely in A5v5 that have reports that either do or don't work in A5v7 (because of the -30 error).

          I have created new apps exclusively in A5v7, and sometimes the reports created are fine, other times they generate the -30 error.

          On this occasion I created a bunch of reports in v7, 2 out of the 5 reports generate the error. Opening the same application in v5, and the reports run fine and save the pdf output file.

          Its irritating! I love Alpha, but I think Im gonna need a councilor soon:( !!
          Chris Tanti
          Technical Support

          Nuance & Fathom Ltd - The data-driven marketing agency


          • #6
            BTW, tried creating a button on the Alphasports App and it worked fine.
            Not sure what that means, when you consider that two version of A5 are reacting differently.

            Also, tried this on a Win XP machine, and a Win 2003 server, same error.
            Chris Tanti
            Technical Support

            Nuance & Fathom Ltd - The data-driven marketing agency


            • #7
              So, only this one report has the problem? If so, can you please send me the table/set the report is based on?
              Aaron Brown
              Alpha Software Development Team


              • #8

                The print driver for the "File Save As" feature in Alpha Five comes from a 3rd party source. The driver in A5v7 is an upgraded version and of course is different from the driver A5v5 uses.

                When A5v7 installs correctly, you should wind up with an "Alpha Five Printer" listed in your printers folder of the Windows control panel. I'm sure it's there, otherwise none of your PDF's would be created using A5v7, but you might want to check it.

                This thread seems to be discussing a different issue, involving reports that include objects where the designer has specified a percentage "fill" style, instead of "solid" in order to achieve a particular effect. Since some of your reports work and others don't I thought I'd mention it in case you're also not using "solid fill" on all objects. Here's the thread:

                -- tom


                • #9
                  Printer Activation error -30

                  Hi Tom and Aaron,

                  Thanks for your help so far.

                  Printer drivers are all installed OK, sometimes it works sometimes it doesnt, and have tried it on multiple PC's.

                  Have removed and reinstalled the software also.

                  I will check out the thread you mentioned, I havent used any shaded boxes as such on the report, but I did use text set to 80% grey, perhaps I should try changing it all to Arial Black (its Trebuchet 80% at the moment)

                  I am attaching a test for you, dumped the entire data set down (3.6mb zipped) and cleaned out the names etc. There is a test form with a button that creates a pdf file.

                  I have also included the pdf report to show you what it should look like.

                  I created the PDF in A5V5, the button works fine in that version! and shows that whateve is happening, it can't be a simple logic issue with the report (I know the two versions use different PDF creation drivers)

                  Hope this helps, I would love to nail this!
                  Chris Tanti
                  Technical Support

                  Nuance & Fathom Ltd - The data-driven marketing agency


                  • #10
                    Printer Not Activated, Error code -30

                    This is the reply I had from the amyuni, not much help unfortunatly, but atleast they recognised the "-30" error. A5v7 must be recognised by the driver as it works some of the time!



                    The version of the PDF Converter installed on your system is a special developer's version of our product which has been configured to function only within the software package which installed it. In your situation, it looks like the PDF Converter was bundled with software package from Alphasoftware.

                    This developer version of our product is not designed to function as general PDF printer driver and offers little to no printer configuration options. If you try to print to the PDF Converter from an application other then the one which installed it, the PDF Converter will generate a "Printer Not Activated, Error code -30" warning message.

                    If you wish to print from any installed application we suggest that you purchase a license for Amyuni PDF Converter Single User edition.

                    Since you are a licensed user of a product that uses our component we can however offer a $20 price reduction applicable to the Single User Edition of the PDF Converter.

                    You can purchase this product online from the link below or if you wish further pricing information, I suggest that you contact our sales department


                    Hope this helps?
                    Chris Tanti
                    Technical Support

                    Nuance & Fathom Ltd - The data-driven marketing agency


                    • #11
                      Chris, a couple of quick things jump out at me.

                      1) All of your objects in your report layout use a fill style of "transparent". The PDF driver with A5v7 has had big problems when the fill style is not "solid". Check the properties of your field objects, by examining the Border tab of each.

                      2) Your layout defines a group break on a field that is empty in over 20,000 records. I don't know that YEAR(Your_Date_Field) is reliable as a group break expression if the "Your_date_field" value is null.

                      3) The field your script uses to initially filter the table also contains a huge number of empty fields. In this case it may not be significant because the field is logical, and I think (?) Alpha will evaluate a null logical as false... but I don't know for sure. Instead of del_flag = .f., I'd probably do del_flag <> .T., since a huge number of your records have empty del_flag fields.

                      If it were me:

                      a) I'd change the fill style for all objects in the layout
                      b) I'd populate all empty fields in columns used to filter or group the output.

                      If necessary, I'd copy the desired records to a temp table and base the report on that.

                      -- tom


                      • #12
                        Chris, my ideas didn't pan out. Changing the fill style property, and using only records with non-blank LastContact fields didn't help. Sorry.

                        -- tom


                        • #13
                          Thanks for looking tom,

                          I take it that you had exactly the same result when you tried to run the report? If yes, thats a relief in some ways, as I was convinced I had some kind of issue with our set ups down here (another printer driver interfering in some way etc)

                          I take on board your suggestions , and will try some combinations, but have to admit that the report in question really is pretty basic, its a large data set, but hardly the biggest I have worked with, and the report doesnt use anything I would call out of the ordinary, A5 never used to be so fussy in its code combinations (that was a strength as well as a weakness as you can hit a problem from many angles and get the same result).

                          I have come across other issues with methods that previously worked fine in v5 and now bomb in v7.

                          As it stands I have an application that can only fully be run in v5, after purchasing a 20 user licence for v6 (and barely using it), and then jumping to v7 a few months back with the same number of licences, its a little bit of an issue to me and our department!
                          Chris Tanti
                          Technical Support

                          Nuance & Fathom Ltd - The data-driven marketing agency


                          • #14

                            I hope you'll report the issues you are hitting so the r & d folks at Alpha Software will be apprised. If you submit an example database, with instructions for them to follow to see the problem, you'll significantly increase the prospects for getting a fix released in a patch. This takes a bit of work, but helps everyone.

                            In this particular case the upgraded PDF driver may be the issue. If so, there's little that Alpha may be able to do. The work around I'd use in that event would be to preprocess the report totals using a script and then dump them to a temporary table for reporting. It's also possible that there's some sort of obscure timing issue going on. Your report requires significant preprocessing. Perhaps that work is still going on when Alpha Five tries to dump the results to the PDF driver? This is a guess but if Alpha tries to call the PDF driver to render the report prematurely, I can imagine an error would be thrown. It might also account for why it works sometimes and not others. i.e. if less preprocessing is needed, perhaps the timing isn't thrown off.

                            -- tom


                            • #15

                              That sounds very logical, may be the reason its happening only sometimes is that smaller data sets or reports with less pre calcing don't give A5 and the printer driver as much chance to miss synch.

                              I am going to try the same process with a drastically reduced data set, and also create a calculated year field in the table, and group/count that, rather than use a soft calc field in the report.

                              Not exactly clean, but if it works, it will offer me a work around that I am pretty desperate for at the moment.

                              As far as presenting it to tech support, do I have to do anything different?
                              Have included the zip file in the forum, should I email it or put it in a different forum section.

                              I know that Aaron has replied to me, so I hope he has picked up the thread in some way.
                              Chris Tanti
                              Technical Support

                              Nuance & Fathom Ltd - The data-driven marketing agency