Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Query Problem on tabbed form

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Query Problem on tabbed form

    Hi All abd thanks in advance,

    I have a no-tabbed form and a Tabbed form that does the same script with different results.

    Code:
    tbl=table.current()
     query.description = "Order Customers"
     query.order = "acct"
     query.filter = "scode=var->scode.and.status='O'"  'O means ordered
     query.options = "N"
     tbl.query_create()
     parent.fetch_last()
     topparent.Resynch()
     topparent.Refresh_Layout()
    on the non-tabbed form it works great whether there is an order outstanding or not.

    On the tabbed form(button is not on a tab and the same code is also in a drop down) it hangs alpha if no record exists that has an O in status field.

    I have several buttons on the forms with similar code that I am sure would also hang alpha if there was no records present.

    Not sure what to do to correct this. Any ideas would be helpful.

    DaveM
    Dave Mason
    dave@aldadesktop.com
    Skype is dave.mason46

  • #2
    Re: Query Problem on tabbed form

    Hi Dave,

    Perhaps you could try adding a count to your query with an if statement, if count=0 then end or display a message, else continue with script.
    Cheryl
    #1 Designs By Pagecrazy
    http://pagecrazy.com/

    Comment


    • #3
      Re: Query Problem on tabbed form

      Dave,

      In have run into more than one issue with browses and tabbed forms when a query is empty. I therefore have gone to almost always, when tabbed forms and browses are involved precede the query with a probe of the table with the same filter as the query using exist(), dbcount() if indexed, but most often A5_get_records_in_query(), and if .f. or zero records returned, I fire a message and skip the query script entirely.
      Mike W
      __________________________
      "I rebel in at least small things to express to the world that I have not completely surrendered"

      Comment


      • #4
        Re: Query Problem on tabbed form

        Dave, I try hard to never mix form level (GUI) code with other code that's manipulating the table beneath the form.

        Here, without touching the GUI you run a query against the table underneath the form. You then do:

        Code:
        parent.fetch_last()
        This concerns me because this tells the form (the GUI) to fetch the last record but the GUI hasn't been resynched and the form doesn't know you've run the query. This disconnect occurs because you're mixing code. If your script is talking directly to the table beneath the form I recommend you finish your processing and then resynch the form. Don't switch in midscript to try to finish the processing using GUI level commands.

        First suggestion here would be to change this to:

        Code:
        tbl.fetch_last()
        This would move the record pointer beneath the form without touching the GUI.

        Comment


        • #5
          Re: Query Problem on tabbed form

          I have revised the code and am showing how I did it. Thanks to Cheryl and mike for the help.

          Code:
          dim dopath as c
          dopath = a5.Get_Exe_Path()
          vmenuitems = <<%a%
          Active Customers
          Sold Customers
          Sold Customers by Last Name
          Sold Businesses
          Ordered Vehicles
          Dead Deals
          Special Sorting
          Find Text in field
          %a%
          a_command = ui_popup_menu(vmenuitems)
          select case
          '=====================================================================================================
          case a_command = "Active Customers"
           'dim tbl as P
           'tbl = table.current()
           'indx = tbl.index_tag_add("xx", "date", "scode=var->scode.and.status='D'", "A")
           dim shared numbs as n
           numbs = A5_get_records_in_query("names","scode=var->scode.and.status='A'")
           if numbs <= 0 then
            ui_msg_box("None Found","There are no Order Units Found")
            goto end
           end if 
           tbl=table.current()
           query.description = "Active"
           query.order = "date"
           query.filter = "scode=var->scode.and.status='A'"
           query.options = "N"
           tbl.query_create()
           parent.fetch_last()
           topparent.Resynch()
           topparent.Refresh_Layout()
          '=====================================================================================================
          case a_command = "Sold Customers"
           dim shared numbs as n
           numbs = A5_get_records_in_query("names","scode=var->scode.and.status='S'")
           if numbs <= 0 then
            ui_msg_box("None Found","There are no Sold Units Found")
            goto end
           end if 
           tbl=table.current()
           query.description = "Sold"
           query.order = "date"
           query.filter = "scode=var->scode.and.status='S'"
           query.options = "N"
           tbl.query_create()
           parent.fetch_last()
           topparent.Resynch()
           topparent.Refresh_Layout()
          '=====================================================================================================
          case a_command = "Sold Customers by Last Name"
           dim shared numbs as n
           numbs = A5_get_records_in_query("names","scode=var->scode.and.status='S'")
           if numbs <= 0 then
            ui_msg_box("None Found","There are no Sold Units Found")
            goto end
           end if 
           tbl=table.current()
           query.description = "Sold Customers"
           query.order = "buyer"
           query.filter = "scode=var->scode.and.status='S'"
           query.options = "N"
           tbl.query_create()
           topparent.Resynch()
           topparent.Refresh_Layout()
          I did not include the whole code but there is an end: at the bottom.
          I will incorporate the changes Tom suggested tomorrow, but it works fine now.

          Dave Mason
          Dave Mason
          dave@aldadesktop.com
          Skype is dave.mason46

          Comment

          Working...
          X