Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Losing records VERY WORRYING

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Al Buchholz
    replied
    Re: Losing records VERY WORRYING

    Originally posted by lascvent View Post
    If alpha five is still using . dbf as it's extensions, this type of thing will be happening.
    Can it be changed?
    The alternative to dbf is to use DAO to connect to another data source.

    It is available as an active link tablee as the closest alternative, but is a level if complexity higher then the native dbf.

    Leave a comment:


  • lascvent
    replied
    Re: Losing records VERY WORRYING

    If alpha five is still using . dbf as it's extensions, this type of thing will be happening.
    Can it be changed?

    Leave a comment:


  • DaveM
    replied
    Re: Losing records VERY WORRYING

    Thanks John,

    I was never a fan of sets built on multiple fields. Nor do I care for indexes built with filtering and/or expressions. Maybe these have kept me out of trouble.

    Leave a comment:


  • johngtatp
    replied
    Re: Losing records VERY WORRYING

    Update: I am keeping my fingers crossed at this point as this issue has not happened for about a month now. I have tried everything under the sun and still am not quite sure what the fix was but I have a general idea. I thought for so long that this was a NAS issue and finally convinced IT to move to an actual server, this did not change the blanking behavior. I then had to get the virus scan restrictions lifted for the files, this too had not effect. I ended up doing a redesign of some sets which allowed me to delete several indexes that had an expression and filter. In addition, my set also had a one to many link using a multiple field link which created some other indexes that I could then delete. So far so good. It has been 4 years of this, loosing a few records a week. I am cautiously optimistic for now. The frustrating thing is there was really nothing wrong with what I was doing, yet the issue still existed.
    Last edited by johngtatp; 10-15-2015, 10:01 PM.

    Leave a comment:


  • mariusm
    replied
    Re: Losing records VERY WORRYING

    Originally posted by Tom Cone Jr View Post
    Marius,

    Perhaps you'd be willing to start a new thread and explain the specifics of the thin client / virtual desktop setup you mention. I think a number of folks would be very interested to learn how its configured on the workstation, and especially on the "server". Thanks. -- tom
    Tom, I'm afraid I don't have much info about how to set this. It was done by my customer's IT guy. The server runs Win Server 2008, you set the Remote Desktop Services in the server roles, you can find how to do it if you google it. You need a fairly hefty server. For about 20 users they have, he installed 20GB of RAM and two fast HD's in RAID1.
    Each user has their own virtual desktop instance that runs on the server - the client machine only displays the screen, all software runs on the server. You need to pay for a M$oft license for each user, so it's not cheap. The advantage is that no database data is sent over the network, all processing is done locally on the server; so the database runs a lot faster. Of course, my main problem was losing records, and that doesn't happen because even if you lose connection from the client computer, your virtual desktop and your instance of the A5 runtime is still running on the server.

    Leave a comment:


  • DaveM
    replied
    Re: Losing records VERY WORRYING

    I, too still have the same issues. I cannot get a server put in due to IT constraints. I lose about 1 record every week sometimes a bit more. The records are there just with their linking field nulled so I can tell how many. I eventually will have to figure out how to put this app on the web which should take away all the issues.
    Most of my installs are on lans with no real server. One windows machine is used "as" a server. I am not having the problems you are on any install. Other side is, if you are having these problems on a lan, why would you think a web app would be better? Especially if it is in the networking??

    Leave a comment:


  • Ray in Capetown
    replied
    Re: Losing records VERY WORRYING

    Originally posted by Tom Cone Jr View Post
    Marius,

    Perhaps you'd be willing to start a new thread and explain the specifics of the thin client / virtual desktop setup you mention. I think a number of folks would be very interested to learn how its configured on the workstation, and especially on the "server". Thanks. -- tom
    have a look here Tom http://msgboard.alphasoftware.com/al...5&goto=newpost

    Leave a comment:


  • Tom Cone Jr
    replied
    Re: Losing records VERY WORRYING

    Marius,

    Perhaps you'd be willing to start a new thread and explain the specifics of the thin client / virtual desktop setup you mention. I think a number of folks would be very interested to learn how its configured on the workstation, and especially on the "server". Thanks. -- tom

    Leave a comment:


  • mariusm
    replied
    Re: Losing records VERY WORRYING

    For the client that had the problem, it was finally sorted when they switched everyone on thin client / virtual desktop. This way, all data processing is done one the server, there is no shadow, and in the 11 months since this was done they haven't lost a single record.
    The database was on the server and all clients were shadowing the database on their computers; it seems like every now and then, the shadow would not update properly and we ended up with an empty record - a completely blank record in the parent table. It was not user error, I spent a lot of time building an audit trail only to find that users had nothing to do with it.
    Because it was so random, my guess is that it's either a network issue, or a problem in the way Alpha updates the main database from a shadow.
    My customer only has some 20 users and fairly light database traffic, so switching to thin clients made sense even though it was a desperation move.

    Leave a comment:


  • johngtatp
    replied
    Re: Losing records VERY WORRYING

    I, too still have the same issues. I cannot get a server put in due to IT constraints. I lose about 1 record every week sometimes a bit more. The records are there just with their linking field nulled so I can tell how many. I eventually will have to figure out how to put this app on the web which should take away all the issues.

    Leave a comment:


  • Al Buchholz
    replied
    Re: Losing records VERY WORRYING

    Originally posted by Dennis Mathias View Post
    Here's a good one. I've even found records with the same record number! And others missing.
    Can you post a visual of that?

    Leave a comment:


  • DaveM
    replied
    Re: Losing records VERY WORRYING

    Unless you are running tons of users, you should not have problems like that. Sounds like connection issues. IT/IS should be able to help that if they will.

    So much for my opinion.

    Leave a comment:


  • Dennis Mathias
    replied
    Re: Losing records VERY WORRYING

    Here's a good one. I've even found records with the same record number! And others missing.

    Leave a comment:


  • Dennis Mathias
    replied
    Re: Losing records VERY WORRYING

    No, never did. What I do is what someone up above is doing. Rebuild those indexes every chance you get. I do it at night. Everyone has to be off or the files are open. Then, after I do that I do a backup. I just wrote a little script, made a batch file using xcopy..the DOS command. Also--and I don't know if this has anything to do with it--I save the record in the app every opportunity. So save when exiting a field and maybe do it again before they leave the app even if they don't do it.

    That said, I'm starting to think that it may indeed have something to do with the app and data not residing on a SERVER type of architecture. I don't know the gorey details of our network but it's big (huge) and maybe it's acting like NAS or something. I'd tell IS about it but a) they wouldn't listen to me and b) would bite my head off for not using SQL. I am an engineer and not in the IS department..so read between the lines.

    Leave a comment:


  • grclark
    replied
    Re: Losing records VERY WORRYING

    I am experiencing the same problem with Alpha 10.5
    The description you have given is identical to what I have found.
    Did you ever get a solution?

    Leave a comment:

Working...
X