Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

Problem with a Set design

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with a Set design

    As an Alpha 4 user since the early 90’s, all my applications have been based on the DOS versions thru Alaha4v8. I tried Alpha5 early on, and didn’t like it. Now, I feel it is necessary to make the switch and my company has bought Alpha5v10, Runtime, and the Web Developer packages.

    I have started to convert the many things we developed with A4v8, and have just run into my first problem. I have 2 tables called Inventory and MasterList. Inventory is our Company list of items in stock………qty, description, prices, etc. This is indexed by a ‘part number’ index. MasterList is the aggregation of all the parts price lists our main vendor has issued annually each year. This is also indexed by ‘part number’. In A4v8,
    MasterList is linked to Inventory where MasterList is a look up table. Our form view has all the data showing from both tables.

    If we buy some parts from a dealer who is going out of business, we type the part number into the Inventory part number field, and if the part is already in our inventory, we just add the quantity to that record. If the part is not in our inventory, it should be found in the MasterList look up table and all the data could be transferred to the Inventory table. It works great in A4v8 and all our employees are happy with the way it works.

    But, I can’t get it to work the same way in A5v10. When I do a search by part number, it searches the MasterList table not the Inventory table as in A4v8.

    Any comments or suggestions will be appreciated.

  • #2
    Re: Problem with a Set design

    I tried the set just now, and it seems to be working. I didn't change anything since yesterday when it was not working correctly. Strange..............

    Comment


    • #3
      Re: Problem with a Set design

      Joe, welcome to Alpha Five.

      A common misconception is that folks sometimes think that the source (lookup) table must be linked into a set with the primary table in order for the lookup field rule to work. That's wrong. The lookup source table does not need to be linked and a set of tables is not necessary. In fact, including the lookup source table in the set will sometimes cause trouble. Your description of the tables suggests to me that you would be better off removing the Masterlist from your set. There doesn't seem to be a business (transaction) relationship between the two tables. What you are doing (if I"m reading you correctly) is like linking the telephone directory to your customer table just because you want to lookup phone numbers for customers.

      Comment


      • #4
        Re: Problem with a Set design

        Originally posted by Tom Cone Jr View Post
        Joe, welcome to Alpha Five.

        A common misconception is that folks sometimes think that the source (lookup) table must be linked into a set with the primary table in order for the lookup field rule to work. That's wrong. The lookup source table does not need to be linked and a set of tables is not necessary. In fact, including the lookup source table in the set will sometimes cause trouble. Your description of the tables suggests to me that you would be better off removing the Masterlist from your set. There doesn't seem to be a business (transaction) relationship between the two tables. What you are doing (if I"m reading you correctly) is like linking the telephone directory to your customer table just because you want to lookup phone numbers for customers.
        Thanks, John. I did not know that the lookup source table does not need to be linked....as in a set. Asyou suggested, I've tried using the lookup just with the Inventory table and it does seem to work. However, our employees are so accustomed to seeing all the fields of both tables, I will probably stick with the set.

        I am so used to using A4v8, where it is pretty simple to design tables, sets,
        indexes, forms, regions and reports, that re-doing my entire App in A5v10 is really challanging. Right now, after a few weeks with v10, I have redone all
        my tables and sets, and they are functioing. It appears to be a very crude and unsophisticated approach that I have taken. And it is obvious to me that A5v10 is very poweful and my entire App could be redone by a sophisticated programmer.

        Another problem I am having is getting a jpeg image to display on my inventory set from. I have jpegs of many of my 15,000+ parts. They jpegs are in a separat folder on my server, and each jpege is named by the parrt number they represent. I have a fields named image in both the inventory and masterlist tables. But i can get the images to display on the form. I want to be able to search for a part, then see the part image as I view the price, qty in stock, etc. What litle I have been able to find on the message board. the help file and the wiki, has not shown me in enough detail exactly what must be done. Any help you might suggest would be appreciated.

        Thanks again, Joe

        Comment


        • #5
          Re: Problem with a Set design

          Joe

          Now that you seem to have the problems resolved as far as converting to V10, you should now post the latest question in the Version 10 forum.

          Most of us would not look in this Upgrading to Alpha Five from Alpha four for Version 10 problems or you can use the New Developers forum for the same thing.

          You will get better response in either one of those.

          Tom Baker

          Comment


          • #6
            Re: Problem with a Set design

            Tom, I have taken note of your sugfgestion, and will repost a modified version of my question in the appropriate forum

            Comment

            Working...
            X