Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

A4V6 Record Access Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • A4V6 Record Access Problem

    I recently added maybe 25 records to a database with Alpha4v6, performed a Query on a common field to isolate the records I'd just entered and then printed a report so that I could edit my data entry. Everything went just fine.

    The next time I used the data base I could not access the records I'd just entered through a Find command. I receive the error message "File not found or Access Denied Reading Database." The same error message is received when I:

    A. Scroll through a Browse table and hit the point where one of the new records should be,
    B. Scroll in View Mode
    C. Attempt to update field Rules

    I've I've tried various indices & ranges, updated Indices, and then erased and re-created them with no luck.

    I've also tried to copy the database (and the "new records" aren't copied) and to export the database in ASCII (with the same result).

    The "new records" appear in the record count and the size of the dbf file suggests that they are there.

    Any thoughts on what the problem might be and how I might correct it?

    Tom

  • #2
    RE: A4V6 Record Access Problem

    Tom:

    This is really rudementary but I assume you have tried to see these in default range and indexed on record order.

    Ken

    Comment


    • #3
      RE: A4V6 Record Access Problem

      Could be a couple of things wrong, but sounds like a bad record. If you send me the .dbf I can take a look at it and see what I can do.

      MickM@unitedindustries.com

      Mick

      Comment


      • #4
        RE: A4V6 Record Access Problem

        Ken,

        Tried your idea first without any luck - but many thanks for sending it along (its usually the "basics" that bite me).

        Best I could figure, the Database records in my newly entered "range" had somehow become corrupted.

        I exported what would export in record number order (which, fortunately, put my problems at the end of the dbf. I then successfully deleted everything after the point where my "browse" hit a snag, and then re-enterd my "problem children." Seems to have solved my problem.

        This one convinces me (hopefully for a while) to take the time to back-up/restore more frequesntly -- "too soon old, too late smart."

        Tom

        Comment


        • #5
          RE: A4V6 Record Access Problem

          Mick,

          Thanks for your generous offer - and I think you nailed my problem. I concluded the same thing (after a ton more time than I'm willing to admit)and "got lucky".

          Do you have any tricks for finding the "bad apples"? Fortunately, my problems were with records I had just entered (and were at the end of the "record number" file).

          I just assumed that the whole range of "new" records was bad and was able to export the good stuff and re-enter the bad.

          Would like to know a better way.

          Thanks again,

          Tom

          Comment


          • #6
            RE: A4V6 Record Access Problem

            Hi Tom

            I have come across this problem occasionally with different clients. It usually clears up when they buy newer computers.

            But to your problem. I use append to fix it. I append the offending tables from a set to temporary tables which are empty. The append stops at the record before the first corrupted record. It usually only one of the tables in a set which has been corrupted

            Then I zap the original tables and reappend back from the temp tables. I have found that only the last record entered has become corrupted. I find this to be fast and very simple way to recover from corrupted records.

            Hope this helps

            Robert

            Comment


            • #7
              RE: A4V6 Record Access Problem

              ALL:

              Picked up an old FAX FAQ from Alpha Soft about rebuilding indexes. Here's what it says......

              "....Do NOT select 'UPdate All' but rather edit each index seperately ---take out and re-type the expression then save each with F10....."

              The article says, in this manner, the index is completely rebuilt rather than just updated. There was another alternative and that was to leave the expression as it was but move the cursor one space past the end of it and then save with F10. Allegedly, according to the FAX-On-Demand that, too, would cause a complete overhaul of the index rather than just an update.

              Just another thing to try.

              Ken

              Comment


              • #8
                RE: A4V6 Record Access Problem

                Ken,

                "Updating" individually makes sense - unfortunately,at 2:00 a.m., that one slipped right by me.

                Thanks for the info.

                Tom

                Comment


                • #9
                  RE: A4V6 Record Access Problem

                  Robert,

                  Sounds like a much better (and safer) approach - particularly if the problem is in the last record entered.

                  I am using an older PC for my older programs like Alpha4v6 (assuming that it would still be fine for those.) I have that PC on one of the first versions of Windows95, which has been a major pain since I installed it.

                  The "Append" to a new (empty).dbf approach must work differently than the "Copy" to a new .dbf function or else my problem arose with the first "new record" I entered rather than the "last record" which has been your experience. Wish I'd kept the "corrupted" file so I could try both approaches.

                  Thanks again.

                  Tom

                  Comment

                  Working...
                  X