Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

A4 was working yesterday, today it won't start!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • A4 was working yesterday, today it won't start!

    I clicked on the desktop icon to start A4V8 today that I have been using for many many months. It started loading as it usually does, opening a dos window, but then the window just collapses and disappears. No error message, nothing. If I double click again, same thing happens.

    Nothing has changed on my computer, except I downloaded and installed the microsoft security updates for Windows XP. I also deleted two files in my Sun Java directory, which I don't think have anything to do with A4.

    I've also tried going to the directory where A4V8 is stored and directly clicking on the exe. Same problem.

    Any ideas?

    Thanks for your help!

  • #2
    RE: A4 was working yesterday, today it won't start

    PS - it occurs to me that if there is an error message, it might be zipping by so fast I don't see it. It may be useful if there is some way to slow down the loading process, or make the window require confirmation before closing. Is there a way to do that?

    Comment


    • #3
      RE: A4 was working yesterday, today it won't start

      Try re-installing A4 and see what happens.

      Comment


      • #4
        RE: A4 was working yesterday, today it won't start

        Adam

        Use a DOS window that you open yourself.

        Start - Run - cmd

        Then navigate to the Alpha 4 directory and run the bat file that starts your app. The dos window shouldn't close and should show any messages.

        The other option is to set the property of the dos window to not close on exit.

        I like the first option because it is a temporary situation and does require you to undo things to bring it back to normal.
        Al Buchholz
        Bookwood Systems, LTD
        Weekly QReportBuilder Webinars Thursday 1 pm CST

        Occam's Razor - KISS
        Normalize till it hurts - De-normalize till it works.
        Advice offered and questions asked in the spirit of learning how to fish is better than someone giving you a fish.
        When we triage a problem it is much easier to read sample systems than to read a mind.

        Comment


        • #5
          RE: A4 was working yesterday, today it won't start

          I'm on WinXP, so unfortunately going through cmd just has the effect of a different method of starting the program - in windows - without any difference after the command has been entered. A new window opens up when I type "A4.exe" for example, as if I had clicked on an icon, and it quickly shuts off again.

          I also can't find any way to get the window not to shut down after ending -- how do you do that in WinXP?

          Comment


          • #6
            RE: A4 was working yesterday, today it won't start

            Nothing changed. I even tried putting it on a different drive, no luck. :(

            Comment


            • #7
              RE: A4 was working yesterday, today it won't start

              Using My Computer or the Explorer, go to the A4 folder and double click on the A4V8.exe. If this starts it up, then it's the A4.exe at fault. If it doesn't, then there's an OS problem.

              Comment


              • #8
                RE: A4 was working yesterday, today it won't start

                Doesn't work. Any idea what might be wrong with the OS? All my other programs work, and a4 has been working for a long time. It just stopped after I installed the MS Security updates, but I've had A4 work with those before. I've also reinstalled A4 and the problem remains.

                Comment


                • #9
                  RE: A4 was working yesterday, today it won't start

                  Had this same thing happen...

                  Had to go back to xp restore point prior to running xp updates and then installed xp updates one at a time and tried bringing up a4v8 each time.

                  after about fifth one, identified the problem one (error was something about no support mode), excluded it and ran rest up xp updates (individually and retested each time).

                  only one was the problem, don't remember which one it was...have it written down at client site and would call and get it but they are gone for day by now...

                  Comment


                  • #10
                    A4.exe and Windows XP

                    I had a similar problem with Alpha 4, version 7 and Windows XP. I found that is I set the compatiability option in the A4.EXE file to Windows 95, the poblem went away.

                    I do not use Version 8, but give this a try, and let me know if it helps.
                    Randall T. Wood (Randy)
                    MED Associates, Inc.
                    Software Support Representative/ Alpha Database Manager

                    Comment


                    • #11
                      Disappearing DOS Window

                      Hi guys,

                      Update on my earlier post (which I realize now does not fix this problem!).

                      I had a computer in our group that had Windows XP with SP1 and Alpha IV installed and running fine. The other day the user got a Security update on Windows XP; it installed SP2.

                      When we tried to run Alpha IV V7 again it did as described; the DOS window would immediately open, then close with no error given. I was able to generate a screen capture of the window while open, but it contained no text at all.

                      I then uninstalled the Alpha software, deleted all icons to apps, etc. and reinstalled the whole application again. It is running fine again. I just thought you would like to know what happened in my case; hopefully it will help you, too!


                      Randy
                      Randall T. Wood (Randy)
                      MED Associates, Inc.
                      Software Support Representative/ Alpha Database Manager

                      Comment


                      • #12
                        RE: A4 was working yesterday, today it won't start

                        Mr. Staples,

                        I would really like to know which update it was that cause the problem. I tried the same thing you did but was unsuccessful. I have noticed, however, that the problem occurs more frequently with XP Home Edition than with XP Pro. Not sure if that means anything.

                        Any assistance on this matter will be greatly appreciated.

                        Charles A. Halsall

                        Comment


                        • #13
                          A45 Was Working, But . . .

                          Guys,

                          Add me to the list. I have A4v6, V7 & V8 on my development system; A4V6 & V8 on my laptop - along with almost all version of V5. But systems run Win XP Pro SP1. V4 worked 100% until one of the Windows updated screwed up all versions of A4 on both systems.

                          After installing SP2 on the laptop, A4 again works 100%. I have no idea which Windows patch did the damage, and since it's probably impossible to unwind one update, I'm not worrying about figuring it out. I'll be installing SP2 on the development system as well and hopefully that will be the end of the A4-Windows problems. Until next time.

                          Dave
                          Dave Jampole
                          www.customalpha.com

                          Women and cats will do whatever they want. The sooner men and dogs realize that, the happier they will be.

                          Comment


                          • #14
                            The updates that are the problem

                            We have had the identical problem. It appears that the updates which prevent Alpha 4 version 8 from starting are KB885835 and KB890859

                            -Steve

                            Comment


                            • #15
                              A4 was working yesterday, today it won't start

                              Hi guys,

                              Someone suggested applying the windows 95 compatibility mode on the alpha.exe file in another discussion. Just to be on the safe side, I applied it to both the a4.exe and the a4v7.exe and it worked. I did the same with my runtime version.

                              To apply it, find the respective executable, right click on it, select property then choose the compatibility tab. The rest from there is straightforward.

                              I had tried this before but was applying the compatibility option to the short cut and not the executable.

                              Charles
                              Last edited by cahalsall; 01-30-2006, 01:11 AM.

                              Comment

                              Working...
                              X