Alpha Software Mobile Development Tools:   Alpha Anywhere    |   Alpha TransForm subscribe to our YouTube Channel  Follow Us on LinkedIn  Follow Us on Twitter  Follow Us on Facebook

Announcement

Collapse

The Alpha Software Forum Participation Guidelines

The Alpha Software Forum is a free forum created for Alpha Software Developer Community to ask for help, exchange ideas, and share solutions. Alpha Software strives to create an environment where all members of the community can feel safe to participate. In order to ensure the Alpha Software Forum is a place where all feel welcome, forum participants are expected to behave as follows:
  • Be professional in your conduct
  • Be kind to others
  • Be constructive when giving feedback
  • Be open to new ideas and suggestions
  • Stay on topic


Be sure all comments and threads you post are respectful. Posts that contain any of the following content will be considered a violation of your agreement as a member of the Alpha Software Forum Community and will be moderated:
  • Spam.
  • Vulgar language.
  • Quotes from private conversations without permission, including pricing and other sales related discussions.
  • Personal attacks, insults, or subtle put-downs.
  • Harassment, bullying, threatening, mocking, shaming, or deriding anyone.
  • Sexist, racist, homophobic, transphobic, ableist, or otherwise discriminatory jokes and language.
  • Sexually explicit or violent material, links, or language.
  • Pirated, hacked, or copyright-infringing material.
  • Encouraging of others to engage in the above behaviors.


If a thread or post is found to contain any of the content outlined above, a moderator may choose to take one of the following actions:
  • Remove the Post or Thread - the content is removed from the forum.
  • Place the User in Moderation - all posts and new threads must be approved by a moderator before they are posted.
  • Temporarily Ban the User - user is banned from forum for a period of time.
  • Permanently Ban the User - user is permanently banned from the forum.


Moderators may also rename posts and threads if they are too generic or do not property reflect the content.

Moderators may move threads if they have been posted in the incorrect forum.

Threads/Posts questioning specific moderator decisions or actions (such as "why was a user banned?") are not allowed and will be removed.

The owners of Alpha Software Corporation (Forum Owner) reserve the right to remove, edit, move, or close any thread for any reason; or ban any forum member without notice, reason, or explanation.

Community members are encouraged to click the "Report Post" icon in the lower left of a given post if they feel the post is in violation of the rules. This will alert the Moderators to take a look.

Alpha Software Corporation may amend the guidelines from time to time and may also vary the procedures it sets out where appropriate in a particular case. Your agreement to comply with the guidelines will be deemed agreement to any changes to it.



Bonus TIPS for Successful Posting

Try a Search First
It is highly recommended that a Search be done on your topic before posting, as many questions have been answered in prior posts. As with any search engine, the shorter the search term, the more "hits" will be returned, but the more specific the search term is, the greater the relevance of those "hits". Searching for "table" might well return every message on the board while "tablesum" would greatly restrict the number of messages returned.

When you do post
First, make sure you are posting your question in the correct forum. For example, if you post an issue regarding Desktop applications on the Mobile & Browser Applications board , not only will your question not be seen by the appropriate audience, it may also be removed or relocated.

The more detail you provide about your problem or question, the more likely someone is to understand your request and be able to help. A sample database with a minimum of records (and its support files, zipped together) will make it much easier to diagnose issues with your application. Screen shots of error messages are especially helpful.

When explaining how to reproduce your problem, please be as detailed as possible. Describe every step, click-by-click and keypress-by-keypress. Otherwise when others try to duplicate your problem, they may do something slightly different and end up with different results.

A note about attachments
You may only attach one file to each message. Attachment file size is limited to 2MB. If you need to include several files, you may do so by zipping them into a single archive.

If you forgot to attach your files to your post, please do NOT create a new thread. Instead, reply to your original message and attach the file there.

When attaching screen shots, it is best to attach an image file (.BMP, .JPG, .GIF, .PNG, etc.) or a zip file of several images, as opposed to a Word document containing the screen shots. Because Word documents are prone to viruses, many message board users will not open your Word file, therefore limiting their ability to help you.

Similarly, if you are uploading a zipped archive, you should simply create a .ZIP file and not a self-extracting .EXE as many users will not run your EXE file.
See more
See less

A4v7 in Vdos

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • A4v7 in Vdos

    Hi everyone. Does anyone have any experience running Alpha4V7 in vdos. I am trying to keep access to some old dos applications while upgrading to Windows 7 and Windows 10. I downloaded the latest version of vdos, installed it and made the autoexec changes to run a4. The program loads and the small sample files seem to work as designed. When I try to use applications I designed, which are larger, I get all kinds of problems. Forms don't display correctly, queries don't display correct records, field rules don't work etc. The vdos crashes when I try to update indexes on the main parent dbf and the set. I have reached out to the developer of vdos, but they don't have the familiarity with a4 that the members of this board have . Thank you in advance for any help.

    Jeff C

  • #2
    Re: A4v7 in Vdos

    Hi all
    Re. Vdos I'd just like to echo Jeff Carozza's request. (Same problems as him) As a long time Alpha dos user, vdos looks like the best thing since sliced bread! If only someone could sort it - the old program looks revitalised somehow - I guess like others here I've built up my application over many years - Having recently tried out an "0ff the shelf" solution for my garage servicing business, I soon realised I wouldn't be able to cope with its limitations & am going to stick with good old Alpha come hell or high water.
    Any help would be much appreciated (that's an example of an English understatement)

    Joe R

    Comment


    • #3
      Re: A4v7 in Vdos

      Hi all, I have attached sample files if anyone wants to try to replicate the problem I'm having.

      Jeff C
      Attached Files

      Comment


      • #4
        Re: A4v7 in Vdos

        Hi all,

        The problems A4v7 is having in vDos are related to an FPU. A4 is calling for the FPU when doing any functions involving math. Vdos doesn't support an FPU; so when Alpha calls for it, the call is ignored. This causes the program to crash or freeze. The developer is looking into this, if I find any additional information I'll post it here.

        Jeff C
        Last edited by Jeff Carroza; 02-14-2017, 01:48 PM.

        Comment


        • #5
          Re: A4v7 in Vdos

          Hi all,

          I have been in contact with the developer of vDos. vDos was developed with out a FPU. A4 versions 4,6,7 and 8 came with WEMU387.386, a FPU emulator. This is a windows device driver and it can't be used in a virtual dos machine. So A4, in versions 4 or greater will not run correctly in vDos.

          Jeff C

          Comment


          • #6
            Re: A4v7 in Vdos

            To clarify further: A FPU was indeed for some reasons omitted from vDos. One of these; as I started the vDos project, I didn’t know of any DOS program requiring this. Until now no problem, I guess, only two vDos users reported this missing over the last 4 years or so. For programs, I’m not interested in.

            Alpha Four at some moment removed the internal math functions, replacing those with functions relying solely on a FPU. Accommodating new Windows NT machines w/o a FPU, while older DOS machines were supposed to have a FPU. What object had Alpha Four in mind, easing the transition to Windows NT with a Windows installation of a still entirely DOS based program, depending on NTVDM and limiting its use in DOS? They should of course have recompiled A4 for Windows 32-bit, a familiar text-based genuine Windows A4 program with some Windows extensions (like printing), that would still run in Windows 64-bit. It would have cost a programmer a week or two of work to make the transition, but would also interfere/compete with the upcoming A5…

            Basically you (A4 DOS users) are left in the cold by Alpha Four. I added FPU support to my to-do list, but it has no priority, you could check the next vDos release if it emulates a FPU.

            Jos Schaars (vDos)

            Comment


            • #7
              Re: A4v7 in Vdos

              Hi all,

              I found my old A4V3 install disks and loaded them onto a Win10 desktop with vDos. Everything thing seems to be working well. I've only worked with the sample files, but they seem to be functioning. The sets can be opened and mathematical functions appear to be working. I haven't tried any of my apps yet. I don't think the files can be read in v3 and the applications would have to be redone. FWIW any v7 or v8 user who has a copy of A4 v3 or earlier should be able to use vDos.

              Jeff C

              Comment


              • #8
                Re: A4v7 in Vdos

                The latest release of vDos (09/16) has added FPU support and also works with a4 networked data. Multi-user shared database and file locking is now supported. We are running alpha4v7 in Windows 10, 64 bit without issues.

                Comment


                • #9
                  Re: A4v7 in Vdos

                  I've been running for several years multi use Alpha 4 V8, with about 5-6 users.
                  My setup is a dozen virtual XP machines, running on dedicated Windows 10 computer. Using Oracle free Virtual box for the virtual XP machines, and free Team viewer or Remote Desktop utilities for remote access. All work fine.

                  Comment


                  • #10
                    Re: A4v7 in Vdos

                    Originally posted by admin@dcitelecom.com View Post
                    The latest release of vDos (09/16) has added FPU support and also works with a4 networked data. Multi-user shared database and file locking is now supported. We are running alpha4v7 in Windows 10, 64 bit without issues.
                    I have been running A4V7 using vDos under 64-bit Windows 10 for about a month now and it seems to run quite well.

                    One thing I've noticed however, is that even when the program is idle, it is using between 14-15% of the cpu (with 0 disk activity). Could this be a side-effect of your FPU implementation?

                    Comment


                    • #11
                      Re: A4v7 in Vdos

                      I have a4v8 running fine in VDOS but it doesnt save changes to multi user mode.
                      It does save other changes but not multi user mode.
                      Other / Configuration / Default Settings / Multi-user mode

                      What am I doing wrong?
                      I am on Win 7 64 bit. latest VDOS.

                      Comment


                      • #12
                        Re: A4v7 in Vdos

                        Hello to everyone. I have used dos versions since 1988.
                        I have a windows 10 laptop that I run Alpha4v8 on and it works very well. It entailed downloading free Oracle virtualbox 6.0 and installing windows xp in virtualbox. The window size is adequate (larger than when running windows 7 pro with the windows virtual machine).
                        This is a link to the video I used to get windows xp on the internet and working.
                        https://www.youtube.com/watch?v=H6r-2EdC30c
                        YOU must setup antivirus. I used avg free and malwarebytes free.

                        Best to all.

                        Ray J.

                        Comment

                        Working...
                        X