Alpha Video Training
Results 1 to 2 of 2

Thread: Synchronize data requires pre-load, but pre-load throws errors.

  1. #1
    Member
    Real Name
    divaanddress
    Join Date
    Jun 2009
    Posts
    95

    Default Synchronize data requires pre-load, but pre-load throws errors.

    Issue: Synchronize data requires pre-load, but pre-load throws errors.

    In my Detail View for a CHILD list control, (also called a Cascading List in the videos) I get this message; "You are trying to synchronize data in a child List, but you have not checked the 'Pre-load data' property for this List. Please edit the definition for the 'LSTPROJECT' List and check the 'Pre-load data' option."

    So I went to Child List Control's List Builder>Data Source tab>Selected "Pre-load" data. Chose the primary key for the Linking Field-parent list. For the Linking field -this list option I chose what would be considered the foreign key. CLIENT_ID and client_id respectively.

    Ran a Live preview and got a 500 error. Ran a Working Preview and got "Error:Script:A5W Code line:109 Error parsing data: Must be a comma or ']' after an array element." Line 109 reads : $('{grid.componentName}.SHOWHIDEPANELIMG.SEARCH.R{grid.rowNumber}').src = '{images.CollapseContainer.Open}'; Which is weird, this is a UX component without any embedded grid controls.

  2. #2
    Member
    Real Name
    divaanddress
    Join Date
    Jun 2009
    Posts
    95

    Default Re: Synchronize data requires pre-load, but pre-load throws errors.

    A brief clarification,
    1) I am running the latest version of Alpha.
    2) I have one master list. From there I "cascade" the to a second list, then "cascade" to a third. The third has, or will have, a minimum of three more lists cascaded from this point.
    3) Each of the list controls uses MySQL, and has a detail section in a window container.


    Great Grandfather
    ------> Grandfather
    ---------> Parent
    -------------> Child 1
    -------------> Child 2
    -------------> Child 3
    -------------> Child 4
    -------------> Child 5

Similar Threads

  1. Errors During Load
    By besmith33 in forum Alpha Five Version 10 - Desktop Applications
    Replies: 8
    Last Post: 07-11-2011, 12:37 PM
  2. Errors During Load
    By Hackey in forum Alpha Five Version 9 - Desktop Applications
    Replies: 0
    Last Post: 09-29-2010, 01:10 AM
  3. Errors during load
    By raymarkc in forum Alpha Five Version 6
    Replies: 2
    Last Post: 08-19-2008, 01:48 PM
  4. Errors During load
    By Bill Griffin in forum Web Application Server v7
    Replies: 18
    Last Post: 11-14-2005, 09:59 PM
  5. Errors During Load
    By J Bowers in forum Alpha Five Version 5
    Replies: 2
    Last Post: 09-03-2002, 06:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •