Alpha Video Training
Results 1 to 9 of 9

Thread: Hyperlink issues in Static HTML cell on Layout reports

  1. #1
    Member
    Real Name
    Bruce Jonson
    Join Date
    May 2010
    Location
    New Zealand
    Posts
    428

    Default Hyperlink issues in Static HTML cell on Layout reports

    Hi All,

    Need some help here as I have hit a wall with this problem.
    I have a report on a web app that we have a quote print report. It is a Table Layout report.
    We have a Quote Footer field that has a number of Hyperlinks in it.
    The problem is rather than a long hyperlink the client want a "Click Here" instead.
    But I cannot get
    <a href="http://aadocuments.s3.amazonaws.com/ReleaseNotes/ReleaseNotes.Html">Click Here for Release Notes</a>
    to work

    Can anyone help?

    Here is an example report attached.

    And here is the text that is in the red "Static HTML" text.
    -----------------------------------------------------------------------
    This is a "STATIC HTML" Cell
    <br>
    <br>
    Below is a pure link
    <br>
    http://aadocuments.s3.amazonaws.com/...easeNotes.Html
    <br>
    And it is clickable (But dosn't look like a hyperlink... but we can fix that with adding style tags)
    <br>
    Now below here is another link, but this time using a a-ref Tag so that we can format the link into something more friendly, e.g. "Click Here"
    <br>
    <a href="http://aadocuments.s3.amazonaws.com/ReleaseNotes/ReleaseNotes.Html">Click Here for Release Notes</a>
    <br>
    But... it is formatted blue and looks like a hyperlink BUT it is NOT clickable in the report preview and in any resulting PDF.
    <br>
    Is this a bug in the "Static HTML" option?
    <br>
    <br>
    The client has really long URLs and wants to make them friendly.

    HELP!!!!!
    ----------------------------------------------------------
    Attached Files Attached Files

  2. #2
    Member
    Real Name
    Bruce Jonson
    Join Date
    May 2010
    Location
    New Zealand
    Posts
    428

    Default Re: Hyperlink issues in Static HTML cell on Layout reports

    Bump? anyone?

  3. #3
    Alpha Software Employee Selwyn Rabins's Avatar
    Real Name
    Selwyn Rabins
    Join Date
    Mar 2000
    Location
    Boston, MA
    Posts
    5,298

    Default Re: Hyperlink issues in Static HTML cell on Layout reports

    are you rendering the report as HTML or as PDF.
    If you render as HTML, then it actually does work as you expected. i.e. the links are clickable, as shown in the video

    https://www.screencast.com/t/G19c1tqINItb

    If the report is being rendered as a PDF, then the links would not be expected to work and the do not work.

  4. #4
    Member
    Real Name
    Bruce Jonson
    Join Date
    May 2010
    Location
    New Zealand
    Posts
    428

    Default Re: Hyperlink issues in Static HTML cell on Layout reports

    Thanks Selwyn, I will have to find another way.

  5. #5
    "Certified" Alphaholic
    Real Name
    Govindan Gandhi
    Join Date
    Aug 2008
    Location
    New York, NY
    Posts
    4,294

    Default Re: Hyperlink issues in Static HTML cell on Layout reports

    there is a service, tinyURL, it will turn long url to shorter one. i do not know it is free or paid one.
    may be you can check it out to shorten the url to a reasonable one.
    as far as i know it does not give you user friendly name like what you would otherwise achieve using <a /> construct.
    take a look, it won't hurt exploring.
    thanks for reading

    gandhi

    version 11 3381 - 4096
    mysql backend
    http://www.alphawebprogramming.blogspot.com
    ggandhi344@gmail.com
    Skype:ggandhi344@gmail.com
    1 914 924 5171

  6. #6
    "Certified" Alphaholic kingcarol's Avatar
    Real Name
    Carol King
    Join Date
    Jun 2010
    Posts
    1,527

    Default Re: Hyperlink issues in Static HTML cell on Layout reports

    I am having the exact same issue. How did you resolve it, Bruce?
    Carol King
    Developer of Custom Homebuilders' Solutions (CHS)
    http://www.CHSBuilderSoftware.com

  7. #7
    Member
    Real Name
    Bruce Jonson
    Join Date
    May 2010
    Location
    New Zealand
    Posts
    428

    Default Re: Hyperlink issues in Static HTML cell on Layout reports

    Hi Carol,
    I never did find a solution. I wanted to email a PDF and have a clickable link in the attached PDF but couldn't find a way. Seems like it SHOULD work but when Selwyn said it won't... I surrender :)

  8. #8
    Member cptutrecht's Avatar
    Real Name
    Ger Kurvers
    Join Date
    Feb 2010
    Location
    Netherlands, Utrecht
    Posts
    525

    Default Re: Hyperlink issues in Static HTML cell on Layout reports

    I remember a very dirty and not quick solution (work around) in other software.
    As you see, the full link is clickable.
    I turned that into a field styled as a line, with font the same colour as the background (for example blue). That line isn't readable, but still clickable :-)
    And put the desired link name above it.
    I had both field in a container so that the line-field got the length of the link name
    Maybe this approach works also in alpha if you really need it....
    Ger Kurvers
    Alpha Anywhere / V4.5.5.0- Build 5667
    Development: Mysql, windows 10 64 Applicationserver: standard on Windows server 2012 R2

  9. #9
    "Certified" Alphaholic kingcarol's Avatar
    Real Name
    Carol King
    Join Date
    Jun 2010
    Posts
    1,527

    Default Re: Hyperlink issues in Static HTML cell on Layout reports

    That's interesting, Ger. If I was better at Alpha reports, I might try it, and I'm going to keep in mind in case I do decide to try it. I understand your concept. For now, I just decided to go ahead and show the whole link in the layout report, and made that row tall enough so hopefully entire link will show. I also merged the cell with the link in it across all columns. When the report is a pdf, I am able to click on it in my Adobe reader, AND when viewing the report on Iphone or Ipad, and it opens the link.

    It doesn't work for me to open it in html, and use the 'a ref....' stuff because my users need to email the report as a pdf to others, and 'a ref..' doesn't work on a pdf. And for the link to activate itself in the PDF, the whole url needs to be available. I also put a note on the report that if the link doesn't work, the user should copy the entire link and paste it into their browser.

    I made a calculated field in my report (using xy tool) like this:
    attachment1 = printHTML(attachedfileurl)

    Then I put the attachment1 calculated field in the cell on the report. I am not setting the cell to Static HTML.

    I used Advanced Options in the source for the report, then check marked Override Field Definitions, and set the attachedfileurl field as an HTML Memo field. Not sure if I needed to all of those things, but it works, so I'll leave it as is.
    Carol King
    Developer of Custom Homebuilders' Solutions (CHS)
    http://www.CHSBuilderSoftware.com

Similar Threads

  1. Replies: 2
    Last Post: 10-19-2016, 06:55 PM
  2. Replies: 1
    Last Post: 01-18-2016, 01:48 PM
  3. Hyperlink on Layout Tbaloe Report
    By gaby_h in forum Application Server Version 11 - Web/Browser Applications
    Replies: 0
    Last Post: 05-27-2012, 01:11 AM
  4. Edit cell in layout report
    By Peter.Greulich in forum Application Server Version 11 - Web/Browser Applications
    Replies: 1
    Last Post: 04-10-2012, 02:01 PM
  5. Tabbed Layout - Hyperlink to New Tab
    By davidachavez in forum Application Server Version 10 - Web/Browser Applications
    Replies: 0
    Last Post: 05-17-2011, 02:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •