Alpha Video Training
Results 1 to 7 of 7

Thread: mobile login component not working on mobile emulators

  1. #1
    Member
    Real Name
    Amit lohogaonkar
    Join Date
    Mar 2017
    Location
    NJ
    Posts
    428

    Default mobile login component not working on mobile emulators

    mobile login component not working on mobile emulators- works in browser. I published android app to phonegap and downloaded it and I am trying to test login functionality using https://testobject.com/ as I do not have android phone but login is not working, same works when I open same page on browser. Its a mobile login component.(based on mobile template)

  2. #2
    "Certified" Alphaholic
    Real Name
    David Kates
    Join Date
    Apr 2008
    Location
    Unionville, ON
    Posts
    7,551

    Default Re: mobile login component not working on mobile emulators

    UX Integrated Login... correct?

    I just tried this and it works ok... no issues. What Alpha server are you pointing to?

  3. #3
    Member
    Real Name
    Amit lohogaonkar
    Join Date
    Mar 2017
    Location
    NJ
    Posts
    428

    Default Re: mobile login component not working on mobile emulators

    thanks David. if its working for thats great. May be I am doing something wrong as I am new to app publishing via phone gap. I will try few things on my local alpha dev box.

  4. #4
    Member
    Real Name
    Amit lohogaonkar
    Join Date
    Mar 2017
    Location
    NJ
    Posts
    428

    Default Re: mobile login component not working on mobile emulators

    I think ajaxcallback is the issue
    https://www.alphasoftware.com/alphaf...d-mobile-login
    I am trying to work it out...

  5. #5
    Member
    Real Name
    Amit lohogaonkar
    Join Date
    Mar 2017
    Location
    NJ
    Posts
    428

    Default Re: mobile login component not working on mobile emulators

    I tried putting http://10.0.0.11:1580 inajaxcallback and I also used testpg from https://www.alphasoftware.com/alphaf...d-mobile-login
    Ajaxcallback is not working on android tab but works in desktop browser. I am installed alpha on my local laptop .

  6. #6
    "Certified" Alphaholic
    Real Name
    David Kates
    Join Date
    Apr 2008
    Location
    Unionville, ON
    Posts
    7,551

    Default Re: mobile login component not working on mobile emulators

    Is http://10.0.0.11:1580 your local dev server? If so, that can't work. Your ajax callback URL must point to an external, remote Alpha Server. It works under your browser because your browser is on the same network at your server... they can see each other. Your local device, if on wifi, can see your network, and that's why it works. Some remote device sitting in Germany is not on your network... so you must point it to an Alpha server that is open and running.

  7. #7
    Member
    Real Name
    Amit lohogaonkar
    Join Date
    Mar 2017
    Location
    NJ
    Posts
    428

    Default Re: mobile login component not working on mobile emulators

    Thanks David. You are right. I will publish it on server and will try.

Similar Threads

  1. Mobile LOGIN with GEO LOCATION
    By parkjammer in forum Mobile & Browser Applications
    Replies: 3
    Last Post: 01-20-2016, 11:01 AM
  2. mobile app login
    By cpampas in forum Mobile & Browser Applications
    Replies: 8
    Last Post: 06-19-2015, 03:27 AM
  3. How to bypass my login component for mobile?
    By -Jinx- in forum Mobile & Browser Applications
    Replies: 7
    Last Post: 04-22-2014, 04:21 AM
  4. UX Login for Mobile
    By Turnbullca in forum Mobile & Browser Applications
    Replies: 0
    Last Post: 08-07-2013, 05:33 PM
  5. V12 Mobile Login
    By josevelez in forum Mobile & Browser Applications
    Replies: 21
    Last Post: 06-15-2013, 09:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •