Alpha Video Training
Results 1 to 4 of 4

Thread: List Control hits "unable to get property 'index' of undefined or null reference"

  1. #1
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    37

    Default List Control hits "unable to get property 'index' of undefined or null reference"

    Dear All,

    when i tried to use the component from alpha sample to move a record from List A to List B,
    hit "unable to get property 'index' of undefined or null reference".

    please help me on that.
    Thanks in advance.

    I'm using alpha anywhere version 4.5.0. I already try recalculate all the control but no luck for me.

    Previously with older version I do not have any issues with this component

    ux_listMethods_populateAndMoveData.a5wcmpCapture.PNG
    Last edited by fatiha@pacific-orient.com; 10-07-2017 at 11:55 AM. Reason: forgot to tell what version I'm on.

  2. #2
    "Certified" Alphaholic
    Real Name
    David Kates
    Join Date
    Apr 2008
    Location
    Unionville, ON
    Posts
    7,867

    Default Re: List Control hits "unable to get property 'index' of undefined or null reference"

    Using Build 4584_4961, I'm not seeing any issues with the control you posted. Is there a specific set of steps you follow to get this error?

  3. #3
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    37

    Default Re: List Control hits "unable to get property 'index' of undefined or null reference"

    Quote Originally Posted by Davidk View Post
    Using Build 4584_4961, I'm not seeing any issues with the control you posted. Is there a specific set of steps you follow to get this error?
    Are you sure?I asked my colleague who is in the same alpha version with me to test the component that I attached in this thread but she hit the same error. Below is how I get the error

    1) First I click add sample data to list
    2) Then I choose one row and move it to other list
    3) The row moved but the alert appeared.

    Not sure why this thing happen. I'm actually using the sample from Alpha.Before this I did not get this error using previous alpha anywhere version. When I want to try it again after I upgrade my version recently , I hit this error.

  4. #4
    "Certified" Alphaholic
    Real Name
    David Kates
    Join Date
    Apr 2008
    Location
    Unionville, ON
    Posts
    7,867

    Default Re: List Control hits "unable to get property 'index' of undefined or null reference"

    Yes... pretty sure... https://youtu.be/di_u_K60t9k

Similar Threads

  1. Replies: 12
    Last Post: 10-19-2016, 08:15 PM
  2. Replies: 1
    Last Post: 12-06-2015, 08:33 PM
  3. Replies: 1
    Last Post: 11-28-2013, 10:27 PM
  4. Unable to get value of the property 'bind': object is null or undefined
    By dmcgrew in forum Application Server Version 11 - Web/Browser Applications
    Replies: 4
    Last Post: 06-03-2013, 08:47 PM
  5. Unable to get value of the property 'length':object is null or undefined, When TabPan
    By satyanarayana in forum Application Server Version 11 - Web/Browser Applications
    Replies: 1
    Last Post: 12-11-2012, 03:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •