Alpha Video Training
Results 1 to 4 of 4

Thread: Phonegap build plugin error

  1. #1
    Member
    Real Name
    Francisco Castillo
    Join Date
    Jun 2017
    Posts
    37

    Default Phonegap build plugin error

    Please help me with the problems I’ve been experiencing during the last weeks using the Phonegap build.
    • The first error happens when selecting the plugins cordova-plugin-file and the cordova-plugin-file-transfer. Phonegap throws me the following error:
    Error - Plugin error (you probably need to remove plugin files from your app): Fetching plugin "cordova-plugin-file-transfer@1.5.1" via npm Installing "cordova-plugin-file-transfer" at "1.5.1" for android Failed to install 'cordova-plugin-file-transfer': CordovaError: Version of installed plugin: "cordova-plugin-file@5.0.0" does not satisfy dependency plugin requirement "cordova-plugin-file@^4.0.0". Try --force to use installed plugin as dependency. at /home/ec2-user/.npm/lib/node_modules/pgb-plugman/node_modules/pgb-cordova-lib/src/plugman/install.js:581:33 at _fulfilled (/home/ec2-user/.npm/lib/node_modules/pgb-plugman/node_modules/q/q.js:787:54) at self.promiseDispatch.done (/home/ec2-user/.npm/lib/node_modules/pgb-plugman/node_modules/q/q.js:816:30) at Promise.promise.promiseDispatch (/home/ec2-user/.npm/lib/node_modules/pgb-plugman/node_modules/q/q.js:749:13) at /home/ec2-user/.npm/lib/node_modules/pgb-plugman/node_modules/q/q.js:509:49 at flush (/home/ec2-user/.npm/lib/node_modules/pgb-plugman/node_modules/q/q.js:108:17) at _combinedTickCallback (internal/process/next_tick.js:67:7) at process._tickCallback (internal/process/next_tick.js:98:9) Version of installed plugin: "cordova-plugin-file@5.0.0" does not satisfy dependency plugin requirement "cordova-plugin-file@^4.0.0". Try --force to use installed plugin as dependency.

    • The second error happens when selecting the plugin cordova-plugin-device. Phonegap throws the following error:
    Error - Plugin (or a specific plugin version) not found in external repo: cordova-plugin-device@4.3.3": Fetching plugin "cordova-plugin-device@4.3.3" via npm Failed to fetch plugin cordova-plugin-device

    • The third error happens when trying to use the barcode scanner in an app that was already succesfully build with the plugin phonegap-plugin-barcodescanner. See the first first capture attached to the email

    • The fourth error happens when trying to upload to Phonegap build using the cordova-media-with-compression plugin.
    Error - Some official plugins have to be updated if using PhoneGap >= 4.0.0. Please upgrade the version of any plugins that may include the following file: AudioHandler.java

    Using the CLI 6.5.0 Phonegap version, Alpha Anywhere v4.4.5, vesion 12-4-4-5, build 4491 and system addins build 4932.
    This problem happens when using your own sample apps as well as our own prototypes. However when testing with AlphaLaunch it all works OK as it should, without errors.

  2. #2
    "Certified" Alphaholic
    Real Name
    David Kates
    Join Date
    Apr 2008
    Location
    Unionville, ON
    Posts
    7,722

    Default Re: Phonegap build plugin error

    Francisco... isn't your other post the same issue? Are you providing specific version numbers for the plugins in your config.xml file?

    Please see this section... "PhoneGap App Builder - Core Plugins And Some Key 3rd Party Plugins" in the pre-release notes.
    http://aadocuments.s3.amazonaws.com/...easeNotes.Html

  3. #3
    Member
    Real Name
    Francisco Castillo
    Join Date
    Jun 2017
    Posts
    37

    Default Re: Phonegap build plugin error

    Hello! Yes, you are right, the problem was that Phonegap made a change in permissions, adding a minimum required version to all their plugins, version which PhonegapBuild doesn't support yet.
    So the solution is installing the alpha prerelease patch to solve this issue.

    Thanks Davidk

  4. #4
    "Certified" Alphaholic
    Real Name
    David Kates
    Join Date
    Apr 2008
    Location
    Unionville, ON
    Posts
    7,722

    Default Re: Phonegap build plugin error

    Although using the pre-release will, in a sense, "fix" the issue, the solution is actually just to include a version for each plugin. Add the version manually for each plugin to your config.xml file. Check for duplicate entries before submitting to PGB.

    Here's a current list of version numbers...

    https://www.alphasoftware.com/alphaf...748#post731748
    Last edited by Davidk; 11-27-2017 at 02:05 PM.

Similar Threads

  1. Phonegap build error
    By fcastillo in forum Mobile & Browser Applications
    Replies: 1
    Last Post: 11-21-2017, 03:56 PM
  2. Phonegap Build error
    By fatiha@pacific-orient.com in forum Mobile & Browser Applications
    Replies: 27
    Last Post: 11-17-2017, 12:52 AM
  3. Phonegap build not available and gives error
    By swest in forum Mobile & Browser Applications
    Replies: 1
    Last Post: 05-16-2017, 01:23 PM
  4. Phonegap Build Error
    By glenschild in forum Mobile & Browser Applications
    Replies: 2
    Last Post: 11-23-2016, 01:38 PM
  5. Phonegap Build Error
    By lutherhuffman in forum Mobile & Browser Applications
    Replies: 3
    Last Post: 04-25-2014, 11:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •