Alpha Video Training
Results 1 to 8 of 8

Thread: Error printing PDF reports with multiple instances/ports

  1. #1
    Member
    Real Name
    Robyn Murphy
    Join Date
    Nov 2017
    Posts
    4

    Default Error printing PDF reports with multiple instances/ports

    I have multiple instances of Alpha running to distribute concurrent users. Each of those instances are using a different port.
    Everything works perfectly, except for generating PDF reports.

    For my initial instance, the PDF is generated using the Alpha print driver and Amyuni driver without issue.
    On any of the alternate ports, generating a PDF brings up the following error:

    Code:
    Report did not print. Error reported was:
    Report Server: Layout Name: xxx.a5rpt Layout type: report Printer error: printer_init - print_dialog returned NULL hdc. at line 552
    This occurs for all PDF reports, but the HTML version is fine.
    As I said, it works fine on the initial port that I have always used (8080), but fails on any of the other ports (81 and 85).

    Where should I be looking to find the cause of this problem?
    Any assistance would be appreciated.

  2. #2
    Member
    Real Name
    Robyn Murphy
    Join Date
    Nov 2017
    Posts
    4

    Default Re: Error printing PDF reports with multiple instances/ports

    I may have narrowed it down a bit...
    If I set the service to Log On as an administrator account, it kind of works. That is, it generates the PDF but it seems to double-up and attempt to generate a temp pdf and the one for display (which doesn't happen in the one that is working). Note that all of the instances were set to use the LOCAL account at log on including the one that worked and the ones that didn't.

    So this indicates to me that there's something here to do with access and security to the printer/printer driver.
    Running on Windows 2003 server.
    I have tried to open up the security on the printers used for PDF, but still can't get it to work on the alternate ports properly.

    Again, if anyone has ideas, that would be great.

  3. #3
    "Certified" Alphaholic mikeallenbrown's Avatar
    Real Name
    Mike Brown
    Join Date
    Nov 2009
    Location
    United States
    Posts
    1,870

    Default Re: Error printing PDF reports with multiple instances/ports

    What version of Alpha are you running? And why are you using a 15 year old OS? I'm wondering if that is part of (the obsolete OS) your problem. I say this because I too run multiple instances on different ports and printing runs fine for me (5221_5152).
    Mike Brown - Contact Me
    Programmatic Technologies, LLC
    Programmatic-Technologies.com
    Independent Developer & Consultant

  4. #4
    Member
    Real Name
    Robyn Murphy
    Join Date
    Nov 2017
    Posts
    4

    Default Re: Error printing PDF reports with multiple instances/ports

    Long story about the 15 year old OS and the 15 year old Access application it was built on!
    Also issues with upgrading to latest Alpha so currently running version 4491-4932

    Generating standard reports is fine - it's only printing to PDF that fails with this error and only on alternate ports.
    I'm thinking it may not be an Alpha issue, but more a Windows security access issue.

  5. #5
    "Certified" Alphaholic
    Real Name
    Rich Fulham
    Join Date
    May 2011
    Location
    Portland, OR
    Posts
    1,021

    Default Re: Error printing PDF reports with multiple instances/ports

    I'd make sure your multiple instances of Alpha are installed into their own folders.
    Also, verify the folder paths used inside of each of your .xml configuration files point to separate folders for the various log files and stuff. You don't want the multiple instances clobbering each other.

    If you do not have every instance split out into its own set of folders then you may have some work ahead of you if your program creates any files on-the-fly that need to be copied to all of the instances. For example, in the Administrator's section of my application they can configure a bunch of things that generate CSS files which have to be distributed across the multiple instances of WAS. In SQL, I keep a list of the installed instance folders and write the dynamically created CSS files to each of the listed folders. Most likely you are not creating dynamic CSS files like my app and you won't have to worry about that. I have actually moved onto using just a single instance of Alpha running under IIS, and I no longer worry about multiple folder instances of the published application. Made my life much easier, but it was tricky getting to IIS.

  6. #6
    "Certified" Alphaholic
    Real Name
    Rich Fulham
    Join Date
    May 2011
    Location
    Portland, OR
    Posts
    1,021

    Default Re: Error printing PDF reports with multiple instances/ports

    P.S. There have been changes with the PDF printer driver on the server across the various versions of Alpha. If you have the multiple versions of Alpha installed, as I mentioned above, it is possible an installed instance does not have the right PDF stuff. I don't recall the folder structure for the installed PDF driver. But I do recall an instance where I installed a new version of Alpha into a folder and that install did not include the proper PDF driver stuff and I had to apply the Patch level update ( of the same build # as the full install) to get it working because the full installer had not included the correct PDF stuff.

  7. #7
    Member
    Real Name
    Robyn Murphy
    Join Date
    Nov 2017
    Posts
    4

    Default Re: Error printing PDF reports with multiple instances/ports

    Thanks for the reply Rich. I'm using a single copy of Alpha, but each instance has it's own config file in a separate folder, which (for my use case), is also the folder that I publish to for each instance. My dynamic CSS and images are actually generated at the back-end using session information and works fine. Each instance has separate logs, separate session folders, etc. I don't use IIS.

    Again, single Alpha installation so the PDF driver works with one app/folder/port, I can't see any reason why it wouldn't work with another. Unless it is a security or access issue which I'm yet to properly identify and resolve.

  8. #8
    Member
    Real Name
    Jmo
    Join Date
    May 2013
    Posts
    367

    Default Re: Error printing PDF reports with multiple instances/ports

    So I wanted to see if you got this issue resolved, I am having a similar issue and I believe the problem has to do with e.sessionFileKey not working properly when running multiple instances. If I run a single instance (using AlwaysUp and separate config files) I am able to print my HTML reports (on screen) and then download them as PDFs or email them using mandrill. However, as soon as I try to run 2 or more instances the PDFs stop working (can't email them or download them, the HTML report still shows on screen). When working in live preview I found that the e.sessionFileKey wasn't not working causing the blob data to not be turned into a PDF file. Any assistance with this issue would be greatly appreciated. I worked on another project (don't have access to it any longer) with a very similar setup and it worked just fine so not sure what is causing my issue this time around. I can see that each instance has it's own session folder and I feel like this may be the issue, though from what I have read it seems like they are suppose to do this. In my above scenarios I can see the PDF file in the session folder, it just seems the application can't find it properly using the e.sessionFileKey.

    Look forward to hearing what others have done to get this working.

Similar Threads

  1. Printing Multiple Reports
    By jrmplus in forum Mobile & Browser Applications
    Replies: 6
    Last Post: 03-10-2017, 08:29 AM
  2. Replies: 3
    Last Post: 03-29-2016, 05:33 PM
  3. possible error with multiple instances of a form
    By richard2007 in forum Alpha Five Version 8
    Replies: 14
    Last Post: 05-31-2008, 10:12 AM
  4. difficulty printing multiple reports
    By Bill Maguire in forum Alpha Five Version 5
    Replies: 1
    Last Post: 08-11-2005, 04:06 PM
  5. PRINTING MULTIPLE REPORTS
    By dorseya in forum Alpha Four Version 6 and Prior
    Replies: 6
    Last Post: 10-02-2002, 12:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •