Alpha Video Training
Results 1 to 7 of 7

Thread: Google Maps API problem?

  1. #1
    Moderator Steve Workings's Avatar
    Real Name
    Steve Workings
    Join Date
    Apr 2000
    Location
    The Dreaded Chair
    Posts
    5,595

    Default Google Maps API problem?

    I've been building a UX with the Google Maps API, all has been just fine. Tonight I viewed it and I got shaded map with "For development purposes only" all over it. The popup that occurs with this links to a page of "why this isn't working" but I've changed nothing -- the API key is still good, billing is not an issue, etc. etc.

    Anyone else using this API and have this undesirable change?

    Thanks
    -Steve


  2. #2
    "Certified" Alphaholic mikeallenbrown's Avatar
    Real Name
    Mike Brown
    Join Date
    Nov 2009
    Location
    United States
    Posts
    1,750

    Default Re: Google Maps API problem?

    My implementation appears to be working as expected.
    Mike Brown - Contact Me
    Programmatic Technologies, LLC
    Programmatic-Technologies.com
    Independent Developer & Consultant

  3. #3
    Member
    Real Name
    Joe Lavely
    Join Date
    Jun 2013
    Posts
    419

    Default Re: Google Maps API problem?

    No problems with mine.

  4. #4
    Moderator Steve Workings's Avatar
    Real Name
    Steve Workings
    Join Date
    Apr 2000
    Location
    The Dreaded Chair
    Posts
    5,595

    Default Re: Google Maps API problem?

    Thanks. Odd that my local development works just fine, but not when I implement to the server. Same API key, the works.
    -Steve


  5. #5
    Alpha Software Employee Beta Spark's Avatar
    Real Name
    Sarah Mitchell
    Join Date
    Jul 2015
    Posts
    424

    Default Re: Google Maps API problem?

    Quote Originally Posted by Steve Workings View Post
    I've been building a UX with the Google Maps API, all has been just fine. Tonight I viewed it and I got shaded map with "For development purposes only" all over it. The popup that occurs with this links to a page of "why this isn't working" but I've changed nothing -- the API key is still good, billing is not an issue, etc. etc.

    Anyone else using this API and have this undesirable change?

    Thanks
    Hello Steve,

    Google adds the watermark "for development purposes only" when any of the following is true:

    1. The Google API key is missing.
    2. You have not enabled billing on your account.
    3. The billing method is invalid (e.g. an expired credit card).
    4. You have exceeded a self-imposed daily limit.

    See https://developers.google.com/maps/d...error-messages for more information.
    Sarah Mitchell

    Looking for answers? Try our documentation.
    If you can't find something, let us know!

  6. #6
    Moderator Steve Workings's Avatar
    Real Name
    Steve Workings
    Join Date
    Apr 2000
    Location
    The Dreaded Chair
    Posts
    5,595

    Default Re: Google Maps API problem?

    Yup, visited that page a bunch of times Sarah. Finally fixed it, but I'm not sure what or how. Got enough to do right now that I'm leaving it at that.

    Thanks to all who responded here.
    -Steve


  7. #7
    Member
    Real Name
    Steven
    Join Date
    Oct 2011
    Posts
    637

    Default Re: Google Maps API problem?

    Which Map API do you create? Map Static API? If that is it, do you copy the URL signing secret into the Alpha Map Control API area?

Similar Threads

  1. Replies: 4
    Last Post: 05-31-2018, 05:10 PM
  2. Google maps using Google API don't show in a panel.
    By Michael1954 in forum Mobile & Browser Applications
    Replies: 4
    Last Post: 07-05-2016, 08:46 AM
  3. Maps Snap to Road in Google Maps
    By chadbrown in forum Mobile & Browser Applications
    Replies: 0
    Last Post: 05-04-2015, 02:04 PM
  4. Supercontrol map problem Google maps
    By Td203 in forum Alpha Five Version 11 - Desktop Applications
    Replies: 6
    Last Post: 09-29-2014, 01:47 AM
  5. Google Makes Subtle Change to Google Maps - Breaks Maps in Grids and Dialogs
    By Selwyn Rabins in forum Application Server Version 11 - Web/Browser Applications
    Replies: 14
    Last Post: 07-27-2012, 08:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •