Alpha Video Training
Results 1 to 3 of 3

Thread: Server caching classes

  1. #1
    Member
    Real Name
    Adam Parker
    Join Date
    Oct 2018
    Posts
    46

    Default Server caching classes

    So nobody wanted to touch my last post with a ten foot pole, I don't blame you.

    Since then I've upgraded to the latest version of Alpha, and I'm having different issues getting REST API functionality working that was running smoothly on a previous version.

    I'm receiving a "type not defined" error with a custom class, so I commented out the declarations to that custom class. However I am still getting the "type not defined" error, and I don't know why. I've completed removed any mention of the custom class, bounced the web app server, republished multiple times, no go.

    Please someone tell me what I am doing wrong here.

    Edit: This is using 6012_5338

  2. #2
    "Certified" Alphaholic
    Real Name
    Larry Grupido
    Join Date
    May 2010
    Posts
    1,820

    Default Re: Server caching classes

    Might be a little easier to help if we had any idea WHAT REST api was working and now is not.

    Do you have multiple APIs on multiple platforms and they are all failing or just a particular one?

    What version did you move from?

    Are you using code from one of Alpha's libraries or something you wrote yourself?

  3. #3
    Member
    Real Name
    Adam Parker
    Join Date
    Oct 2018
    Posts
    46

    Default Re: Server caching classes

    Thanks for the reply Larry.

    I think a reboot of the VM hosting the Alpha server was somehow able to rectify the situation. I have to believe Alpha was caching the .a5wclass files, otherwise nothing makes sense above.

    As for your questions, it was an API I wrote myself in Xbasic, and one of my UX had a viewbox that was calling it. I was previously using 5447_5206, but not sure that had anything to do with it.

Similar Threads

  1. Javascript caching
    By Steve Workings in forum Application Server Version 11 - Web/Browser Applications
    Replies: 41
    Last Post: 03-15-2013, 09:50 PM
  2. App Server and Classes
    By djvdm in forum Application Server Version 11 - Web/Browser Applications
    Replies: 4
    Last Post: 12-19-2012, 04:45 PM
  3. v11 Prevent HTM Files on alpha server from caching in user's browser
    By khorsed1018 in forum Application Server Version 11 - Web/Browser Applications
    Replies: 5
    Last Post: 08-27-2012, 01:51 PM
  4. Annoying Image Caching Problem with Alpha Web Server
    By shood38 in forum Application Server Version 11 - Web/Browser Applications
    Replies: 5
    Last Post: 03-27-2012, 04:18 PM
  5. CSS caching problem
    By Sparticuz in forum Application Server Version 10 - Web/Browser Applications
    Replies: 7
    Last Post: 12-14-2009, 08:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •