Alpha Video Training
Results 1 to 16 of 16

Thread: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in a UX

  1. #1
    Member
    Real Name
    Mark Moss
    Join Date
    Aug 2015
    Posts
    38

    Default Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in a UX

    Forum Wizards,


    I have watched your Video 'Edit the Current Row in a List Control in another UX Component' UXL-V12-49, and read the Documentation on Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in a UX


    I have created the New Child UX which has 6 fields on it and Bound it to the same table as the Parent UX. I have mapped the Data Fields from the Parent UX to the Component Fields on the Child UX. When the Parent UX invokes the Child UX it pops up with the data from the List component in the Parent UX in 5 of the 6 fields.

    I can modify and save the data in the other fields, but the 6th field does not show any data and if I place any values into it they are not saved.


    There is nothing special about this field and I have gone back and checked it against the other fields and nothing sticks out.

    Any ideas on what might cause this issue


    Mark
    Last edited by markemoss; 10-03-2019 at 04:10 PM. Reason: Lost almost all of post when I submitted it

  2. #2
    Member
    Real Name
    Mark Moss
    Join Date
    Aug 2015
    Posts
    38

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Forum Wizards,


    I have watched your Video 'Edit the Current Row in a List Control in another UX Component' UXL-V12-49, and read the Documentation on Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in a UX


    I have created the New Child UX which has 6 fields on it and Bound it to the same table as the Parent UX. I have mapped the Data Fields from the Parent UX to the Component Fields on the Child UX. When the Parent UX invokes the Child UX it pops up with the data from the List component in the Parent UX in 5 of the 6 fields.

    I can modify and save the data in the other fields, but the 6th field does not show any data and if I place any values into it they are not saved.


    There is nothing special about this field and I have gone back and checked it against the other fields and nothing sticks out.

    Any ideas on what might cause this issue


    Mark

  3. #3
    Alpha Software Employee Selwyn Rabins's Avatar
    Real Name
    Selwyn Rabins
    Join Date
    Mar 2000
    Location
    Boston, MA
    Posts
    5,298

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    i suspect that there is no data binding defined for the 6th field whereas all of the other 5 fields have the correct data binding defined.

  4. #4
    Member
    Real Name
    Mark Moss
    Join Date
    Aug 2015
    Posts
    38

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Selwyn,



    Thank you so much for your reply, but attached please find a Screen Shot of the 'Bind Controls for Fields' clearly showing the Service_Status field bound to the Table's Service_Status.



    Mark


    BindControls.JPG

  5. #5
    Alpha Software Employee Selwyn Rabins's Avatar
    Real Name
    Selwyn Rabins
    Join Date
    Mar 2000
    Location
    Boston, MA
    Posts
    5,298

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    please attach a test case. your test case will include both the component and a backup of the sql database.

  6. #6
    Member
    Real Name
    Sean OKelly
    Join Date
    Sep 2015
    Location
    Charleston, WV
    Posts
    242

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Does the parent UX list have all the same fields associated with it? I'm thinking that the parent and sibling aren't matching...

  7. #7
    Member
    Real Name
    Mark Moss
    Join Date
    Aug 2015
    Posts
    38

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Sean,


    Thank you so much for your reply, but no the parent has many more fields than the Child, but the child is being sent the Six Fields that it needs as Arguments that the child is requesting. 5 of the 6 get and display the data correctly, but the 6th field does not and if you look it is actually the second field in the list.


    Mark

  8. #8
    Member
    Real Name
    Jeremy Scrime
    Join Date
    Sep 2015
    Posts
    99

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    I ran into this issue last week. I ended up rebuilding the form from scratch after various attempts to resolve the problem. Hopefully the issue can be identified as the alternate solution I have is not all that practical.

  9. #9
    "Certified" Alphaholic peteconway's Avatar
    Real Name
    Peter Conway
    Join Date
    Oct 2005
    Location
    Melbourne, Australia
    Posts
    2,642

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    One is a date type and one is a time type, what happens if you make them both the same?
    Insanity: doing the same thing over and over again and expecting different results.
    Albert Einstein, (attributed)
    US (German-born) physicist (1879 - 1955)

  10. #10
    Member
    Real Name
    Mark Moss
    Join Date
    Aug 2015
    Posts
    38

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Peter,


    I see what you mean with the Date/Time Field differeance, however the field that was not working properly was the Service_Status field.


    Mark

  11. #11
    "Certified" Alphaholic peteconway's Avatar
    Real Name
    Peter Conway
    Join Date
    Oct 2005
    Location
    Melbourne, Australia
    Posts
    2,642

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Re ‘Service_Status’ - Could be some reserved words in there (who knows what they are these days) try changing the name.
    Insanity: doing the same thing over and over again and expecting different results.
    Albert Einstein, (attributed)
    US (German-born) physicist (1879 - 1955)

  12. #12
    Member
    Real Name
    Jeremy Scrime
    Join Date
    Sep 2015
    Posts
    99

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Once again this issue has resurfaced for a third time. I simply added a Label control to my UX and bound that to a table that was already joined to in my Data Binding Settings.

    No matter what I do, I cannot get the value to display anything in the control (all I get is a label with an empty value for the field). I'm certain it has a value because the calling screen shows the value I'm expecting to see. It's also not tied to any specific record or value as I've tried multiple combinations...

    Another developer in our office encountered this last week. It's very annoying and currently, the only workaround I know of is a complete rebuild of the form from scratch. I tried adding the control, removing all data binding, re-binding my controls... But that seemed to make it worse as now more controls that were displaying data were now no longer displaying data. I used the Bulk Operations to rebuild the component, manifest files, etc, etc.

    I can't rebuild every form that this happens with as it seems to be something that is coming up more than I'd like.

  13. #13
    Alpha Software Employee Selwyn Rabins's Avatar
    Real Name
    Selwyn Rabins
    Join Date
    Mar 2000
    Location
    Boston, MA
    Posts
    5,298

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    you don't say what build you are using, but unless I misunderstand what you are reporting here, I don't think that there is an issue, as shown in this video

    https://www.screencast.com/t/IeeCPR0F

  14. #14
    Member
    Real Name
    Sean OKelly
    Join Date
    Sep 2015
    Location
    Charleston, WV
    Posts
    242

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Hi Jeremy,

    Have you tried deleting the action in the parent component (if it's a button - delete that) and then rebuild the button and action?

  15. #15
    Member
    Real Name
    Jeremy Scrime
    Join Date
    Sep 2015
    Posts
    99

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    Thanks Sean, I tried your suggestion but I am still unable to get Alpha to populate the newly added control. I'll keep trying and post any solutions I may come across as I know others are randomly encountering this issue.

  16. #16
    Member
    Real Name
    Barry Canfield
    Join Date
    May 2009
    Posts
    26

    Default Re: Issue with- Open a UX component to Edit Current Record in List Control in a UX, or add a new Record to a List Control in

    I have the same issue. The application has worked for the last 4 years, adding fields over time. recently on the last 3 UX components where i have added a new field it has failed to bind and update. The binding and configuration of everything is correct - done it 100’s of times. The only way to get it to work is to delete all the tables/bindings, create the tables and re-bind. This is a very lengthy job to add a single new field. As I said at the start this has never happened until the last 3 occasions.

Similar Threads

  1. Replies: 19
    Last Post: 07-30-2018, 05:14 AM
  2. How to open a report based on current list control filter?
    By Gatorfan in forum Mobile & Browser Applications
    Replies: 10
    Last Post: 06-22-2016, 12:44 PM
  3. Open UX Component to Edit the Current Record in a List Control
    By rvanderbes in forum Mobile & Browser Applications
    Replies: 2
    Last Post: 05-19-2014, 01:02 PM
  4. List control select current record
    By jmsilva in forum Mobile & Browser Applications
    Replies: 8
    Last Post: 05-15-2014, 10:34 PM
  5. Setting default value of control from list control when adding new record
    By jrmplus in forum Mobile & Browser Applications
    Replies: 8
    Last Post: 01-26-2014, 05:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •