Alpha Video Training
Results 1 to 5 of 5

Thread: Application Server Running on Windows Server 2016 works only on localhost

  1. #1
    Member
    Real Name
    Isang Udo-Akagha
    Join Date
    Aug 2011
    Location
    Lagos, Nigeria
    Posts
    121

    Default Application Server Running on Windows Server 2016 works only on localhost

    I have this small but very big problem after migrating my websites on vps from the older windows server 2008 to the modern windows 2016 server which is quite new to me. Alpha Anywhere sever installs fine on the new VSP, the web files and folders are moved into place and Alpha anywhere full license key is running fine. The website show up normally when browsing from the server machine itself but not when browsing from any other computer on earth.

    I understand we need to open up "SERVER MANAGER" and add some certain "ROLES AND FEATURES" before it works but I am still struggling to find the exact "ROLES AND FEATURES" to add, before Windows Server 2016 will let me have some peace. I am not doing ISS for now. Just native alpha application server on dbf database.

    Any help? Thanks

  2. #2
    Volunteer Moderator Steve Wood's Avatar
    Real Name
    Steve Wood
    Join Date
    Nov 2003
    Location
    Bay Area, California
    Posts
    8,842

    Default Re: Application Server Running on Windows Server 2016 works only on localhost

    There is not enough information here. PM me the public ip address so I can see what actually appears in the browser when attempting to access the website.
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

  3. #3
    Member
    Real Name
    Isang Udo-Akagha
    Join Date
    Aug 2011
    Location
    Lagos, Nigeria
    Posts
    121

    Default Re: Application Server Running on Windows Server 2016 works only on localhost

    WS 2016 is build in such a way that nothing really works until you choose which features and needed for your application. Please take a look at the following link. It's a guide for developers using a sever application called vfire, which can also be installed on a VPS. What they have done is to provide this guide for their developers who choose to deploy on Windows Server 2016. Alpha developers who are new to WS 2016 will need some sort of guide like this, so that we know which features of WS 2016 to enable.

    I hope this explains better.

    https://www.alemba.help/help/content...g%20server.htm

    Thanks

  4. #4
    Volunteer Moderator Steve Wood's Avatar
    Real Name
    Steve Wood
    Join Date
    Nov 2003
    Location
    Bay Area, California
    Posts
    8,842

    Default Re: Application Server Running on Windows Server 2016 works only on localhost

    Did you get your server working from outside your localhost yet? Most likely your issue is a simple firewall issue. Try disabling your firewall temporarily and see if you can gain access from outside. If that works, then you need to add the Alpha Anywhere to your framework as an allowed application. And, you might need to open port 80 and/or port 443 if they are purpously closed on your server. If it fails, please make a screenshot of what you do see so we can tell what is happening. I don't recall making any changes to Roles and Features for my Windows 2016 installation. If anything, it would be to install .Net Framework.
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

  5. #5
    Member
    Real Name
    Isang Udo-Akagha
    Join Date
    Aug 2011
    Location
    Lagos, Nigeria
    Posts
    121

    Default Re: Application Server Running on Windows Server 2016 works only on localhost

    I've just turned off windows firewall and it works.

Similar Threads

  1. Potential Watch out for Windows Server 2016 October Update/Fix
    By ssmoore1 in forum Mobile & Browser Applications
    Replies: 0
    Last Post: 10-15-2018, 12:17 AM
  2. Trouble installed Alpha Anywhere on windows virtual server 2016
    By Mike Reed in forum Mobile & Browser Applications
    Replies: 3
    Last Post: 10-28-2017, 08:00 PM
  3. Windows server 2016 and Version 11
    By Ronald Anusiewicz in forum Alpha Five Version 11 - Desktop Applications
    Replies: 5
    Last Post: 04-27-2017, 06:34 AM
  4. Lookup flyout grid works on localhost but not on the web server
    By gfspeter in forum Application Server Version 11 - Web/Browser Applications
    Replies: 10
    Last Post: 06-11-2013, 03:08 PM
  5. vps localhost v. application server
    By Jay Talbott in forum Application Server Version 8
    Replies: 4
    Last Post: 05-29-2009, 12:05 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •