Alpha Video Training
Results 1 to 6 of 6

Thread: Problem with V11 and hotmail.com

  1. #1
    Member
    Real Name
    Jon P Moody
    Join Date
    Nov 2016
    Posts
    196

    Default Problem with V11 and hotmail.com

    We've had a client complain that if they send an email to a hotmail.com address any reply sent by the addressee does not arrive. If the hotmail.com user starts a new conversation the message is successfully delivered.

    We have tested this on V11 and V12 and the problem only occurs if the originating email is generated/sent from V11. Any reply is in the hotmail sent folder, but it is not delivered to any address on the list. Forwarding also appears to be broken.

    It doesn't seem to matter what method we use to generate the email or what transmission method we use.

    Not expecting a solution (though if you have one, I'd be eternally grateful), just wanted to warn others of the issue.

  2. #2
    "Certified" Alphaholic
    Real Name
    Gregg Schmidt
    Join Date
    Mar 2001
    Location
    Milwaukee
    Posts
    1,406

    Default Re: Problem with V11 and hotmail.com

    Hi Jon,

    I am sure this may sound like a crazy question, but what method do you use, and what email address do you expect the reply to go to ?

  3. #3
    Member
    Real Name
    Jon P Moody
    Join Date
    Nov 2016
    Posts
    196

    Default Re: Problem with V11 and hotmail.com

    Gregg,

    We use both the reportmailer bolt-on and email_smtp_send. Reply address is the sender of the original email - doesn't matter what this is (gmail, yahoo etc.) the replies don't get through.

    As I said above, not expecting a solkution, just wanted to let others know of the problem.

  4. #4
    "Certified" Alphaholic
    Real Name
    Gregg Schmidt
    Join Date
    Mar 2001
    Location
    Milwaukee
    Posts
    1,406

    Default Re: Problem with V11 and hotmail.com

    Hi Jon,

    I just tried with my system, and it worked great.
    I am including my email function as well as pics of the emails from the test.
    Just to be fair, I also tried this using a gmail account as the sender.
    The message went to the spam folder, but the reply came directly to the Hotmail inbox.

    Code:
    'Date Created: 20-Oct-2012 08:09:14 PM
    'Last Updated: 22-May-2017 09:27:12 PM
    'Created By  : Gregg
    'Updated By  : Gregg
    
    FUNCTION autoemail AS L (sub AS C, msg AS C,attfile as c ,whofrom as  c,whoto as c,rr as l)
     dim pm as P
    
    dim ps as P
    ps.timeout = 7000
    if (email_smtp_open(ps, <yourEmailServer>, 25, <accountOnyourEmailServer>, <password>)) then
    
        pm.to = whoto
    
        pm.from = whofrom
    
        pm.subject = sub
    
    '    pm.message = msg
    
    
        pm.html_message = msg
        pm.attachments = attfile
    	pm.returnreceipt = rr
        email_smtp_send(pm, ps)
        
        autoemail=.t.
        
        else
        autoemail = .f.
    
    end if
    
    email_smtp_close(ps)
    END FUNCTION
    a5mail01.PNGa5mail02.PNGa5mail03.PNGa5mail04.PNGa5mail05.PNG

  5. #5
    Member
    Real Name
    Jon P Moody
    Join Date
    Nov 2016
    Posts
    196

    Default Re: Problem with V11 and hotmail.com

    Gregg,

    Problem is that replies FROM Hotmail don't arrive NOT replies to Hotmail.

    It now appears that the problem is with the built-in Alpha functions email_send() and email_send2() and whatever Reportmailer uses (this is from 10.5 so may be even older code) as we have successfully tested emailing using the EMAIL_SMTP_OPEN(), _SEND() and _CLOSE() functions.

  6. #6
    "Certified" Alphaholic
    Real Name
    Gregg Schmidt
    Join Date
    Mar 2001
    Location
    Milwaukee
    Posts
    1,406

    Default Re: Problem with V11 and hotmail.com

    Hi Jon,
    I just used reply from Hotmail for both examples, and that came through.
    The replies came through as expected, even directly to the inbox.

    I see you're using the report mailer (I gave up on that a long time ago).
    The function I provided allows attachments.
    I hope this helps.

Similar Threads

  1. A5 Integration into Facebook, LinkedIN and Hotmail/Gmail
    By Dezza in forum Application Server Version 11 - Web/Browser Applications
    Replies: 0
    Last Post: 11-30-2012, 12:08 PM
  2. Web Project Properties - Hotmail email settings
    By Steve Workings in forum Application Server Version 11 - Web/Browser Applications
    Replies: 9
    Last Post: 11-28-2011, 06:36 AM
  3. Email settings using Hotmail
    By Michael Humby in forum Alpha Five Version 10 - Desktop Applications
    Replies: 19
    Last Post: 05-30-2011, 03:55 PM
  4. Email using web based like hotmail
    By masteralone in forum Alpha Five Version 7
    Replies: 0
    Last Post: 07-01-2006, 11:33 PM
  5. hotmail e-mail settings!?
    By biber yashar in forum Alpha Five Version 5
    Replies: 5
    Last Post: 12-30-2003, 02:41 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •