Alpha Video Training
Results 1 to 2 of 2

Thread: Default Data Entry in Embedded Browse Problem

  1. #1
    Barbara Collins
    Guest

    Default Default Data Entry in Embedded Browse Problem

    Okay, I have a set that has a file called Family.dbf, with a couple of databases connected as One to Many.
    Children.dbf
    Lineitems.dbf
    Payments.dbf
    Notes.dbf

    I have them on a form linked by a field called IDNUM. To speed data entry, I would like to set the Date field in Lineitems, to default to Previous Value.

    My problem is that it works okay for the first family, but the next family it finds the previous value that was enter for that Family.

    Any ideas?

    Barb

  2. #2
    "Certified" Alphaholic forskare's Avatar
    Real Name
    Ken Nordin
    Join Date
    Apr 2000
    Location
    Walker, MN
    Posts
    7,545

    Default RE: Default Data Entry in Embedded Browse Problem

    Hi Barbara,

    It's doing what it's supposed to do so ya have to go to plan "B".

    Go to the form's properties and select Actions. Put htis code on the OnKey event. When entering data, anytime you want to copy the data (or date) from the last record to the current record, press the F-12 key.

    if a_user.key.value = "{F12}"
    a_user.key.handled = .T.
    sys_send_keys("{CTRL-SHIFT-F}")
    '{ENTER}")
    'sys_send_keys("{RIGHT}")
    end if

    OK, that's not quite what you wanted but it's a manual way and better than a poke in the eye with a sharp (or dull) stick.

    Put this code in the date field's OnArrive event. I haven't tried it but it might work. Perhaps others, more knowledgible with Xbasic than I, may have a better idea.

    sys_send_keys("{CTRL-SHIFT-F}")
    '{ENTER}")
    'sys_send_keys("{RIGHT}")
    end if

    kenn

Similar Threads

  1. popup disappearing in embedded browse data entry
    By Jenny Lynch in forum Alpha Five Version 6
    Replies: 6
    Last Post: 02-24-2005, 01:57 PM
  2. Data Entry - Embedded Xdialog
    By forskare in forum Alpha Five Version 5
    Replies: 4
    Last Post: 08-03-2004, 06:57 PM
  3. Data appears missing in default browse
    By russellroad in forum Alpha Five Version 5
    Replies: 7
    Last Post: 03-04-2004, 09:34 AM
  4. Safe embedded browse entry at last in A5V5?
    By Greg Fong in forum Alpha Five Version 4
    Replies: 9
    Last Post: 03-31-2002, 05:41 PM
  5. Default Value in Data Entry
    By Jeff, Richards in forum Alpha Five Version 4
    Replies: 5
    Last Post: 11-26-2001, 01:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •