Alpha Video Training
Results 1 to 7 of 7

Thread: Disappearing data in set

  1. #1
    David Johnson
    Guest

    Default Disappearing data in set

    I have a set on medical treatments. The main data set is named Treatcard and contains the treatment date and treatment number. The next data set is the patients on a one to one relationship with treatcard. The final child data set is treatment and is a one to many relationship with the patient.
    After many hours of work setting up what should be a very straightforward set, I finally got it to perform the way I intended it to.
    After entering 50+ Treatcard records, not to mention the ones in the patient and medicals data sets, I felt proud of my endeaver.
    When I opened the set hours later much to my dissappointment and anger 11 records had incomplete information. The Treatcard information was there but the other two parts were blank. I then remembered why I shelved A5 before, it is unreliable and unstable.
    I got two error messages which kicked me out of the program: Invalid page fault at module AZINPUT.dll and the same at MFC40.dll.
    I need some help quick or this thing is going in the round file very soon.
    I can reenter the data but that is not what should happen.
    Thanks Dave

  2. #2
    Member
    Real Name
    robert adler
    Join Date
    Apr 2000
    Location
    Boynton Beach, BL
    Posts
    591

    Default RE: Disappearing data in set

    Dave:
    I can understand your frustration, but you have not indicated what key structure exists between each table in the set. Have you check the contents of each table for the data in question? Is it possible that he keys are not matched corectly?

    I and others have defined many simple and complex data set structures in A5. The loss of data within a set is not a normal occurrence when the keys are defined correctly. If this is not the problem I would be willing to look at your system if you attach to your response.

    bob adler

  3. #3
    "Certified" Alphaholic Stan Mathews's Avatar
    Real Name
    Stan Mathews
    Join Date
    Apr 2000
    Location
    Bowling Green, KY
    Posts
    25,119

    Default RE: Disappearing data in set

    Dave,

    If you do a search on the board there are 411 references to disappearing data. Mostly they deal with indexes or table links which are set to filter out data through some expression.

    The first thing to check is the default browse for your set. If the data is there, the problem lies in how the data is presented by whatever layout you are viewing.

    Alpha has it's quirks, but I don't think "unreliable" is a fair assessment.

    Good luck.

    Stan

  4. #4
    "Certified" Alphaholic forskare's Avatar
    Real Name
    Ken Nordin
    Join Date
    Apr 2000
    Location
    Walker, MN
    Posts
    7,545

    Default RE: Disappearing data in set

    David,

    When I have data that's missing, the first thing I check is the primary index. Most of the time it's set to record number. Once I set the primary index, the data 'mysteriously' appears.

    Stan is correct, A5 has it's quirks but most of the 'quirks' are our own doing.

    kenn

  5. #5
    David Johnson
    Guest

    Default RE: Disappearing data in set

    Dear Stan,
    The data is not in the default browse.
    thanks for the suggestion but unreliable is high on my list.
    if the data was there and everything worked as it should , I made no changes to any index or any other part of the program, what caused the data to disappear?
    Thanks Dave

  6. #6
    David Johnson
    Guest

    Default RE: Disappearing data in set

    Dear Bob,
    The Parent data set is treatrecord, it contains only the treatment record number and the treatment date. The first child data set is called heifers and contains the heifer tag number, the owner and the date of birth. it is tied tthe treatrecord data set by a one to one relationship. it appears in a subform on the treatment set form. The second child data set is called treatment and contains the treatment date, symptoms, treatment, dose, cost each and treatment cost. The relationship to heifers is a one to many. It is in asubbrowse form on the treatrecord form. to round out the form is a total field to total the cost of the treatments of this particular heifer on this particular day. If she is treated the next day or the next week it becomes a new record. My main purpose is to keep track of the total treatment cost for each heifer while she is under my care. Iused the report genie to create a simple report to show the costs for each heifer for the month with a subtotal each time the tag number changes and a grand total for each owner at the bottum of the report.
    If you think there is somthing wrong with the stucture I would send you a coppy.
    No one said anything about the error messages, does this mean I am the only person to ever get them or what?
    Thanks Dave

  7. #7
    "Certified" Alphaholic Stan Mathews's Avatar
    Real Name
    Stan Mathews
    Join Date
    Apr 2000
    Location
    Bowling Green, KY
    Posts
    25,119

    Default RE: Disappearing data in set

    "I made no changes to any index"

    First question is do you have any indexes defined?
    When you open the default browse, the last used index or query is in effect. Are you looking at the browse in record number order? (CTRL-I to select an index, what is in effect?)

    If you are in the default browse and record number order is the current index and the records are missing, then there is a problem.

    Why not zip up a sample an attach it to a post and let us take a look?

Similar Threads

  1. My data is disappearing
    By Susan Schlueter in forum Alpha Five Version 6
    Replies: 2
    Last Post: 05-17-2005, 10:32 AM
  2. Disappearing Data
    By Paul DeLosa in forum Alpha Five Version 5
    Replies: 4
    Last Post: 10-14-2004, 02:31 AM
  3. DATA DISAPPEARING
    By LEGRAN in forum Alpha Five Version 6
    Replies: 5
    Last Post: 08-02-2004, 04:51 PM
  4. Disappearing Data
    By fairviewcomputing in forum Alpha Five Version 4
    Replies: 8
    Last Post: 06-19-2002, 06:29 AM
  5. DATA DISAPPEARING
    By josephalee in forum Alpha Four Version 6 and Prior
    Replies: 0
    Last Post: 01-29-2001, 12:24 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •