Alpha Video Training
Results 1 to 7 of 7

Thread: Negative Number Display

  1. #1
    "Certified" Alphaholic
    Real Name
    JohnZaleski
    Join Date
    Oct 2000
    Posts
    1,736

    Default Negative Number Display

    Apologies in advance for not researching this first, but I'm not able to at this time. On forms when data is being added or changed and numeric amounts are entered as negative, they display as positive until record is saved. Anyone know anything about this???
    John

  2. #2
    "Certified" Alphaholic Stan Mathews's Avatar
    Real Name
    Stan Mathews
    Join Date
    Apr 2000
    Location
    Bowling Green, KY
    Posts
    25,119

    Default RE: Negative Number Display

    Mine don't.

  3. #3
    "Certified" Alphaholic
    Real Name
    JohnZaleski
    Join Date
    Oct 2000
    Posts
    1,736

    Default RE: Negative Number Display

    Stan,
    Thanks for the reply.
    I've got 4.5 Build 263. Are you on the same version???
    John

  4. #4
    "Certified" Alphaholic Stan Mathews's Avatar
    Real Name
    Stan Mathews
    Join Date
    Apr 2000
    Location
    Bowling Green, KY
    Posts
    25,119

    Default RE: Negative Number Display

    Yep.

    I tried several formatting options for the numeric field and was always able to enter the minus (-) first and it stayed while I entered the rest of the digits.

    Just tried a couple of settings changes in the control panel (Windows regional settings) and I still don't see a problem.

    What is the sequence of steps you are taking?

  5. #5
    "Certified" Alphaholic
    Real Name
    JohnZaleski
    Join Date
    Oct 2000
    Posts
    1,736

    Default RE: Negative Number Display

    Stan,
    This is happening for all forms. I even created a new test database with one table and one form and it's happening. The test table had no field rules and the form had nothing but the fields on it.

    If I start entering a record and put a negative value in a numeric field, and leave the field (enter mouse or tab) the field does not display as negative. After leaving the field, if I back up into the field it then displays as negative, and if I leave the field again, for the most part, it will then display as negative. Once saved, even if I don't back up into the field, it will then display as negative. The field is always negative, it just doesn't display as such after first entering a value or changing a value to a different value.

    I did update the dll Cian posted ( a2cntrl.dll ) to remedy another problem with percents. This could be the culpprit.
    John

  6. #6
    "Certified" Alphaholic
    Real Name
    JohnZaleski
    Join Date
    Oct 2000
    Posts
    1,736

    Default RE: Negative Number Display

    Stan,
    Here's proof that talking out a problem helps. The
    a2cntrl.dll was the problem. For anyone looking at this, this was a fix posted by Cian early in the 4.5 game to fix percentage displays.
    John

  7. #7
    Frederic Thompson
    Guest

    Default RE: Negative Number Display

    Where can I find the update, I cannot save an opened form.

Similar Threads

  1. negative number input
    By kevinsmith in forum Alpha Five Version 6
    Replies: 2
    Last Post: 10-31-2004, 02:21 PM
  2. Transposing a negative number to a blank field
    By Charles Scott in forum Alpha Five Version 5
    Replies: 2
    Last Post: 02-16-2004, 04:12 AM
  3. Total using negative number
    By NBGH in forum Alpha Five Version 5
    Replies: 9
    Last Post: 05-26-2003, 01:41 PM
  4. Display Negative Numbers in Parenthesis
    By Steve Canepari in forum Alpha Five Version 5
    Replies: 6
    Last Post: 03-06-2003, 04:49 AM
  5. Negative Number Instead of Positive Number
    By forskare in forum Alpha Five Version 4
    Replies: 3
    Last Post: 01-02-2002, 09:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •