Alpha Video Training
Results 1 to 7 of 7

Thread: Printing bug (con't)

  1. #1
    Member
    Real Name
    Eric Johnson
    Join Date
    Apr 2000
    Posts
    171

    Default Printing bug (con't)

    I note that earlier there was a mention of a printing bug that someone discovered in 4.5. I've been seeing something similar since very early in Version 4.

    I've attached a reduced verison of a database that demonstrates this. This is a database used to keep track of department policy documents. The one report included shows the problem at the bottom of page 4 and the top of page 5. The text "Separation from Employment" is the name of a policy numbered 60-70. The title appears at the bottom of page 4 while the balance of the record appears on page 5.

    I've played with this a good bit to see what the driving issue is. I've managed to avoid the bug by fiddling with the height of the detail record. However, each time the report is run, I have to check to see if the bug shows up and if so, by trial and error move the detail record height to get it to go away. This isn't a useful solution.

    Eric Johnson

  2. #2
    Member
    Real Name
    Eric Johnson
    Join Date
    Apr 2000
    Posts
    171

    Default RE: Printing bug (con't)

    I forgot to mention there's a second manifestation of this problem....this or a closely related one....at the bottom of page 2 and the top of page 3. The title is split over the 2 pages although the report design calls for records to be kept together on a page.

    Eric Johnson

  3. #3
    "Certified" Alphaholic
    Real Name
    Tom Cone Jr
    Join Date
    Apr 2000
    Location
    Florida
    Posts
    23,311

    Default RE: Printing bug (con't)

    Try unchecking the 'repeats on page/group break' property of the group's header settings.

    Using vers. 4.03 build 230 this seemed to print just fine.

  4. #4
    Member
    Real Name
    Eric Johnson
    Join Date
    Apr 2000
    Posts
    171

    Default RE: Printing bug (con't)

    Well.....I wonder why I had that set.

    Anyway, good news and bad news. I removed that and indeed in the sample I sent, the problem went away. Then I went to the real database and made the change and the problem went away. Then I reduced the size of the detail section slightly to tighten the report composition a bit. Bang! The problem re-occurred. Then I went to the sample I'd posted here and got the same result.

    Thanks but it appears the problem just isn't that simple. I do woner why I had that option set however.

    Eric

  5. #5
    "Certified" Alphaholic
    Real Name
    Tom Cone Jr
    Join Date
    Apr 2000
    Location
    Florida
    Posts
    23,311

    Default RE: Printing bug (con't)

    Eric, I wonder if your tightening the detail section is what's causing the problem. If I were you, and the report ran fine with just a tad more white space between lines in the detail section, I'd accept the layout... on the theory that my head would stop hurting as soon as I put the hammer back in the toolbox.

    My guess is that when Alpha Five calculates remaining space at the bottom of the page it must take a number of things into consideration, including font size and type, line height, page size, top and bottom margins, footers, headers, and a host of other things including the amount of 'white space' specified in the detail band in your report layout. In my book close enough is good enough. I don't expect my database engine to have the capabilities of a desktop publishing program. If I needed closer tolerances I'd probably export the data and do the report using other tools.

  6. #6
    Member
    Real Name
    Eric Johnson
    Join Date
    Apr 2000
    Posts
    171

    Default RE: Printing bug (con't)

    Tom-

    I understand what you are saying and don't necessarily disagree. However, the history of this thing is that as the report data varies, the problem comes and goes. There doesn't appear to be any single setting of the detail section that makes it disappear for good. That kind of unpredictability makes a work-around difficult to live with.

    Eric

  7. #7
    "Certified" Alphaholic
    Real Name
    Tom Cone Jr
    Join Date
    Apr 2000
    Location
    Florida
    Posts
    23,311

    Default RE: Printing bug (con't)

    Eric, I suggest you increase the white space (vertical height) in the detail band (region) a bit. Also it's important that the vertical height of the field object be tall enough to contain the text you are trying to print, considering font size and type. Since the text changes from record to record this can be a bit tricky, but should settle down pretty quickly. Add a bit of vertical room here too if you continue to have problems.

Similar Threads

  1. Printing
    By Brandon Burtnik in forum Alpha Five Version 6
    Replies: 6
    Last Post: 09-02-2005, 01:21 PM
  2. printing
    By richie V in forum Alpha Four Versions 7 and 8
    Replies: 0
    Last Post: 01-03-2005, 09:35 AM
  3. USB Printing
    By AlexW in forum Alpha Four Versions 7 and 8
    Replies: 10
    Last Post: 02-25-2004, 10:13 PM
  4. Printing on 11 1/2 x 17
    By Nip Lewis in forum Alpha Five Version 4
    Replies: 1
    Last Post: 02-13-2003, 08:32 AM
  5. Printing???
    By Thomas Henkel in forum Alpha Five Version 4
    Replies: 8
    Last Post: 09-21-2001, 03:54 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •