Alpha Video Training
Results 1 to 5 of 5

Thread: can't change field rules

  1. #1
    Becky McNichols
    Guest

    Default can't change field rules

    I need to make a simple change in a set's field rules, but every time I open the field rules, I get the message:
    "The database/set is being used by another user or in another session and could not be opened in exclusive mode. Field rules can be viewed but no changes can be saved"
    I'm using a stand-alone PC (no network). I get this message even when I first start up my computer and choose the set first thing. (A form is opened on entry, but it is attached to another table.) The set is not listed under the "Windows" screen. I tried deleting my app's *.muf file - no difference.

    What's going on? Thanks in advance.

  2. #2
    "Certified" Alphaholic Stan Mathews's Avatar
    Real Name
    Stan Mathews
    Join Date
    Apr 2000
    Location
    Bowling Green, KY
    Posts
    25,119

    Default RE: can't change field rules

    Can only suggest that you try compacting. Something is corrupted somewhere.

  3. #3
    Jake Vuckovic
    Guest

    Default RE: can't change field rules

    You might get some clue of what's happening if you look into xbasic explorer immediately after you open the application (since you say it happens even first time you open it).
    You'll be able to see all open sessions and windows and you'll see if the table in question is being used.

    From View menu, choose "Code editor", then if you don't see xbasic explorer, choose "Xbasic explorer" from View menu again.
    Jake

  4. #4
    "Certified" Alphaholic
    Real Name
    William Hanigsberg
    Join Date
    Apr 2000
    Location
    Toronto, ON
    Posts
    4,018

    Default RE: can't change field rules

    Becky,

    You write that,

    "A form is opened on entry, but it is attached to another table."

    Do you have an autoexec script which runs on load and opens another session? Is it possible that the other table is part of your set? I assume you've verified this but otherwise you have a mystery.

    Jake's method will find any open session but you still need to figure out what's opening it.

    Bill

  5. #5
    Becky McNichols
    Guest

    Default RE: can't change field rules

    Yes- soon after posting this I realized that although the table that the opening form was attached to was not the table I was trying to modify, I WAS part of the set. The problem was easily solved by closing that table first.
    Thanks for your replies - really appreciate the advise.

Similar Threads

  1. field rules lookup table and field to fill
    By rleunis in forum Web Application Server v6
    Replies: 5
    Last Post: 09-22-2005, 06:33 AM
  2. A4V6 unable to change field rules
    By Gary Botstein in forum Alpha Four Version 6 and Prior
    Replies: 2
    Last Post: 03-05-2003, 04:59 PM
  3. Can't change table field rules
    By John Gamble in forum Alpha Five Version 4
    Replies: 3
    Last Post: 08-23-2001, 02:40 PM
  4. change in posting rules
    By Jeff Maples in forum Announcements
    Replies: 2
    Last Post: 03-23-2001, 02:26 AM
  5. How to change field rules on a clients machine?
    By Noble Bell in forum Alpha Five Version 4
    Replies: 8
    Last Post: 02-07-2001, 10:41 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •