New call-to-action
Results 1 to 4 of 4

Thread: Qlinker and A5V5

  1. #1
    Carl Schmid
    Guest

    Default Qlinker and A5V5

    Every time I try to export a data from a table from alpha5
    to quickbooks using qliker I get this message:
    ODBC-connection to "Visual Fox Pro Tables" failed... error
    occured at line 770. Can anybody tell me what this means and how to resolve the problem.

    Thanks
    Carl

  2. #2
    Lee Furr
    Guest

    Default RE: Qlinker and A5V5

    Carl,

    I get the same message when attempting an export:

    ODBC-connection to "Visual Fox Pro Tables" failed... error occured at line 770.

    I also get the message (when attempting an import) concerning the "a5conv.dbf" file/object not being found:

    "Error The Microsoft Jet Database Engine could not find the object a5conv.dbf. Make sure the object exists and that that you spell its name and the pathmane correctly. Error occured at 2290."

    I see you have not gotten any responses. It is a conundrum, as nobody seems to have an answer. It seems others have had similar issues, but none of the threads I have seen reveal an answer -- to this basic issue of getting the product working.

    Even a call to tech support revealed they didn't know either. And that the Qlinker forum section is apparently disbanded (don't know if its messages have been blended in here or not, don't think so). But have found a link to what messages are(were) there in the old Qlinker forum.

    http://msgboard.alphasoftware.com/alphaphorum/alpha_list.php3?num=12&sortby=lastreply&direction=desc

    After a little more rummaging around there, I found
    this link to one of the messages in the Old Qlinker forum.

    "Visual FoxPro ODBC Driver location has changed"
    http://msgboard.alphasoftware.com/alphaphorum/read.php3?num=12&id=137&loc=0&offset=0&sortby=lastreply&direction=desc&thread=137

    In that thread (by John Mango), he gives this link to the MS site for the installer for V FoxPro (VFPODBC.MSI)
    http://msdn.microsoft.com/vfoxpro/downloads/updates/odbc/default.aspx

    I dnld it (VFPODBC.MSI) and reinstalled the Visual FoxPro ODBC driver. MS says you can tell if it is already there by looking for the VFPODBC.DLL in the %system% dir. It was there, still I figured it was worth it to try the reinstall. The reinstall of the Visual FoxPro ODBC driver seemed to work for me, as I no longer get that error msg.

    I must say I am quite dissapointed in the support of this product. Live Tech didn't seem to know and not knowing didn't seem to have a great deal of interest in finding out a resolution that might benefit other (potential) customers. Plus the answer I did find was in the recesses of a defunct forum section and was darned lucky to find that.

    This has not cured the "a5conv.dbf" error msg on importing, though. I have the product half working.
    I am wondering whether it is worth it -- to attempt to get the other half working.

    Went back to the recesses of the old Qlinker forum one more time. Found something about reinstalling the Jet ODBC driver. Went to the MS site and found this.

    http://support.microsoft.com/default.aspx?scid=kb;en-us;271908
    "Starting with Microsoft Data Access Components (MDAC) version 2.6, MDAC no longer contains Jet components. In other words, MDAC versions 2.6 and later do not include Microsoft Jet, Microsoft Jet OLE DB Provider, and the ODBC Desktop Database Drivers. The ODBC Desktop Drivers and Visual FoxPro ODBC driver, that are no longer included with MDAC 2.6, are included with the Microsoft Windows 2000 operating system that contains MDAC 2.5. Microsoft Windows Millennium Edition (Me) is also included with MDAC 2.5.

    Microsoft Windows XP also contains the ODBC Desktop Drivers and Visual FoxPro Driver. For Microsoft Windows NT, Microsoft Windows 95, and Microsoft Windows 98, you must install MDAC 2.5 or an earlier version to obtain these drivers."

    Although it looks like XP is supposed to already have these, still a reinstall of the Visual FoxPro Driver seemed to work, so maybe reinstalling the Jet ODBC Drive will help with the other half.

    Stand by for a test...
    (Have to reboot to apply the Jet Service Pack)


    Lee





  3. #3
    Lee Furr
    Guest

    Default RE: Qlinker and A5V5

    After applying Jet ODBC Service Pack 8 and rebooting, I am not sure that it mattered in resolving the import issue.
    But here is what else I found.

    The first test, after installing the Service Pack, of importing the "Customer" list from QuickBooks *failed*.
    It failed just like before installing the service pack.

    The second test of importing the "Customer" list MINUS (just for kicks) the "Notes" field *worked*. (The whole list except for 1 field)

    Importing the "CompanyName" and "Notes" fields ONLY Worked. So that meant it wasn't the "Notes" field itself.

    A myriad of other importing tests, importing various fields from the "Customer" QB list revealed this...

    Import works with any combination of fields up to
    a total record length of 4000 bytes.

    At a record length of *4001 bytes*, the import fails, and throws one of two misleading error messages:

    1) "Error: Field will not fit in record: Error Occurred at line: 2290."

    2) "Error: The Microsoft Jet database engine could not find the ojbect 'a5conv.dbf'. Make sure the object exists and that you spell its name and the path name correctly.. Error occurred at line: 2290" [huh?]

    Do not know why it wants the file 'a5conv.dbf' when it reaches 4001 bytes, or what it would do if such a file were there.

    Bottom Line: Apparently, somewhere in the chain, there is a record importation limit of 4000 bytes.

    Apparently an error message referencing "line 2290" really means the *record* -- not field -- length you are attempting to import is TOO LONG. And unless 'a5conv.dbf' really does something, you don't need to worry about finding it (even if you could). And you probably don't need to worry about the Microsoft Jet engine. Just reduce what you are importing to less than 4001 bytes.

    Do not know if the same limitation exists on exporting.


    Since importing and exporting are the *main* function of Qlinker, it's a shame it takes this much research and experiential testing (apparently for quite a few users) to find these things required just for basic functioning.

    To summarize:

    FOR EXPORTING:
    If an error message is received on exporting,
    try reinstalling the Visual FoxPro ODBC drive.

    FOR IMPORTING:
    If an error message is received on importing,
    try reducing the length of what is being imported to
    a maximum of 4000 bytes.


    Hope this Helps,

    Lee



  4. #4
    "Certified" Alphaholic
    Real Name
    Cal Locklin
    Join Date
    Mar 2000
    Location
    S.E. Michigan
    Posts
    5,763

    Default RE: Qlinker and A5V5

    One thing I can tell you is that the driver must be installed with EXACTLY the same name as listed in the error message. "Visual Fox Pro" is not the same as "Visual Fox Pro Driver", etc., etc.

    Cal Locklin
    www.aimsdc.net

Similar Threads

  1. What hapened to Qlinker?
    By Rayr in forum Other Products
    Replies: 13
    Last Post: 05-26-2010, 04:09 PM
  2. Qlinker and Alpha V6
    By Hilllo in forum Alpha Five Version 6
    Replies: 6
    Last Post: 12-07-2004, 01:00 PM
  3. Qlinker problem
    By Daryl Mcclimans in forum Alpha Five Version 6
    Replies: 1
    Last Post: 09-15-2004, 01:37 PM
  4. qlinker
    By JBrown in forum Alpha Five Version 4
    Replies: 2
    Last Post: 03-03-2003, 02:56 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •