Alpha Video Training
Results 1 to 7 of 7

Thread: Unable to edit field rules

  1. #1
    Dick Anderson
    Guest

    Default Unable to edit field rules

    I have a Dbase which for some unknown to me at least has had all of my original field rules corrupted to the point that I can no longer edit them back to their original states.
    Keep getting Error modifying field rules for db name or words to that effect.
    In essence, I am not able to change the field rules. They all stay at some default settings.
    I am using A5V5 build 2051 RT

  2. #2
    VAR davej's Avatar
    Real Name
    Dave Jampole
    Join Date
    Apr 2000
    Location
    Haughton, LA ( just east of Shreveport, Louisiana)
    Posts
    2,524

    Default RE: Unable to edit field rules

    Dick,

    In the RT you cannot edit field rules, even though that option (Edit Field Rules) appears when you right click the Table/Set name in the Control Panel.

    Dave

  3. #3
    Dick Anderson
    Guest

    Default RE: Unable to edit field rules

    I was under the impression that the full version and Run Time were the same as opposed to home edition.
    My version was purchased as the full boat. That being said, how do I edit the field rules and why do they give you an option to edit if you can't?

  4. #4
    "Certified" Alphaholic
    Real Name
    Raymond Lyons
    Join Date
    Apr 2000
    Location
    Carlsbad, CA
    Posts
    2,143

    Default RE: Unable to edit field rules

    You need the full version. The runtime is way different. I know nothing about the Home version.

    Ray

  5. #5
    Dick Anderson
    Guest

    Default RE: Unable to edit field rules

    I have the full version, at least that's what it says in the About Alpha5 in the Help menu.
    What next? Any ideas on why I can't edit the rules.
    BTW in my original post there was a typo. The build is 1051 for the the addins and 1498 for the version build

  6. #6
    Volunteer Moderator
    Real Name
    Alan Buchholz
    Join Date
    Oct 2000
    Location
    Delavan, Wisconsin
    Posts
    9,643

    Default RE: Unable to edit field rules

    Dick


    Back up - back up - back up - first.

    Use the duplicate table option using a new table name.

    Check all four options.

    See if you can edit the field rules under the new table name.

    Sometimes the index of the structure files gets corrupted and the duplicate will rebuilt it.

    If it works, then delete the original table and duplicate or rename it back to the original name.

    Let us know if that is successful.

  7. #7
    Dick Anderson
    Guest

    Default RE: Unable to edit field rules

    How does one say THANK YOU to the nth degree?
    It was such a simple operation to do, yet had trouble wading through 1700 entries on "field rules" and 32 entries in "edit field rules" in this forum. Just couldn't seem to find what I needed. So like probably many others, just posted a new thread.
    At any rate, thank you all for trying to help, and especially to you Al, for finally posting something about how to do what I wanted.
    Merry Christmas to all from one, each, happy camper.
    I've been using Alpha since 1989 and have no intention of changing any time soon.

Similar Threads

  1. Edit field rules in a set
    By Peter Wade-Graham in forum Alpha Five Version 6
    Replies: 4
    Last Post: 11-23-2005, 07:04 PM
  2. Edit field rules with xbasic?
    By Bill Warner in forum Alpha Five Version 5
    Replies: 0
    Last Post: 02-17-2005, 11:14 AM
  3. A4V6 unable to change field rules
    By Gary Botstein in forum Alpha Four Version 6 and Prior
    Replies: 2
    Last Post: 03-05-2003, 05:59 PM
  4. unable to save edit
    By Mary Vitale in forum Alpha Five Version 5
    Replies: 2
    Last Post: 12-31-2002, 06:34 PM
  5. can't edit field rules
    By Becky McNichols in forum Alpha Five Version 4
    Replies: 1
    Last Post: 01-17-2001, 07:07 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •