Alpha Video Training
Results 1 to 8 of 8

Thread: Alpha 5 Printer not activated, error code -30

  1. #1
    Real Name
    Jack Birnbaum
    Join Date
    Jun 2000

    Default Alpha 5 Printer not activated, error code -30

    I can't use the Alpha printer driver to print PDF files. I tried the print Genie to email PDF reports, no go. I tried to preview reports and then save as PDF, no go. I consistently get "Printer not activated, error code -30" message.

  2. #2
    Alpha Software Employee Lenny Forziati's Avatar
    Real Name
    Lenny Forziati
    Join Date
    Nov 2001
    Alpha Software


    Scroll down and review the related threads or try searching - this has been discussed several times recently.

  3. #3
    Real Name
    Jack Birnbaum
    Join Date
    Jun 2000


    I did that prior to posting my message. It does not work. I tried "Save As" etc... but the printer gives me an error. If the print genie offers email as option than it should create the PDF file from within the Genie without any work around. I am not trying to print directly to the Alpha5 PDF driver, for that I use Adobe Acrobat driver.


  4. #4
    Real Name
    Kay Bedeau
    Join Date
    Apr 2006
    On 100 Acres of the Black Hills of South Dakota

    Default Re: Alpha 5 Printer not activated, error code -30

    After using the ARCHIVE feature for over a year, suddenly I am getting this error code when I try to archive a report. I have not changed my printer. In fact, I can't think of anything I have changed. Can you help?
    Karen Bedeau

  5. #5
    "Certified" Alphaholic
    Real Name
    Ed Barley
    Join Date
    Mar 2002
    Southern California

    Default Re: Alpha 5 Printer not activated, error code -30

    Hi Karen,

    If you have not resolved your problem.............look at this thread.

    HTML Code:


  6. #6
    Real Name
    Mike Atkinson
    Join Date
    Jun 2010

    Default Re: Alpha 5 Printer not activated, error code -30

    I know this is an old thread, but this thread is the top of the google search for this type of problem, and with Windows 10 virtually REQUIRING everyone to upgrade, it seems this might come up.

    The problem seems to be with the upgrade process losing the printer drivers and/or removing sufficient permissions for Alpha to communicate with the Amyuni printer driver. The following are the steps I had to go through to resolve the problem:

    Step #1 - I did a fresh install of AlphaFive (I just did a run time install to have it re-install the printer drivers). Others may be able to go direct to Step #2, but if the "AlphaFivePrinterV4" does not exist in the list in the registry, this should get it back in the list (note the V4 may be specific to my version of Alpha).

    Step #2 - Edit registry permissions.
    A) Windows Key, Run, Regedit
    B) Go to HKEY_CURRENT_CONFIG, under "Software" you should see "AlphaFivePrinterV4" or something very similar (if you don't, do Step #1).
    C) Right Click "AlphaFivePrinterV4" and click Permissions
    D) If you see "Everyone", left click and make sure the you "Allow Full Control" (this will automatically check the "Read" box under it. If you do NOT see "Everyone" see below on how to add it:

    If you do NOT see "Everyone" in the permissions list:
    1 - Click "Add"
    2 - Type "Everyone" in the "Enter the object names to select" box at bottom.
    3 - Click "Check Names" button (this should underline the word "Everyone"
    4 - Click Ok
    5 - Once this is done you should be able to proceed to D above.

    I was very happy when I got this sorted out. It seems that the Alphasoftware answer to problems these days is to uprade, upgrade, upgrade (i.e. more money to fix stuff we already paid for). Hope this helps someone else.
    Attached Images Attached Images
    Last edited by Mike Atkinson; 03-10-2016 at 03:52 PM. Reason: Typos and inserting images

  7. #7
    Volunteer Moderator
    Real Name
    Alan Buchholz
    Join Date
    Oct 2000
    Delavan, Wisconsin

    Default Re: Alpha 5 Printer not activated, error code -30


    Nicely done.

    This should be in a place for all to see..

    You should consider adding it to the code archive.

    It would be great to build a script to do this.

    I googled and found this link.

    Looks like something for Friday.(tomorrow) or that extra hour this week end...
    Al Buchholz
    Bookwood Systems, LTD
    Weekly QReportBuilder Webinars Thursday 1 pm CST

    Occam's Razor - KISS
    Normalize till it hurts - De-normalize till it works.
    Advice offered and questions asked in the spirit of learning how to fish is better than someone giving you a fish.
    When we triage a problem it is much easier to read sample systems than to read a mind.

  8. #8
    Real Name
    Richard James
    Join Date
    Jun 2004
    Atlanta, Ga.

    Default Re: Alpha 5 Printer not activated, error code -30

    Mike --

    Your comment with the steps to get rid of the error code -30 was really helpful. After upgrading to Windows 10, I had to do both Steps #1 & #2, but when I did, everything worked perfectly. Thank you very much, sir!

    -- Dick James

Similar Threads

  1. Amyuni Printer Driver Not Activated??
    By aboutblank in forum Alpha Five Version 7
    Replies: 4
    Last Post: 12-29-2005, 07:19 PM
  2. error Alpha Five Printer for PDF printer not installed
    By oldtony in forum Web Application Server v7
    Replies: 2
    Last Post: 12-05-2005, 02:20 PM
  3. nestle alpha code into java code?
    By Willard in forum Web Application Server v6
    Replies: 6
    Last Post: 01-18-2005, 08:03 AM
  4. Error Message-Key Not Activated?
    By Cedric McCraw in forum Alpha Five Version 5
    Replies: 1
    Last Post: 02-09-2004, 06:55 AM
  5. No Code in Alpha sports code tab
    By forskare in forum Alpha Five Version 5
    Replies: 5
    Last Post: 01-10-2004, 06:13 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts