Alpha Video Training
Results 1 to 3 of 3

Thread: Custrom Controlled field: Property not found / Subelement not found

  1. #1
    Member
    Real Name
    Maarten B.
    Join Date
    Oct 2006
    Posts
    13

    Default Custrom Controlled field: Property not found / Subelement not found

    Script UI_DLG_BOX line 104
    Property not found
    Subelement not found

    This is the error I get when I start to use a CUSTOM CONTROLLED field.

    All other fields are made using WEB COMPONENTS. Now I want to set a field type to 'file' for uploading files. Strange that Alpha5 v7 does not give me the possibility to specify it using WEB COMPONTENTS. So my idea was to write it in Xbasic. Even stranger is that when a form is built using WEB COMPONENTS it's not exactly Xbasic, so I can not find out where I have to enter my Xbasic code.

    So I used CUSTOM CONTROLLED fields, but as soon as I select a field to be CUSTOM CONTROLLED, the above error appears when I save the form.

    Could someone please help me out?

    Thanks!

    Meanrat

  2. #2
    Member
    Real Name
    Maarten B.
    Join Date
    Oct 2006
    Posts
    13

    Default Re: Custrom Controlled field: Property not found / Subelement not found

    14 views (minus 1 from me) and still no response.

    Meanwhile I've found something out.
    If I use TEXTBOX instead of CUSTOM and enable the FREEFORM LAYOUT I am able to process an input type of FILE. At the freeform layout I enter "<input type="file"..." and there it is...

    But...
    I can't seem to upload. The form tag has the "enctype" tag, but still, the Alpha5 code interpretes the value of the FILETYPE as a character. I think because the type in the WEB COMPONENT is set at TEXTBOX, like I said.

    So still I hope someone can give me a clue.

  3. #3
    Volunteer Moderator Steve Workings's Avatar
    Real Name
    Steve Workings
    Join Date
    Apr 2000
    Location
    The Dreaded Chair
    Posts
    5,632

    Default Re: Custrom Controlled field: Property not found / Subelement not found

    Can I encourage a bit of patience? This is free support from a lot of busy, capable people.

    You don't say if you're getting this error on a dialog or grid component, but I can select Custom control on both without getting the error. Try creating a completely new component and see if you can reproduce the error.

    While I suppose that with a bunch of work you could use a grid or dialog custom control for file upload, that's not the "standard" method. I couldn't find the example right away, but with some looking around (use the search feature on this board) you'll find a complete example of an .a5w page used for file upload.
    -Steve


Similar Threads

  1. Property Not Found / subelement not found
    By Rich Hartnett in forum Web Application Server v7
    Replies: 2
    Last Post: 10-13-2006, 09:31 AM
  2. Subelement Not Found
    By Steve Workings in forum Alpha Five Version 7
    Replies: 16
    Last Post: 05-03-2006, 03:14 PM
  3. subelement not found
    By Trixie dela Cena in forum Alpha Five Version 5
    Replies: 8
    Last Post: 04-17-2003, 11:35 AM
  4. subelement not found
    By John Castle in forum Alpha Five Version 5
    Replies: 2
    Last Post: 03-14-2003, 05:55 AM
  5. a_tbl.[field name] subelement not found error
    By Tony Rutherford in forum Alpha Five Version 4
    Replies: 4
    Last Post: 05-05-2002, 09:12 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •