Alpha Video Training
Results 1 to 8 of 8

Thread: memo field randomly refuses new text, then shows as bold

  1. #1
    Member
    Real Name
    Reva Reck
    Join Date
    Feb 2006
    Location
    Warwick, Mass. - in the woods
    Posts
    73

    Default memo field randomly refuses new text, then shows as bold

    I'm having problems with a a memo field in an application developed under v.7 & upgraded to v. 8 a month or 2 ago. This didn't seem to be happening in v.7. The user is typing text into the memo field on a form. Suddenly the memo field will no longer accept any more text. So he clicks the pencil, and is then able to add more text to the field. However, when he closes the memo box, the text he has just typed doesn't appear in the memo field on the form. If he switches to a different record & then goes back to the original record, the additional text DOES appear, but the text is now bold & any additional text is bold. Also, after this happens a few times, the whole application slows way down - to the point of being virtually frozen sometimes, and he has to close A5 & re-start it.

    I tried check/repair memo fields & didn't get any errors. If anything, the problem is worse since I did that.

    This is Enterprise addition on a network - don't know if that would make any difference. I haven't installed the most recent patch, but there was nothing about this in the release notes and so far applying patches hasn't helped at all.

    I looked at some other posts about memo fields, and some seemed to say that you can't just put a memo field on a form & edit it the way you would any other field. We haven't had problems doing this before & I'm not sure how to work with a field that the user can't edit. It seems to me that this can't be the case!

  2. #2
    Member
    Real Name
    Reva Reck
    Join Date
    Feb 2006
    Location
    Warwick, Mass. - in the woods
    Posts
    73

    Default Re: memo field randomly refuses new text, then shows as bold

    So.. nobody seems to have any experience with this kind of problem? I guess I'll try going to the latest build & then submit a bug report.

  3. #3
    Volunteer Moderator Peter.Greulich's Avatar
    Real Name
    Peter Greulich
    Join Date
    Apr 2000
    Location
    Boston, MA
    Posts
    11,644

    Default Re: memo field randomly refuses new text, then shows as bold

    Quote Originally Posted by Reva View Post
    I looked at some other posts about memo fields, and some seemed to say that you can't just put a memo field on a form & edit it the way you would any other field.
    You should be able to edit a memo field on a form. The problem arises is that if the user inadvertently fetches another record while in change or enter mode, the memo field may be vulnerable to wholesale corruption.

    It sounds like you are referring to an RTF Memo field, not a standard memo field? RTF's tend to be somewhat unreliable in my experience. Do submit a bug report along w. a (non?)-working example.

  4. #4
    Member
    Real Name
    Reva Reck
    Join Date
    Feb 2006
    Location
    Warwick, Mass. - in the woods
    Posts
    73

    Default Re: memo field randomly refuses new text, then shows as bold

    This is just a plain old memo field, not rtf. You say that the memo can be corrupted if the user "inadvertently fetches another record while in change or enter mode".
    I'd like to understand this better. The form is modeless. Most of the time, the user is editing existing records. Are you saying that if he doesn't hit the save button before he goes to the next record, he'll end up with the memo being corrupted? Or if he moves to the browse on the same tab & fetches a record fro a linked file? Or both?

  5. #5
    Volunteer Moderator Peter.Greulich's Avatar
    Real Name
    Peter Greulich
    Join Date
    Apr 2000
    Location
    Boston, MA
    Posts
    11,644

    Default Re: memo field randomly refuses new text, then shows as bold

    Quote Originally Posted by Reva View Post
    Are you saying that if he doesn't hit the save button before he goes to the next record, he'll end up with the memo being corrupted?
    Correct - that is a possibility.

    Or if he moves to the browse on the same tab & fetches a record fro a linked file?

    IF he is in change mode corruption is possible.

  6. #6
    Member
    Real Name
    Reva Reck
    Join Date
    Feb 2006
    Location
    Warwick, Mass. - in the woods
    Posts
    73

    Default Re: memo field randomly refuses new text, then shows as bold

    So, can I put a record save on the memo field's onDepart or canDepart event to prevent this? Also, how can I fix what's already there? The check/repair memo fields doesn't seem to have any effect.

  7. #7
    Volunteer Moderator Peter.Greulich's Avatar
    Real Name
    Peter Greulich
    Join Date
    Apr 2000
    Location
    Boston, MA
    Posts
    11,644

    Default Re: memo field randomly refuses new text, then shows as bold

    This is the MUST read article for anyone using memo fields:

    http://www.learnalpha.com/MemosThatW...osThatWork.htm


    Quote Originally Posted by Reva View Post
    Also, how can I fix what's already there?
    Try exporting the records to a similar structured table, and see if that fixes it. I would create the duplicate table from scratch - w/o field rules or forms, etc. If the data imports whole and intact, zap the original table's records, and export back from your dup to the master. Make sure you back up before doing anything!

  8. #8
    Member
    Real Name
    Reva Reck
    Join Date
    Feb 2006
    Location
    Warwick, Mass. - in the woods
    Posts
    73

    Default Re: memo field randomly refuses new text, then shows as bold

    Thanks Peter. I'll continue looking at ways to tighten up memo processing on this form per the suggestions in this article.

Similar Threads

  1. Cannot Copy Text from Rich Text Memo Field
    By rtbtat in forum Alpha Five Version 7
    Replies: 8
    Last Post: 10-11-2006, 09:37 AM
  2. get text from memo field
    By DaveM in forum Alpha Five Version 7
    Replies: 18
    Last Post: 07-27-2006, 08:26 PM
  3. bold text a field
    By dparkins in forum Alpha Five Version 5
    Replies: 3
    Last Post: 01-25-2005, 05:09 AM
  4. Bold Text Objects
    By cpc@technonet.com in forum Alpha Five Version 6
    Replies: 3
    Last Post: 01-11-2005, 06:03 AM
  5. Text field(s) to memo
    By Tony Buddes in forum Alpha Five Version 4
    Replies: 2
    Last Post: 05-29-2000, 02:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •