Alpha Video Training
Results 1 to 4 of 4

Thread: Specifying the link address for a set in a web application

  1. #1
    Member
    Real Name
    Travis Seymour
    Join Date
    Sep 2007
    Location
    Bay Area, California
    Posts
    44

    Default Specifying the link address for a set in a web application

    Although the answer to my question must be here somewhere, I've searched the forums, but I can't find the answer...Please advise:

    I have a page (kidslistview.a5w) with a view-only list grid component (grid_PEKids_listview) in which one field (called detail) points to a page (kidsdetail.a5w) with a tabular grid component (grid_PEKids_detail). Both grid_PEKids_listview and grid_PEKids_detail reference the same table and have a unique ID field for each record. So I used the following link address:

    kidsdetail.a5w?grid_PEKids_det_filter=ID={ID}

    This worked great....

    until I decided to make use a Set so that each kid could have multiple "calls" associated with them (we have to call kids and their parents). So I made a set called set_PEKids using a one to many relationship between the kids and calls tables linked by ID. This works fine and I can add and delete multiple calls for each kid as you would expect. The problem is that the link address no longer works. It always goes to the first record. I can move forward and backwards using the navigation keys under the grid, and so I can see that the set works fine, so it must be the linke address. I tried

    kidsdetail.a5w?set_PEKids_filter=ID={ID}

    but it didn't work. How do I properly filter a page with a set component on it?

    I'd appreciate any advice, I'm sure it's simple!

  2. #2
    Moderator
    Real Name
    Alan Buchholz
    Join Date
    Oct 2000
    Location
    Delavan, Wisconsin
    Posts
    9,580

    Default Re: Specifying the link address for a set in a web application

    Sets are for the desktop. (or is it Trix are for kids??)

    One to many relationships on the web needs a grid for each table and the grid linker to tie the grids together.
    Al Buchholz
    Bookwood Systems, LTD
    Weekly QReportBuilder Webinars Thursday 1 pm CST

    Occam's Razor - KISS
    Normalize till it hurts - De-normalize till it works.
    Advice offered and questions asked in the spirit of learning how to fish is better than someone giving you a fish.
    When we triage a problem it is much easier to read sample systems than to read a mind.

  3. #3
    Member
    Real Name
    Travis Seymour
    Join Date
    Sep 2007
    Location
    Bay Area, California
    Posts
    44

    Default Re: Specifying the link address for a set in a web application

    shoot...that's what I meant...I'm using a grid linker component. Sorry about that.

  4. #4
    Member
    Real Name
    Travis Seymour
    Join Date
    Sep 2007
    Location
    Bay Area, California
    Posts
    44

    Default Re: Specifying the link address for a set in a web application

    I figured it out! In the link builder, I was creating a variable and I should have created a filter! So this works:

    kidsdetail.a5w?grid_PEKids_detail_filter=Id={ID}

    hopefully this helps some other newbie out there...

Similar Threads

  1. Link Address error in select statement
    By andi in forum Application Server Version 8
    Replies: 1
    Last Post: 05-25-2007, 01:08 AM
  2. Problem with Link Address
    By Rich Hartnett in forum Web Application Server v7
    Replies: 21
    Last Post: 10-18-2006, 10:39 AM
  3. Add Variable to Web Address
    By RKPSR in forum Alpha Five Version 6
    Replies: 5
    Last Post: 09-02-2005, 10:58 PM
  4. Internal link in link address not working
    By Howard G. Cornett in forum Web Application Server v6
    Replies: 2
    Last Post: 08-25-2005, 07:57 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •