Alpha Video Training
Results 1 to 4 of 4

Thread: Email Profile Not Changing

  1. #1
    "Certified" Alphaholic Phil Rolf's Avatar
    Real Name
    Philip Rolf
    Join Date
    Apr 2000
    Location
    Kentucky
    Posts
    1,539

    Default Email Profile Not Changing

    I have a button on a form that sends an email and the profile is selected based upon some logical fields. Here is the simple xbasic Azproduct, fsproduct, and srproduct are logical fields.

    Code:
    if clients->azproduct
    	email_set_active("Azenta Products")
    end if
    
    if clients->fsproduct
    	email_set_active("FerraStone")
    end if
    
    if clients->srproduct
    	email_set_active("Sweet Rock")
    end if
    In the events portion of the button this xbasic is the first action to be taken, The second action is to send the email. I created this using the Action Scripting.

    When I click on the button everything works fine including the selection of the appropriate Profile. However, if I decide to change the profile when the email window appears by clicking on the FROM button, the Profile changes on the display but when the email is sent, whatever the profile was when the Email window appears is the Profile that is included with the email, not to the Profile that I changed it to.

    Is this correct behavior on the part of V8? The reason I ask this is because the FROM portion is Grayed out even though the newly selected profile is displayed. Is there a workaround if V8 is working properly?

  2. #2
    "Certified" Alphaholic
    Real Name
    Mike Christensen
    Join Date
    Nov 2005
    Location
    Michigan U.P.
    Posts
    5,937

    Default Re: Email Profile Not Changing

    Hi Phil,

    I just set up the email for both using my default and for using Alpha mail (you didn't specify which!) and can confirm the problem changing the profile from one to the other and having it show correctly when sending but actually shows the initial profile once sent. I will try a couple of other things but sure looks like a bug to me.

    Using builds 1980 3163
    Mike
    __________________________________________
    It is only when we forget all our learning that we begin to know.
    It's not what you look at that matters, it's what you see.
    Henry David Thoreau
    __________________________________________




  3. #3
    "Certified" Alphaholic Phil Rolf's Avatar
    Real Name
    Philip Rolf
    Join Date
    Apr 2000
    Location
    Kentucky
    Posts
    1,539

    Default Re: Email Profile Not Changing

    Mike, thanks for responding, I am using the Alpha Client with the same build as you.

  4. #4
    "Certified" Alphaholic Phil Rolf's Avatar
    Real Name
    Philip Rolf
    Join Date
    Apr 2000
    Location
    Kentucky
    Posts
    1,539

    Default Re: Email Profile Not Changing

    I sent in a bug report and Selwyn just emailed me that this problem has been fixed and will be in the next release.

Similar Threads

  1. email profile
    By motigalil in forum Alpha Five Version 8
    Replies: 9
    Last Post: 06-27-2007, 05:16 PM
  2. Email profile setting
    By Bill Parker in forum Archived Wishlist
    Replies: 0
    Last Post: 11-11-2006, 02:46 PM
  3. Selecting Email Profile
    By Phil Rolf in forum Alpha Five Version 7
    Replies: 2
    Last Post: 04-19-2006, 05:41 PM
  4. Which Email profile is active?
    By Steve Wood in forum Web Application Server v6
    Replies: 5
    Last Post: 03-28-2005, 08:25 AM
  5. Email Profile
    By Phil Rolf in forum Alpha Five Version 5
    Replies: 3
    Last Post: 10-24-2002, 07:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •