Alpha Video Training
Results 1 to 2 of 2

Thread: "Find And Replace" Won't Work In Embedded Browse

  1. #1
    Member
    Real Name
    Jim Snyder
    Join Date
    Jun 2009
    Location
    Nashville, TN and Medellin, Colombia
    Posts
    53

    Default "Find And Replace" Won't Work In Embedded Browse

    I can't get the 'Find and Replace' operation to work in any of my embedded browses. I have tried to run the operation from both the 'Edit' menu and as an 'Update' operation/script. When run in an embedded browse, it either does nothing or results in an error message (in short: 'object does not exist'). On the other hand, it works fine in a simple browse. Has anyone else encountered this issue? Is there any way to make the 'Find/Search and Replace' operation work in an embedded browse?

    Thanks,

    Jim

    PS: After reading through some earlier posts, my impression is that embedded browses in general are problematic, ie, buggy. Is this true?

  2. #2
    Member
    Real Name
    Jim Snyder
    Join Date
    Jun 2009
    Location
    Nashville, TN and Medellin, Colombia
    Posts
    53

    Default Re: "Find And Replace" Won't Work In Embedded Browse

    I think I might have a 'work around'. As I mentioned in my original post, the 'Find and Replace' works fine in a non-embedded browse. In fact, I've noticed that when I use 'Find and Replace' to make changes to a record in a particular non-embedded browse, those changes are reflected in the 'companion' embedded browse. Maybe this 'back door' approach will work in my application. In other words, maybe I can program the 'Find and Replace' to operate on a hidden non-embedded companion browse. Then, in order to see the changes in the embedded browse, I can simply refresh the embedded browse. To the user, it will appear as if he is making the changes directly to the embedded browse data. Is this feasible?

    thanks again,
    Jim
    Last edited by drjgs200; 06-29-2009 at 04:40 AM.

Similar Threads

  1. Embedded browse-Find by text
    By crimmelcp in forum Alpha Five Version 9 - Desktop Applications
    Replies: 9
    Last Post: 07-03-2008, 11:09 AM
  2. find last record in embedded browse
    By danh in forum Alpha Five Version 8
    Replies: 8
    Last Post: 02-18-2008, 09:11 PM
  3. Set Field for embedded Browse doesn't work
    By JGROSS in forum Alpha Five Version 8
    Replies: 1
    Last Post: 09-04-2007, 07:13 PM
  4. EMBEDDED BROWSE MASK WON'T WORK
    By KathyWeeks in forum Alpha Five Version 6
    Replies: 1
    Last Post: 06-30-2005, 06:22 PM
  5. FIND AND REPLACE
    By Keith Regan in forum Alpha Five Version 5
    Replies: 2
    Last Post: 12-28-2003, 06:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •