Alpha Video Training
Results 1 to 4 of 4

Thread: a5_eval_expression()

  1. #1
    Member
    Real Name
    Douglas Wiegand
    Join Date
    Apr 2007
    Posts
    154

    Default a5_eval_expression()

    I have an image reference field called 'Image'. In the field's Onchange I want to have another stored field's value set to the value defined by the expression
    Code:
    a5_eval_expression(image)
    But it doesn't work change mode, only in create mode. But if I define a calculated field using the exact same expression it works. I can also use the same expression in a button Onpush event to set the field value and it works. I'm perplexed.

  2. #2
    "Certified" Alphaholic Stan Mathews's Avatar
    Real Name
    Stan Mathews
    Join Date
    Apr 2000
    Location
    Bowling Green, KY
    Posts
    25,119

    Default Re: a5_eval_expression()

    Clear the trace window, go back to the form and change the image filename, then back to the trace window. It doesn't appear that the action of changing the image filename triggers the onchange event.

    Not just in v9, tested in v8.
    There can be only one.

  3. #3
    Member
    Real Name
    Douglas Wiegand
    Join Date
    Apr 2007
    Posts
    154

    Default Re: a5_eval_expression()

    That was my tentaive conclusion as well - changing the image field not triggering the Onchange event. I tested making a manual edit to a separate text field before trying to make a change to the image field. If another field is changed first then the image field Onchange event fires after changing the image name. So does this qualify as a bug?

  4. #4
    "Certified" Alphaholic Stan Mathews's Avatar
    Real Name
    Stan Mathews
    Join Date
    Apr 2000
    Location
    Bowling Green, KY
    Posts
    25,119

    Default Re: a5_eval_expression()

    Since you can accomplish the same thing in other ways it might be an annoyance or anomaly but I doubt much consideration will be given to it as a bug report.
    There can be only one.

Similar Threads

  1. a5_eval_expression not working ....
    By peterg000 in forum Alpha Five Version 8
    Replies: 13
    Last Post: 03-01-2007, 12:32 PM
  2. a5_eval_expression
    By dik_coleman in forum Alpha Five Version 5
    Replies: 1
    Last Post: 08-07-2004, 10:16 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •