Alpha Video Training
Results 1 to 7 of 7

Thread: Endless problems with A5 email client

  1. #1
    "Certified" Alphaholic
    Real Name
    Gaby Hernandez
    Join Date
    Sep 2008
    Posts
    1,170

    Default Endless problems with A5 email client

    Using A5 email client, I created an email script as follows:
    From AS Send Email Message,
    - Which email client?: built in A5 email client
    Send to: field that contains the email address
    Attachments: var->zattachment
    Next Window:
    In Message box:
    ="Dear "+Students->Name + crlf()+
    "Please see attached" + crlf()+
    "the Sender"
    Message Type: Plain
    Option: Don't open A5 email client, just send it

    The email goes out fine, the files are attached properly,... BUT the body of the email that is received shows codes (exactly as follows):
    ="Dear "+Students->Name + crlf()+\cr\lf"Please see attached" +
    crlf()+\cr\lf"the Sender"

    Changed the Message Type to HTML, same thing. Created an email template, exact same thing.

    I have been wrestling with this issue for several days...

  2. #2
    Member
    Real Name
    Garry M Flanigan
    Join Date
    Jul 2004
    Location
    Melbourne, Australia
    Posts
    909

    Default Re: Endless problems with A5 email client

    Instead of:
    Code:
    ="Dear "+Students->Name + crlf()+
    "Please see attached" + crlf()+
    "the Sender"
    put it all on one line as:
    Code:
    ="Dear "+Students->Name + crlf()+ "Please see attached" + crlf()+ "the Sender"
    The problem is you have pressed "enter" when typing in your formula to go to new lines of code and Alpha cannot interpret that correctly. If the formula "flows" to another line this is ok but you cannot break it into lines by pressing "enter".
    Garry

  3. #3
    "Certified" Alphaholic
    Real Name
    Gaby Hernandez
    Join Date
    Sep 2008
    Posts
    1,170

    Default Re: Endless problems with A5 email client

    Garry: you saved me twice today. Big Thanks. :)
    Quote Originally Posted by Garry Flanigan View Post
    The problem is you have pressed "enter" when typing in your formula to go to new lines of code and Alpha cannot interpret that correctly. If the formula "flows" to another line this is ok but you cannot break it into lines by pressing "enter".
    Garry
    This is an old habit from FM... learned my lesson.

  4. #4
    "Certified" Alphaholic
    Real Name
    Raymond Lyons
    Join Date
    Apr 2000
    Location
    Carlsbad, CA
    Posts
    2,143

    Default Re: Endless problems with A5 email client

    Yes but in the context of the Code Editor the backslash can function as a line continuation character (see image below). Then in an expression it can be an escape character (see the Help file for both items).

  5. #5
    "Certified" Alphaholic
    Real Name
    Gaby Hernandez
    Join Date
    Sep 2008
    Posts
    1,170

    Default Re: Endless problems with A5 email client

    Hi Raymond:
    Good to know, thanks for the tip.
    The reason I used the "Enter" is to better "visualize" my expression; I can do without it easily. I have used it many times before with A5 and never suspected it could be a source of problems. Lesson learned.

  6. #6
    Member
    Real Name
    Garry M Flanigan
    Join Date
    Jul 2004
    Location
    Melbourne, Australia
    Posts
    909

    Default Re: Endless problems with A5 email client

    Gaby is using AS. The backslash does not work in the "Expression Builder", but does work in the "Code Editor" when, for example, writing an xbasic script.

    It was only because I helped Gaby in another post that I realised that I realised Gaby was using "Action Script" rather than "email script" as it was described in the first post of this thread.

    Garry

  7. #7
    "Certified" Alphaholic
    Real Name
    Raymond Lyons
    Join Date
    Apr 2000
    Location
    Carlsbad, CA
    Posts
    2,143

    Default Re: Endless problems with A5 email client

    Quote Originally Posted by Garry Flanigan View Post
    Gaby is using AS. The backslash does not work in the "Expression Builder", but does work in the "Code Editor" when, for example, writing an xbasic script.
    Yes but it does work in the Expression Builder when used as an escape character, as in "Dear \"Alice\"" which produces Dear "Alice". Garry I am sure you know this but Gaby and others new to A5 may not.

Similar Threads

  1. default email client
    By Ian_Edwards in forum Alpha Five Version 7
    Replies: 2
    Last Post: 08-28-2006, 10:26 AM
  2. email client issue
    By Robert Emery in forum Alpha Five Version 7
    Replies: 5
    Last Post: 06-19-2006, 10:06 PM
  3. Alpha Email Client - Forwarding email
    By Steve Wood in forum Alpha Five Version 7
    Replies: 0
    Last Post: 03-31-2006, 05:43 AM
  4. Email client
    By Schulzie in forum Alpha Five Version 6
    Replies: 4
    Last Post: 07-09-2005, 04:01 PM
  5. email client
    By Chester Kylstra in forum Alpha Five Version 5
    Replies: 2
    Last Post: 12-02-2002, 12:10 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •