Alpha Video Training
Results 1 to 4 of 4

Thread: Date Problem

  1. #1
    Member
    Real Name
    David Donohue
    Join Date
    Jul 2009
    Location
    NZ
    Posts
    85

    Default Date Problem

    I am writing data to a transaction file using the event, 'afterUpdatingRecord' and using debug the date stored in e.DataSubmitted.date is correct but does not get into the Access table 'transaction.date' which is Data Type 'date/time'.
    Everything else is correct including logical fields.

    For example e.DataSubmitted.date = 03/03/2010
    in the database record is recorded 00/00/00 converted then by Access to be 01/01/1900.
    I guess I have missing something.
    I have tried using convert_type(e.DataSubmitted.date,"D") but to no avail.

    Can anybody help me on this?

  2. #2
    Member
    Real Name
    David Donohue
    Join Date
    Jul 2009
    Location
    NZ
    Posts
    85

    Default Re: Date Problem

    I have found out that by using 'convert_type(e.DataSubmitted.date,"T")' solves the problem.

    I also made the 'date/time' field in the access db to be 'short date'.

    Great now I can continue..... till the next problem.!!!

  3. #3
    "Certified" Alphaholic
    Real Name
    Frank Bicknell
    Join Date
    Feb 2010
    Location
    39.1915° N, 84.4348° W
    Posts
    2,467

    Default Re: Date Problem

    Quote Originally Posted by BigBoss1 View Post
    Great now I can continue..... till the next problem.!!!
    That is not a problem, that is merely a learning experience, you won't do that again.
    When your database crashes or you accidentally delete 5000 customers and your backup does not work.... that's a problem!

  4. #4
    Member MichaelCarroll's Avatar
    Real Name
    Michael Carroll
    Join Date
    Feb 2008
    Posts
    467

    Default Re: Date Problem

    Quote Originally Posted by frankbicknell View Post
    That is not a problem, that is merely a learning experience, you won't do that again.
    When your database crashes or you accidentally delete 5000 customers and your backup does not work.... that's a problem!
    Talk about not wanting to do that again! LOL

Similar Threads

  1. UK/US date format problem using date picker
    By Robert Rough in forum Application Server Version 8
    Replies: 4
    Last Post: 06-14-2007, 10:55 AM
  2. Date problem US/UK formatting. Resurrecting old problem
    By Robert Rough in forum Web Application Server v7
    Replies: 2
    Last Post: 03-06-2007, 02:33 AM
  3. Date Problem
    By B Philip Gerber in forum Alpha Five Version 5
    Replies: 5
    Last Post: 04-15-2004, 12:46 PM
  4. Date Problem
    By Phil Rolf in forum Alpha Five Version 4
    Replies: 1
    Last Post: 04-04-2001, 12:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •