Alpha Video Training
Results 1 to 5 of 5

Thread: jQuery UI progressbar does not work on A5WS

  1. #1
    Member
    Real Name
    Locke
    Join Date
    Jan 2008
    Posts
    22

    Default jQuery UI progressbar does not work on A5WS

    Hello,
    I've been experimenting with the Progressbar element of the jQuery UI, and have run into an issue.
    Essentially, the user presses a button, an alert shows to note that the process has begun, the page uses AJAX callbacks to a .php page to increment by 1% each callback (jumping ahead from 30 to 45, and from 45 to 85; just to experiment), and then another alert is generated that the increments are finished. This code works perfectly on my local XAMPP server, and my own Non-Alpha website, but in my A5WS, I only receive the Beginning and ending alerts, and the percentage never changes.

    I have tried to use the $.noConflict() fix (This is "test.html"), and that code is operational (I tried it on my non A5 web server); but I still have the same issue.

    Any suggestions?

  2. #2
    "Certified" Alphaholic
    Real Name
    unactive
    Join Date
    Dec 2006
    Posts
    1,573

    Default Re: jQuery UI progressbar does not work on A5WS

    Alpha don't know what to do with poster.php

    Ken

  3. #3
    Member
    Real Name
    Locke
    Join Date
    Jan 2008
    Posts
    22

    Default Re: jQuery UI progressbar does not work on A5WS

    Lovely, I'll test it with an a5w page and present the results.

  4. #4
    Alpha Software Employee Lenny Forziati's Avatar
    Real Name
    Lenny Forziati
    Join Date
    Nov 2001
    Location
    Alpha Software
    Posts
    4,699

    Default Re: jQuery UI progressbar does not work on A5WS

    poster.a5w:
    Code:
    <%a5
    dim percentage as c
    if percentage = "30"
    	? "45"
    else if percentage = "45"
    	? "85"
    else
    	? val(percentage) + 1
    end if
    %>

    Lenny Forziati
    Vice President, Internet Products and Technical Services
    Alpha Software Corporation

  5. #5
    Member
    Real Name
    Locke
    Join Date
    Jan 2008
    Posts
    22

    Default Re: jQuery UI progressbar does not work on A5WS

    Thanks Lenny! I rewrote it in .a5w and it works. Now to figure out how to emulate PHP's $_FILES[] in A5WS.

Similar Threads

  1. Any update for the JQUERY JavaScript Calendar
    By kunjulin in forum Application Server Version 10 - Web/Browser Applications
    Replies: 5
    Last Post: 10-04-2010, 11:30 PM
  2. the $ sign on JQuery and Alpha
    By mmaisterrena in forum Application Server Version 10 - Web/Browser Applications
    Replies: 5
    Last Post: 06-02-2010, 03:50 PM
  3. FYI...jQuery Wizard called Glimmer
    By netfroguk in forum Application Server Version 9 - Web/Browser Applications
    Replies: 0
    Last Post: 04-28-2009, 11:41 PM
  4. Test A5WS
    By Keith Hubert in forum Application Server Version 9 - Web/Browser Applications
    Replies: 5
    Last Post: 01-30-2009, 01:08 PM
  5. Progressbar in Alpha Five
    By Marcel Kollenaar in forum Alpha Five Version 8
    Replies: 0
    Last Post: 03-03-2007, 05:34 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •