Alpha Video Training
Results 1 to 2 of 2

Thread: MySQL Auto increment field problem in linked grid.

  1. #1
    Member
    Real Name
    Andy Clark
    Join Date
    Apr 2010
    Location
    Buckinghamshire UK
    Posts
    6

    Default MySQL Auto increment field problem in linked grid.

    Hi

    When I'm using a grid to add a new record into a MySQL database with an auto incrementing identity column it works fine (see first attached image) and the <AUTO> flag appears in the ID column.

    If I use this grid as a linked grid then it no longer works (see second attached image). A zero appears instead of <AUTO> and an error stating that a duplicate ID would be created appears when I attempt to save that record.

    I've tried using an in-grid display and also a modal pop-up and the behaviour is the same for both.

    If any one has any pointers to where I might be going wrong I'd be grateful as this seems like a pretty basic operation.

    Thanks in anticipation.

    Andy

  2. #2
    Member
    Real Name
    Andy Clark
    Join Date
    Apr 2010
    Location
    Buckinghamshire UK
    Posts
    6

    Default Re: MySQL Auto increment field problem in linked grid.

    Quote Originally Posted by ahclark View Post
    Hi

    When I'm using a grid to add a new record into a MySQL database with an auto incrementing identity column it works fine (see first attached image) and the <AUTO> flag appears in the ID column.

    If I use this grid as a linked grid then it no longer works (see second attached image). A zero appears instead of <AUTO> and an error stating that a duplicate ID would be created appears when I attempt to save that record.

    I've tried using an in-grid display and also a modal pop-up and the behaviour is the same for both.

    If any one has any pointers to where I might be going wrong I'd be grateful as this seems like a pretty basic operation.

    Thanks in anticipation.

    Andy
    Well no-one replied but I did get a further in my investigations. This occurs when a table in a grid is linked to itself in another grid. A master detail relationship is fine. I had a read only grid linked to a SQL statement with some joins in it, the linked grid was for editing purposes. I was able to re-create the problem in a simple stand alone application. Not sure if its unique to MySQL, might give it a go in SQL Server if I've got time.

Similar Threads

  1. Row Expander Problem Showing Linked Grid with Image Ref Field
    By jkletrovets in forum Application Server Version 10 - Web/Browser Applications
    Replies: 5
    Last Post: 05-11-2010, 01:14 AM
  2. MYSQL db - field type auto increment not available
    By workaholic06 in forum Alpha Five Version 10 - Desktop Applications
    Replies: 3
    Last Post: 01-06-2010, 01:53 AM
  3. Auto-increment field problem
    By MartinR in forum Alpha Five Version 8
    Replies: 18
    Last Post: 10-25-2008, 09:52 PM
  4. auto increment ID field problem
    By foodminer in forum Alpha Five Version 8
    Replies: 2
    Last Post: 05-31-2007, 10:34 PM
  5. Replies: 2
    Last Post: 08-12-2006, 11:41 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •