Alpha Video Training
Results 1 to 2 of 2

Thread: Could not refresh Detail View after inserting record...

  1. #1
    Member
    Real Name
    Roelof
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    763

    Exclamation Could not refresh Detail View after inserting record...

    Can someone help me with this I click on Add a new reocrd the detail view page comes up.
    I fill out some fields click on Save and the error that comes up is :"Could not refresh Detail view after inserting record. No records were found when executing the 'Refresh row' query"

    When I go to my SQL table the record is there. See the picture. I have not a clue what is going on.

  2. #2
    "Certified" Alphaholic
    Real Name
    Scott
    Join Date
    Mar 2010
    Location
    Toronto,ON
    Posts
    1,031

    Default Re: Could not refresh Detail View after inserting record...

    Are you using the latest version of Alpha?
    Do you have any custom grid event code?

    Code:
    ans1=tolower(ans1)
    ans2=tolower(ans2)
    if (ans1=="no") then
       ?"Upgrade A5"
    else if (ans1=="yes" .AND. ans2=="no")
       ?"recreate your grid from scratch."
    else if (ans1=="yes" .AND. ans2=="yes")
       ?"check your grid event code and read the comments in "
       ?"the events. E.g onbeforesqlcommandexecute - you need"       
       ?" to set e.lastInsertedIdentityValue or you will get"
       ?" this error"
    else
       ?"clueless :("
    end if

    Having a little fun at the end of a work day :)

Similar Threads

  1. Could not refresh Detail View after inserting record. No records were found ...
    By rnoguera in forum Application Server Version 10 - Web/Browser Applications
    Replies: 14
    Last Post: 04-20-2019, 02:46 AM
  2. Could not refresh detail view after inserting record. No records were found when...
    By aburningflame in forum Application Server Version 10 - Web/Browser Applications
    Replies: 13
    Last Post: 03-16-2011, 01:38 PM
  3. Could not refresh Grid after inserting record. No records were found when execut
    By aburningflame in forum Application Server Version 10 - Web/Browser Applications
    Replies: 0
    Last Post: 11-15-2010, 08:19 PM
  4. New Record Detail View Window Not Centered
    By gregincolumbus in forum Application Server Version 10 - Web/Browser Applications
    Replies: 2
    Last Post: 11-04-2010, 10:15 AM
  5. Detail View Link Only Select First Record
    By graysarge in forum Alpha Five Version 7
    Replies: 2
    Last Post: 01-28-2007, 06:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •