Alpha Video Training
Results 1 to 3 of 3

Thread: Error Adding Relation Child

  1. #1
    Moderator Steve Workings's Avatar
    Real Name
    Steve Workings
    Join Date
    Apr 2000
    Location
    The Dreaded Chair
    Posts
    5,595

    Default Error Adding Relation Child

    I'm trying to figure out where to start on this one -- looking for ideas:

    The attached error message is produced by previewing a report, and then attempting to save it as a PDF. My customer gets this sometimes, I get it sometimes. Using A5v10, later-to-current builds.

    Usually you get this kind of message if a set needs to access a table using a linking index, and the index does not exists, but the table is in use elsewhere so the index cannot be built.

    But, that's clearly not the case here: The report is already produced as a preview, so we know the tables and indexes are in place.

    I tried this on the Alpha Sports Invoice report which is based on a set but could not reproduce the problem there.

    Any thoughts?
    Attached Images Attached Images
    -Steve


  2. #2
    "Certified" Alphaholic
    Real Name
    Mike Christensen
    Join Date
    Nov 2005
    Location
    Michigan U.P.
    Posts
    5,937

    Default Re: Error Adding Relation Child

    Hi Steve,
    Does Alpha show in the database information that the table is open?

    If not then do you have the code editor open---has caused this error for me before....doubt it is your cause though unless your customer has access to it. Another similar issue I had was remedied by using a registry cleaner to rid the system of unwanted/needed entries (also sped up Alpha).
    Mike
    __________________________________________
    It is only when we forget all our learning that we begin to know.
    It's not what you look at that matters, it's what you see.
    Henry David Thoreau
    __________________________________________




  3. #3
    "Certified" Alphaholic MoGrace's Avatar
    Real Name
    Robin
    Join Date
    Mar 2006
    Location
    Los Angeles
    Posts
    3,595

    Default Re: Error Adding Relation Child

    This just happened to me (again) when trying to put a stand alone browse, based on a set, in design mode. When I went to check the indexes for the errant table reported in the error message - all the indexes were gone. Lucky for me I have Cal Locklin's rebuild index function and was able to restore them. Once I did that the error went away and I was able to open the browse. However when I did that all the indexes disappeared again! The indexes are fairly simple using one or two fields and no filters.

    I am going to try deleting the browse (and the set it is based on?) and see if that makes a difference when opening another set that uses this table...

    Ah Hah - the browse error was only the symptom, the problem was the set had a filter for a field in that table that was no longer in use (name cx'd but not removed)
    The set is only used for a report and the browse was only for testing the data - neither of which I had checked when I changed the table.

    I should know better... I was able to fix the set without losing the report or the browse. Now I can find this post if it happens again.
    Last edited by MoGrace; 06-23-2019 at 02:14 PM.
    Robin

    Discernment is not needed in things that differ, but in those things that appear to be the same. - Miles Sanford

Similar Threads

  1. Error invalid relation type occurred......
    By boba in forum Alpha Five Version 10 - Desktop Applications
    Replies: 3
    Last Post: 06-22-2010, 01:20 PM
  2. Nav component - order when adding Child
    By Steve Wood in forum Archived Wishlist
    Replies: 0
    Last Post: 09-25-2007, 07:53 PM
  3. Adding Child Record in Subform in Tabbed
    By kumargroup in forum Alpha Five Version 5
    Replies: 0
    Last Post: 10-19-2003, 09:02 PM
  4. Adding a Child Record
    By Charles Hoens in forum Alpha Five Version 5
    Replies: 2
    Last Post: 06-27-2003, 12:53 PM
  5. Adding New Records to Child dbf
    By Charles Hoens in forum Alpha Five Version 5
    Replies: 10
    Last Post: 12-28-2002, 02:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •