Alpha Video Training
Results 1 to 6 of 6

Thread: Rookie Question - Deploying a web application to a A5 App Server Machine

  1. #1
    Member
    Real Name
    Dion McCormick
    Join Date
    Jun 2011
    Location
    Austin Texas
    Posts
    124

    Default Rookie Question - Deploying a web application to a A5 App Server Machine

    I have created a web application in Alpha Five. Included in the application are classes I have generated to support the application. I am able to "publish" and run the application to my local machine.

    I have set up another test machine as a production application server setup. I published the application to the local machine and then copied the files over to the production application server. The application functions correctly (dialogs, a5w pages and code that is embedded work great) but, it throws an error whenever it is attempting to access the classes I have generated for the application.

    I selected the option to compile the code into an AEX file, but that didn't seem to make a difference. My guess is that I am missing a step to make sure that the classes are being published along with the rest of the application.

    Any assistance would be appreciated.

    NOTE: Here is a snippet from the application server error file showing that the script is not seeing the class "tigerBlind" as it attempts to initialize it. Works fine on my test/development machine.:
    ***************************
    [Thu Sep 29 17:04:06 2011] [startup] Server is starting.
    [Thu Sep 29 17:04:34 2011] [Internal Server Error] (C:\A5Webroot\tigerblinds\dialogtest.a5w) Script Error: Error:Script: /tigerblinds/dialogtest.a5w line:85<br/>
    dim anotherBlind as tigerBlind <br/>
    Type is not defined
    Last edited by dionmccormick; 09-29-2011 at 07:31 PM.

  2. #2
    Moderator Steve Wood's Avatar
    Real Name
    Steve Wood
    Join Date
    Nov 2003
    Location
    Bay Area, California
    Posts
    8,827

    Default Re: Rookie Question - Deploying a web application to a A5 App Server Machine

    Alpha often does not publish the aex file. Select All Files in the Alpha project list and find your aex and publish. Then verify a fresh copy made it to your server, then restart your web app server (although there are other ways) this removes the old aex from cache.
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

  3. #3
    Member
    Real Name
    Dion McCormick
    Join Date
    Jun 2011
    Location
    Austin Texas
    Posts
    124

    Default Re: Rookie Question - Deploying a web application to a A5 App Server Machine

    Great advice. I re-published and verfied that the AEX file was in the output directory (and copied to the test machines directory). Restarted the server and still getting the same problem.
    Is there another location that you need to specify the AEX file to the application server? I did do a test where I embedded the class structure in the A5W page and it worked great. So I feel confident the issue is that the class structure in the AEX file is not being seen by the app server/pages on the test server.

  4. #4
    Moderator Steve Wood's Avatar
    Real Name
    Steve Wood
    Join Date
    Nov 2003
    Location
    Bay Area, California
    Posts
    8,827

    Default Re: Rookie Question - Deploying a web application to a A5 App Server Machine

    Your AEX also needs to be registered in the Project Properties dialog from the Web Projects panel.
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

  5. #5
    Member
    Real Name
    Dion McCormick
    Join Date
    Jun 2011
    Location
    Austin Texas
    Posts
    124

    Default Re: Rookie Question - Deploying a web application to a A5 App Server Machine

    Updating that now and will let you know how it goes!

  6. #6
    Member
    Real Name
    Dion McCormick
    Join Date
    Jun 2011
    Location
    Austin Texas
    Posts
    124

    Default Re: Rookie Question - Deploying a web application to a A5 App Server Machine

    Bingo! That looks like it did the trick. I went into the settings and put the full name (name and aex extension) and re-published. Looks like it is working smooth. Thanks so much for your help!

Similar Threads

  1. A5v9 Platinum Server, Desktop & Web Rookie-dom
    By GuyAtLarge in forum Alpha Five Version 9 - Desktop Applications
    Replies: 0
    Last Post: 03-10-2009, 12:24 PM
  2. App Server and Develppment on same machine
    By Louis Nickerson in forum Application Server Version 8
    Replies: 5
    Last Post: 03-22-2007, 10:26 AM
  3. Web Application Server Performance Question
    By whiteside in forum Web Application Server v6
    Replies: 0
    Last Post: 07-25-2005, 08:33 PM
  4. Question on V6 Web App Server
    By djones092 in forum Alpha Five Version 5
    Replies: 1
    Last Post: 07-20-2004, 11:16 AM
  5. Web Application Server Question
    By djones092 in forum Alpha Five Version 5
    Replies: 4
    Last Post: 07-09-2003, 08:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •