Alpha Video Training
Results 1 to 2 of 2

Thread: Error expanding Grid Part template: Column not found while getting result set data co

  1. #1
    Member leetv's Avatar
    Real Name
    Lee Taylor-Vaughan
    Join Date
    Aug 2010
    Location
    Hillsborough, NJ/Avondale, AZ/Sheffield, UK
    Posts
    352

    Default Error expanding Grid Part template: Column not found while getting result set data co

    I'm using the SQL below to populate to a grid. The SQL works fine (give me all the results/data) in the SQL Editor (from the Query Builder). however once i put the field on to a grid it get this error:


    Error expanding Grid Part template: Column not found while getting result set data column.'

    The error doesnt tell me which column, although i dont think it is related to a column. I tried erasing the grid and re-creating, but still the same error... the SQL (without the ['s) works find in a Navicat test query... hmmm...

    anyone have any ideas? is this a bug?

    Lee


    this is the SQL in the Query Builder of the grid.
    Code:
    SELECT  Count(*)  AS NoEntered, Count( IF( tbl_ext_registrants.HCP_ID > '' , 1, NULL) )  AS AutoEntered,  Date(tbl_ext_registrants.[_entered_date_time])  AS EnteredDate,  Concat(web_users.LNAME, ', ', web_users.FNAME)  AS EnteredBy, web_users.ID, v_ext_crs_badmail.BadMail 
    FROM (tbl_ext_registrants tbl_ext_registrants
         INNER JOIN web_users web_users
             ON  tbl_ext_registrants.[_entered_by] = web_users.ID 
         LEFT OUTER JOIN v_ext_crs_badmail v_ext_crs_badmail
             ON  tbl_ext_registrants.[_entered_date_time] = v_ext_crs_badmail.[_entered_date_time]  AND  tbl_ext_registrants.[_entered_by] = v_ext_crs_badmail.[_entered_by] ) 
    WHERE Date(tbl_ext_registrants.[_entered_date_time])  BETWEEN ( CURDATE()  - 365) AND  CURDATE() 
    GROUP BY web_users.LNAME, web_users.FNAME, v_ext_crs_badmail.BadMail, web_users.ID,  Date(tbl_ext_registrants.[_entered_date_time])  
    ORDER BY  Date(tbl_ext_registrants.[_entered_date_time])  DESC

  2. #2
    Member leetv's Avatar
    Real Name
    Lee Taylor-Vaughan
    Join Date
    Aug 2010
    Location
    Hillsborough, NJ/Avondale, AZ/Sheffield, UK
    Posts
    352

    Default Re: Error expanding Grid Part template: Column not found while getting result set dat

    somehow, and i don't really know how, this error is fixed.
    I have no clue if it helped but i erased the whole query, saved the component and pasted the query back and saved again... very odd.

Similar Threads

  1. Error expanding Grid Part template: Not found controlDef not found.
    By Jberry in forum Application Server Version 10 - Web/Browser Applications
    Replies: 3
    Last Post: 07-18-2016, 09:26 AM
  2. Error expanding Grid Part template: Not found
    By jmsilva in forum Application Server Version 10 - Web/Browser Applications
    Replies: 0
    Last Post: 06-27-2011, 11:13 PM
  3. Error expanding Grid Part template: Column not found while getting result set data co
    By Atta in forum Application Server Version 10 - Web/Browser Applications
    Replies: 1
    Last Post: 10-24-2010, 07:54 PM
  4. Error expanding Grid Part Template: Not an open table
    By Eric Johnson in forum Application Server Version 10 - Web/Browser Applications
    Replies: 3
    Last Post: 02-04-2010, 11:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •