Alpha Video Training
Results 1 to 22 of 22

Thread: Error expanding Grid Part template: Function: 'convert_number' was not recognized

  1. #1
    Member
    Real Name
    Jose Velez
    Join Date
    Oct 2010
    Location
    Dallas, Texas
    Posts
    125

    Default Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Hi everyone,

    I am getting this error when I publish my tabbed ui to my webroot and view the page. It works fine in working preview.

    Any ideas?

    Thanks,

    Jose
    Version 11

    grid_error.jpg

  2. #2
    Moderator Steve Workings's Avatar
    Real Name
    Steve Workings
    Join Date
    Apr 2000
    Location
    The Dreaded Chair
    Posts
    5,592

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Alpha doesn't have a built-in function of convert_number(). Did you create and attempt to use your own here?

    If so, you might show us the related code.

    And, if so, did you create an .AEX file and place it in your webroot?
    -Steve


  3. #3
    Member
    Real Name
    Garth McConnochie
    Join Date
    May 2009
    Location
    UK
    Posts
    138

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Hi Steve,

    I'm not sure that's correct I'm also getting this on some grids. I just build a new 64 bit server with appserver 2291-3841 on it
    I've just searched through the a5wcmp file in my webroot and found reference to convert_number

    {Grid.RowSeparator}
    </tbody>
    CŸ data.VISIBLE_FROM = tbl.data("VISIBLE_FROM") data.VISIBLE_TO = tbl.data("VISIBLE_TO") data.MSG_ID = tbl.data("MSG_ID") data.PRD_CODE = tbl.data("PRD_CODE") CĂș [['{js_escape(""+time("{grid.clientSideDateFormat}",tbl.data("VISIBLE_FROM")))}','#'],'{js_escape(""+time("{grid.clientSideDateFormat}",tbl.data("VISIBLE_TO")))}','{js_escape(convert_number(tbl.data("MSG_ID")))}','{js_escape(tbl.data("PRD_CODE"))}']
    C2 ['VISIBLE_FROM','VISIBLE_TO','MSG_ID','PRD_CODE'] C‚ ['{tbl.dataIsNull("VISIBLE_FROM")}','{tbl.dataIsNull("VISIBLE_TO")}','{tbl.dataIsNull("MSG_ID")}','{tbl.dataIsNull("PRD_CODE")}']
    C( [{name: 'VISIBLE_FROM' , hlp: '', type: 'link,label', dataType: 't',
    qbe: {operator: '', exclude: false, andOr: 'AND'} },{name: 'VISIBLE_TO'
    , hlp: '', displayFormat: 'plain', type: 'label,label', dataType: 't',
    qbe: {operator: '', exclude: false, andOr: 'AND'} },{name: 'MSG_ID' ,
    hlp: '', displayFormat: 'plain', type: 'label,label', dataType: 'n',
    qbe: {operator: '', exclude: false, andOr: 'AND'} },{name: 'PRD_CODE' ,
    hlp: '', displayFormat: 'plain', type: 'label,label', dataType: 'c',
    qbe: {operator: '', exclude: false, andOr: 'AND'} }] C

  4. #4
    Member
    Real Name
    Jose Velez
    Join Date
    Oct 2010
    Location
    Dallas, Texas
    Posts
    125

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Hi Steve,

    No, I'm too new to create my own.

    All I did was create some grid components, a tabbed UI and put the grid components into the TUI and then published. I am using mysql so, would I need a .AEX file? What is that? I thought that was just for .dbf files.

    Thanks!

    Jose

  5. #5
    Moderator Steve Wood's Avatar
    Real Name
    Steve Wood
    Join Date
    Nov 2003
    Location
    Bay Area, California
    Posts
    8,827

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Likely you need to make sure the Alpha versions on both local and remote server are the same. Update both to the latest Alpha patch.
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

  6. #6
    Member
    Real Name
    Jose Velez
    Join Date
    Oct 2010
    Location
    Dallas, Texas
    Posts
    125

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Steve,

    I am only running one instance of A5W server, which is build 2291-3841. The developer is Version 11, Build 2323-3850. Is this correct? Are the server and developer supposed to have corresponding build #'s?

    Thanks!

    Jose

  7. #7
    Moderator Steve Wood's Avatar
    Real Name
    Steve Wood
    Join Date
    Nov 2003
    Location
    Bay Area, California
    Posts
    8,827

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Developer and App Server must always be the exact same release number. They are always issued together.
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

  8. #8
    Moderator Steve Wood's Avatar
    Real Name
    Steve Wood
    Join Date
    Nov 2003
    Location
    Bay Area, California
    Posts
    8,827

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Actually, your server has the latest official patch. Your developer has PRE-RELEASE patch that you should not be using for production. So if you are testing out the pre-release they should be the same on server and developer and you should be reporting your troubles to bug reports, not here. If you are not wanting to be testing pre-release patch, then patch your developer copy BACK to the same copy as you have on the server.
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

  9. #9
    Member
    Real Name
    Jose Velez
    Join Date
    Oct 2010
    Location
    Dallas, Texas
    Posts
    125

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    I got with zebra host, I am hosting with them, and they made sure that I am using the correct builds (2291-3841). I re-published my files and restarted the server and I am still getting the same error.

    Does anyone have an idea what might be causing this error? Has anyone seen it before?

  10. #10
    Moderator Steve Wood's Avatar
    Real Name
    Steve Wood
    Join Date
    Nov 2003
    Location
    Bay Area, California
    Posts
    8,827

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    You didn't read my post or I was unclear. Your server is fine, your local developer copy is pre-release. Both server and developer need to be the same version, you have different versions on server and developer machine, and the developer machine is pre-release version.
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

  11. #11
    Member
    Real Name
    Jose Velez
    Join Date
    Oct 2010
    Location
    Dallas, Texas
    Posts
    125

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Steve,

    I am only using one machine right now - the server. My copy of developer is installed on the hosted server and I am using it via remote desktop.

  12. #12
    Member
    Real Name
    Clive Swanepoel
    Join Date
    Apr 2006
    Location
    Johnston, Iowa
    Posts
    119

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Hi Steve:

    I checked both the developer and the web app server (both are on the server) Both indicate the latest build when I check for updates.
    Affordable Alpha Five, PHP, MySQL Hosting.
    Serving Webmasters since 2000.ZebraHost

  13. #13
    Member
    Real Name
    Jose Velez
    Join Date
    Oct 2010
    Location
    Dallas, Texas
    Posts
    125

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Here is a screen shot of what my developer version is. Perhaps it has to do something with the new web starter version??? Anyone have any clues?... I still have not heard anything from the Alpha folks... it would be nice to get their help on this.

    Developer Version.jpg

  14. #14
    Moderator Steve Wood's Avatar
    Real Name
    Steve Wood
    Join Date
    Nov 2003
    Location
    Bay Area, California
    Posts
    8,827

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    My first post is accurate -- you have mis-matched versions of App Server and Developer. They are different; ignore what it says when you click to see if you have the latest version. You need to resolve this mismatch before you continue. I am repeating myself but you have pre-release version 2323-3850 for Developer and the latest official patch 2291-3841 on the server. Pre-release is for those who want to test out PRE-RELEASE non-official patches.
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

  15. #15
    Member
    Real Name
    Jose Velez
    Join Date
    Oct 2010
    Location
    Dallas, Texas
    Posts
    125

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    I just bought this last week, why did Alpha Software sell me, and give me a download link for, a pre-release version that does not match the app server?

    When I tried to install the developer patch from the patch download site (http://downloads.alphasoftware.com/A...chDownload.ASP) - choosing 'Alpha Five Update' I get more problems. For example, I was not able to use connection strings. I kept getting sql api not installed errors.

    So I went back to the download link that I got from my order email and downloaded and re-installed the developer, which seems to be a pre-release.

    I'm going around in circles and I cannot get anyone at Alpha to help me out. At this point I'l probably just ask for a refund.

  16. #16
    "Certified" Alphaholic
    Real Name
    Bill Griffin
    Join Date
    Jul 2001
    Location
    Edgewood, NY
    Posts
    1,201

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Go to the help menu and select download patches. The latest official release is there. Make sure you close all instances of alpha prior to applying the patch.
    Bill Griffin
    Parkell, Inc

  17. #17
    Member
    Real Name
    Jose Velez
    Join Date
    Oct 2010
    Location
    Dallas, Texas
    Posts
    125

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Bill,

    I have tried that several times. When I do I end up having more problems. For example, I cannot use connection strings. I get an error telling me that the SQL API is not installed. When I uninstall developer and reinstall it the connection strings works fine.

  18. #18
    Moderator Steve Wood's Avatar
    Real Name
    Steve Wood
    Join Date
    Nov 2003
    Location
    Bay Area, California
    Posts
    8,827

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    I am on the road and it took some time to get back to this. One thing we can assure you is once whatever is going on is set straight, and afterwards you keep developer and server in sync, things will work out.

    I downloaded the pre-release and see that the download is 2327-3852. The current official version is still 2291_3841 as noted above, that's for sure. Your's is a version in between the pre-release I downloaded and the official version, which just means you were provided a link to what was still pre-release, just a few weeks earlier than my download.

    I noted when I installed the downoaded pre-release that it included some new (not seen before) install for an sql server utility. I also note that your screenshot of the About screen has the product named Alpha Five V11 WebApp Developer Starter Edition. The "Developer" version has always just been called the "Developer" and so I don't know what a "WebApp Starter Edition" is or where it came from (anyone else?).

    Since anything past 2291_3841 is pre-release, I believe your only viable option is to contact Alpha's Sales department. You need a full download of the current Developer version, 2291_3841 to match your current Web App Server.

    Once you have the current Developer, my advice is to make note of your license number, back up your project files, completely uninstall A5 Developer and reinstall version 2291_3841. Then go to your project folder and delete any files that end in .manifest or .compiled. (Alpha will recreate them fresh when you publish), then attempt to open your project, review, publish, test, etc.

    I think you will still find problems that you noted above. If so, open each grid, make some simple change, and resave the grid, and republish, test. This should render the grid back to the current version.

    If you have problems with that approach, then next best advice is to NOT open your existing project but instead re-build it from scratch in the current version (it appears to be reasonably small). The reason is that your existing project was built in a pre-release version and is using functions that only exist in that pre-release version, which is where we started and why Steve Workings said that function did not exist.

    I think you just got caught in the middle somehow, not your fault.

    EDIT: I should add that one of your options is to download the latest pre-release version and make sure Developer and Server have that latest version. You should not do this with any project that is in or near production, but it would be OK to use if you were in the building stages and did not expect to go live for at least a month. You should expect problems if you go this route just because it is pre-release software.
    Last edited by Steve Wood; 12-30-2011 at 02:54 AM.
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

  19. #19
    "Certified" Alphaholic Clipper87's Avatar
    Real Name
    Frank
    Join Date
    Dec 2008
    Location
    Antwerp, Belgium
    Posts
    1,891

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Steve,

    The Alpha Five V11 WebApp Developer Starter Edition is an edition Alpha recently started to market:

    The Alpha Five v11 Web Starter Edition
    Just $199 - includes everything you need to build and deploy great web applications

    This new package includes the Alpha Five v11 Web Developer (without the ability to build desktop applications) and a 3-concurrent user web application server license. It's everything you need to build and deploy Alpha Five Internet and intranet applications - at a very attractive price.
    Frank

    Tell me and I'll forget; show me and I may remember; involve me and I'll understand

  20. #20
    Member
    Real Name
    Jose Velez
    Join Date
    Oct 2010
    Location
    Dallas, Texas
    Posts
    125

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Hello Everyone,

    I wanted to update you on the resolution. The issue was a build mismatch, as Steve correctly pointed out. After reconciling both developer and app server with the same builds I am able to view my grids!

    Thanks everyone for your help!

    Jose

  21. #21
    Member
    Real Name
    Jose Velez
    Join Date
    Oct 2010
    Location
    Dallas, Texas
    Posts
    125

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Steve,

    The Alpha folks were able to get me squared away with the pre-release issue. I'm good to go!

  22. #22
    Moderator Steve Wood's Avatar
    Real Name
    Steve Wood
    Join Date
    Nov 2003
    Location
    Bay Area, California
    Posts
    8,827

    Default Re: Error expanding Grid Part template: Function: 'convert_number' was not recognized

    Jose, Good that it worked out and this forum helped in the process.

    re: WebApp Starter Edition - didn't see that promo until today's Alpha newsletter. I remember back when they had multiple editions and it made it more confusing for us on the forum trying to figure out who had what. And I admit I wish they would make a SQL-only version that eliminated the options for DBF, which are mostly the default option and therefore requiring some extra motion to get to the SQL option.
    Last edited by Al Buchholz; 12-30-2011 at 10:47 PM. Reason: spelling
    Steve Wood
    Join the ALPHA DEVELOPERS NETWORK
    There is no Cloud. It's just someone else's computer.
    Web - Mobile - Hosting - Products - Frameworks - Developer Resources
    AlphaToGo | IADN (100% Alpha Anywhere Websites)

Similar Threads

  1. Error expanding Grid Part template: Not found controlDef not found.
    By Jberry in forum Application Server Version 10 - Web/Browser Applications
    Replies: 3
    Last Post: 07-18-2016, 09:26 AM
  2. Error expanding Grid Part template: Column not found while getting result set data co
    By leetv in forum Application Server Version 11 - Web/Browser Applications
    Replies: 1
    Last Post: 12-14-2011, 06:46 PM
  3. Error expanding Grid Part template: Not found
    By jmsilva in forum Application Server Version 10 - Web/Browser Applications
    Replies: 0
    Last Post: 06-27-2011, 11:13 PM
  4. Error expanding Grid Part template: Column not found while getting result set data co
    By Atta in forum Application Server Version 10 - Web/Browser Applications
    Replies: 1
    Last Post: 10-24-2010, 07:54 PM
  5. Error expanding Grid Part Template: Not an open table
    By Eric Johnson in forum Application Server Version 10 - Web/Browser Applications
    Replies: 3
    Last Post: 02-04-2010, 11:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •