Alpha Video Training
Results 1 to 6 of 6

Thread: Annoying Image Caching Problem with Alpha Web Server

  1. #1
    Member
    Real Name
    Steve Hood
    Join Date
    Dec 2007
    Posts
    19

    Default Annoying Image Caching Problem with Alpha Web Server

    Hi All,

    I operate an Alpha 11.0 Website that displays boats for sale. Most boats we have for sale come with photographs, and these photos are displayed online along with a description of the boat.

    Occasionally we need to swap out a photo for a more suitable photo.

    The problem is that after a photo is changed (overwritten) the "old" photo continues to display when viewed in browsers. My first thought is that my browser (Firefox) must be caching the older image. But this is not so because old photos show in "any" browser (IE, Firefox, Chrome). Also, matters not what computer I use to load the boat and photo... the "overwritten photo" continues to show up.

    Has anyone out there experienced this issue? Any suggestions on how to fix? It seems this must be an Alpha Server caching issue..

    Cheers,
    Steve

  2. #2
    "Certified" Alphaholic chadbrown's Avatar
    Real Name
    Chad Brown
    Join Date
    Aug 2007
    Location
    Aurora, Ontario, Canada
    Posts
    1,412

    Default Re: Annoying Image Caching Problem with Alpha Web Server

    Have you republished the photos?
    If you have your WAS restart everyday in the middle of the night it would help with any cache issues.
    Doesn't help with your problem during the day but it may help.
    Chad Brown

  3. #3
    "Certified" Alphaholic
    Real Name
    Rich Fulham
    Join Date
    May 2011
    Location
    Portland, OR
    Posts
    1,021

    Default Re: Annoying Image Caching Problem with Alpha Web Server

    I saw a suggestion once to create an a5w page that would be accessible to an administrator for clearing a5's cache on the server. The body of the a5w page would contain a code block with the following:
    <%a5
    Server.ClearAEXCache()
    ? "Server common code cache cleared."
    %>
    If "ClearAEXCache()" is does not clear the image cache then perhaps there is another similar command that will.

  4. #4
    Alpha Software Employee Lenny Forziati's Avatar
    Real Name
    Lenny Forziati
    Join Date
    Nov 2001
    Location
    Alpha Software
    Posts
    4,698

    Default Re: Annoying Image Caching Problem with Alpha Web Server

    Server.ClearAEXCache() is deprecated in V11 and does nothing. It would not be relevant in V10 either.

    If you have verified that the latest file is in fact published to the server, does restarting the Application Server then cause the correct file to be served?

    Lenny Forziati
    Vice President, Internet Products and Technical Services
    Alpha Software Corporation

  5. #5
    Member
    Real Name
    Steve Hood
    Join Date
    Dec 2007
    Posts
    19

    Default Re: Annoying Image Caching Problem with Alpha Web Server

    These photos do not get "published". They are FTP'd to a directory in the www folder. I have several data admins who update listing photos and we always FTP.

  6. #6
    Member
    Real Name
    Bob Alston
    Join Date
    Feb 2012
    Location
    Dallas
    Posts
    180

    Default Re: Annoying Image Caching Problem with Alpha Web Server

    OK but if you go to the folder where the server gets the photos, are they updated?

    Bob
    Bob Alston
    -------------------------------------------------------------------
    http://webpages.charter.net/bobalston/bob1.htm
    Alpha five v11 Tips

Similar Threads

  1. E-Mail button on web app caching the first result
    By cavj1 in forum Application Server Version 10 - Web/Browser Applications
    Replies: 2
    Last Post: 03-14-2012, 05:56 PM
  2. CSS caching problem
    By Sparticuz in forum Application Server Version 10 - Web/Browser Applications
    Replies: 7
    Last Post: 12-14-2009, 08:34 PM
  3. Annoying Refresh problem
    By gaby_h in forum Alpha Five Version 9 - Desktop Applications
    Replies: 1
    Last Post: 08-04-2009, 09:47 AM
  4. Annoying imbedded browse problem
    By brett s in forum Alpha Five Version 8
    Replies: 5
    Last Post: 02-15-2009, 12:45 AM
  5. Menu Forms - Annoying Problem
    By rtbtat in forum Alpha Five Version 5
    Replies: 14
    Last Post: 07-16-2003, 06:51 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •